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Overview
------------------------------------------------------------------------------------------------------------------------------------------------

4D Write 2004 provides sophisticated word processing and document management
functionality to 4D applications.

Word processing documents can be attached to any record in the database.

Even better, 4D Write documents can use data from 4th Dimension records. Reports
and letters can automatically extract information from the database and merge it with
text.

The purpose of this Technical Note is to cover the use of dynamic data in 4D Write.
Examples of how to insert 4D fields and expressions, use dynamic references, and
create tables in a 4D Write area are presented.

Getting Started
------------------------------------------------------------------------------------------------------------------------------------------------

In order to use 4D Write the 4D Write plug-in must be installed in the 4D database.
The next step is to add a 4D Write Plug-in area to an input form in Design mode. Then
switch to User mode and open a record to display the Input form and the 4D Write
area.

The next section covers using 4D fields and expressions in a 4D Write document.

Note that it may be easier to work in a larger 4D Write area. Clicking the Goto Full
Menu button in the 4D Write menu bar will expand the area.

Using 4D Fields and Expressions

4D fields and expressions can be inserted into a 4D Write document. Referenced data
can be displayed either as references or as actual values based on data from a 4th

Dimension database.

When fields and expressions are shown as references, they are displayed with a grey
background and surrounded by reference (<< >>) symbols.



The following figure shows some references in a form letter. The letter uses field
references for the person’s name and address and an expression for the date of the
letter.

When the references are converted to values, the values are displayed as regular text.

The values from field references and expressions always refer to the current record.
They are updated whenever the current record changes.



If there is no current record, the values are blank.

Inserting a 4th Dimension field in a 4D Write document

4D fields can be inserted in a 4D Write document. The field information displayed is
dynamic. A change in the information in the current record will be updated when
COMPUTE REFERENCES NOW is selected from the 4D Write Tools menu or when the
document is opened subsequently.

Data can be displayed and printed from the current record. When the 4D Write
document is displayed in an input form, the current record is the record being
displayed. When the document is displayed in an external window, the current record
is the record currently open on the screen.

A 4th Dimension field can be inserted using the Insert menu commands or the
contextual menu.

To insert a 4th Dimension field into a 4D Write document:

1. Click where the field will be inserted in the 4D Write area and choose the 4D
Expression… command in the Insert menu.
OR
Right click (Windows) or Control + click (Mac OS) where the field will be located
and choose the 4D Expression… command from the contextual menu.

The following box is displayed. The hierarchical list displays the names of the
database tables.

2. Expand the table in which the field is located.
3. Select the field by clicking it in the Field list.



The display formats that match the type of field selected are displayed in the
Format list.
To apply a display format to the field, select one from the Format area.
OR
Enter a new display format in the editing area located above the Cancel button.

4. Click OK.

The field is added to the 4D Write document.

Using Dynamic Field References

4D Write allows the use of dynamic references in 4D Write documents. Dynamic
references are objects whose content is calculated at the moment of their insertion,
update, or if they simply provoke a certain action.

For example, 4D Write allows the insertion of standard references, such as the current
date and time or the page number.

Dynamic references can also be information coming from a 4th Dimension database.
For example, a standard letter can be created that is personalized for each person
registered in the database. To do this, simply reference the fields from the database
into the document.

4th Dimension and 4D Write interactions are not limited just to fields though. 4D
expressions can be used to complete complex tasks such as calculating totals or text
concatenation. For example, calculating and inserting an employee’s annual salary
into a document.

Showing References or Values

When inserting a 4th Dimension expression, 4D Write displays the current value of the
expression. Field and expression references can also be displayed in 4D Write. The
field or expression references (surrounded by <<>> characters) that are inserted
then appear in the document.

The following table recapitulates the displayed information in terms of the type of
dynamic reference and the selected display mode:

Dynamic Data Type Displaying Values Displaying References
Date and time Value at moment of insertion “Date and time” label1
Numbers and page numbers Value at moment of insertion “Page number” and “Number of

pages” labels2
4D fields Field value in current record Field name
4D expressions Result of expression Expression code

To switch between displaying references or values in a 4D Write document:



1. In the 4D Write menu bar, choose References from the View menu.
2. A check mark appears next to References when references are shown.

Freezing References

The values any references refer to can be “frozen”. Freezing references converts their
currently displayed values to regular text and removes the associated references.
This enables a permanent record to be kept in a document or portion of a document
created. For example, freezing a report containing financial data so that any further
modifications to the data do not impact the report.

To freeze the references:
1. Select the reference(s) to freeze.
2. Choose the Freeze Selection command in the Tools menu from the 4D Write

menu bar.
All selected references in the selection are frozen.

OR
1. Choose the Freeze Document command in the Tools menu in 4D Write

(without selecting the reference).
In this case, all references contained within the document are frozen.

Computing References

Fields or expression references in a 4D Write document are automatically computed
when:

• The reference is inserted in the document
• The document is loaded or opened

Note: Only “Page number” and “Total number of pages” type references are
automatically updated.

Consequently, the computation of references must be forced each time when viewing
or printing the document their new values during the working session.

To force the computation of the references:
1. Choose Compute References Now from the Tools menu from the 4D Write

menu bar.
2. The values of the references are instantaneously updated.

Viewing field values

To view the field values, show use the following instructions. Remember that
displaying values does not compute references.

1. Select View in the 4D Write menu bar.
2. Select References from the menu and the checkmark will be cleared.



Modifying Field References

Field references can be modified at any time regardless of whether the values or the
references are displayed. The field can be replaced by another field or by an
expression, or the display format can be changed.

To change the field reference:

1. Double-click the field reference
2. The Insert 4D Expression dialog box is displayed, enabling changes to the field

reference.

Inserting a 4D Expression

The following 4D expressions can be inserted in a 4D Write document:

• 4th Dimension variables
• Formulas
• Certain 4th Dimension functions
• Project methods (under certain conditions)
• Plug-in functions (through project methods)

Only project methods that are explicitly authorized by the 4D developer using the SET
ALLOWED METHODS command can be inserted in a 4D Write document when using
4D 2004.3 and earlier versions. The user can access 4D Write commands (for
example, WR Count) or 4D commands that cannot be accessed by default by having
the designer create and authorize project method that specifically calls these
commands. An example is shown below.

`Executed method
Array text(methodarray;3)
methodarray{1}:=”Calculate”
methodarray{2}:=”Compute”
methodarray{3}:=”Generate”
Set allowed methods(methodarray)

When using 4D 2004.4, all commands can be temporarily enabled in the Formula
editor.

1. Open Preferences
2. Select the Application theme
3. Enable the “Always allow all commands and project methods in the Formula

editor” option.

Remember to disable this option when done so that only authorized project methods
may be used in the Formula editor again.



Inserting expressions allows the use of 4th Dimension’s procedural language within 4D
Write documents to perform calculations, concatenate information from several fields,
and so forth.

The following are examples of expressions:
Expression Comment
MyVar A 4th Dimension variable
Current time A 4th Dimension function
Current date-vDate A statement that performs a calculation
Salutation A project method that returns a value

(must have been explicitly authorized)

After creating customized expressions, use the following instructions to insert
expressions using methods that activated with the SET ALLOWED METHODS
command.

To insert an expression:

1. Click where the expression will be located in the 4D Write area.
The insertion point should now be blinking.

2. Choose 4D Expression… from the Insert menu.
A dialog box is displayed, listing the database tables by default.

3. Click the Expression tab.

4. Click the Edit… button
The 4D Formula Editor is then displayed.

5. Custom methods are added at the bottom of the commands list window. This
editor displays a list of the database fields, a list of operators and a list of 4D
commands authorized by default in formulas.

6. Enter the formula or 4D variable to be inserted
To reference a variable, simply enter its name in the entry area. Warning: In
order for a 4D variable to be inserted into the document, it must already exist
in the current process.

7. -Click OK to validate the expression.

Using Tables in a 4D Write Area
------------------------------------------------------------------------------------------------------------------------------------------------

4D Write allows information to be displayed as tables in a 4D Write area. It is possible
to fill the table’s columns with fields from a 4D table. Also, a row of predefined values
can be added to label the columns instead of needing to typing them out. The
following sections will first show how to fill the columns with data and the second



section will show how to add a row. The last section will show how to combine the
columns and row to create a table.

Insert a 4D field as an automatic column value

This feature lets a table column be filled with data from a 4D field. Simply select a
field and 4D Write will populate the column with values from a table field in 4D.
Choose multiple 4D fields to fill multiple columns in a table within the 4D Write area.
Caution should be taken when querying because querying on one field will
automatically resize the entire table.

To insert a 4D field as an automatic column value

1. Select Table Wizard… from the Tools menu
The Table Wizard is then displayed

2. Click on the Columns tab control.
The Column page is displayed

3. In the Style for drop-down list, select the column in where the 4D field will
appear.

4. Choose “4D Field” in the Value area
5. Click the Field selection button … .

On the Field page, select the field that will be inserted. In the Format area,
select one of the predefined display formats or define a specific display format.

6. Expand the hierarchical list of the table that contains the field to insert.

7. Double-click on the field to be inserted as a value.

The numbers of selected records for that table is displayed at the bottom of the
Value area. For each record, the value of the record will be displayed in a row.

8. To select specific records, click the Find… button.

The Query editor is then displayed. Edit the query as in 4D.
Once done executing the query and if the number of records matches the size
of the table, the Column page is displayed again and the number of records is
modified accordingly. If the number does not match the array, a choice is
given.
Clicking the Leave Unchanged button will cause the Column page to display
again and the size of the table remains unchanged. Clicking the Resize button
will display the Column page again with the number of rows modified to match
the number of records.

9. To modify the sort order, click the Sort… button.

The 4D Order by dialog box is then displayed.
Define the sort order and set the sequence of values in the table.



10. Once done defining the selection and sorting it, the insertion of 4D fields as
values is complete.

The table can be improved by adding a label as described in the next section.

Insert a Predefined Value as an Automatic Row Value

This feature allows the insertion of data such as the day of the week, the month,
numbers or letters across the column headers. These predefined values are chosen
from a dropdown list. The Table Wizard is needed to create a table with these rows.

To insert a predefined value as an automatic row value:

1. Select Table Wizard… from the Tools menu.
The Table Wizard is then displayed.

2. Click on the Rows tab control.
The Rows page is displayed.

3. In the Style for drop-down list, select the row type in which the predefined
values will appear.

4. Choose Predefined in the Values area.
5. Select the type of predefined value from the Values drop-down list.
6. Select the Start Value.

The Start Value is always a number but it will apply to any kind of selected
value. For example, entering 2 as a start value and selecting the month value,
the first value displayed will be February.

7. Once done with the Predefined value settings, proceed with the remainder of
the table configuration.

Creating a Table

Before creating a table, check that the element to be entered in the table will fit in the
columns. Since 4D Write does not manage the concept of cells, make sure that the
columns are large enough to contain data

To create a table:

1. Select Table Wizard… from the Tools menu in the 4D Write area.
The Table Wizard is then displayed.

2. On the Template page, select the template by selecting it from the Table Type
drop-down menu.

3. Enter the number of rows and columns in the Rows and Columns boxes.
4. Optionally, define a global character format for the table in the Text Format

area.
5. Click on the Columns tab control to set the column options.

The columns page is then displayed.



6. Using the Style for drop-down list, select the column to modify.
7. For the current column, choose either predefined values or a 4D field as

automatic values.
8. In the Format area, set the alignment, format and width of the current column.
9. Repeat steps 6 through 8 for each column to configure.

10. Click on the Rows tab control to set the row options.
11. Using the Style for drop-down list, select the type of row to modify.
12. For the current type of row, set predefined values as automatic values.
13. In the Format area, set the border, formats and line spacing of the current row.
14. Using the Back and Row picture menus, select a color for the line and for the

background of the selected type of rows.
15. Click OK to create the table.

Because 4D Write does not manage cells in tables as rows and columns, once a table
is created it is usually easier to create it again rather than modify it.

Conclusion
------------------------------------------------------------------------------------------------------------------------------------------------

Using dynamic data in a 4D Write document is easy. This Technical Note covered the
use of dynamic data in 4D Write. Examples of how to insert 4D fields and expressions,
use dynamic references, and create tables in a 4D Write area were presented.

Keep these tips in mind when using dynamic data in 4D Write:

• 4D fields and expression can be viewed as actual values or references.
• Although the values are dynamic, keep in mind that when a change is made in

the current record the COMPUTE REFERENCES NOW command needs to be
executed in order to update the 4D Write document.

• In order to execute project methods in the Formula editor, the project method
must be enabled with the SET ALLOWED METHODS command.

• It is easier to create a new table rather than modify an existing one.


