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Preface

4D Write is a plug-in that extends word-processing capabilities to your 
4th Dimension databases. It is one of several plug-ins that, together 
with 4th Dimension, form the 4th Dimension environment.

About this Manual
This manual introduces 4D Write and describes how to create and use 
4D Write documents in 4th Dimension. It explains how to use 
4D Write to create letters, memos, and other documents. It explains 
how to enter and edit text in these documents and how to use these 
documents in conjunction with data in your database and in other 
plug-ins.

Cross-Platform 
Considerations

This manual explains how to use 4D Write on both the Windows and 
Mac OS platforms. Although the concepts and functionality of both 
versions are nearly identical, the manual addresses any differences 
where necessary. Such differences may include the graphical user 
interface and/or keyboard commands.

The graphics in this manual illustrate 4D Write in the Windows 
environment. Both versions of the same screen are only presented 
when there are major differences between them.

Hypertext 
Navigation

If you are reading this manual in electronic format (Adobe™ Acrobat 
PDF), you can take advantage of the hypertext links that it contains. 
Each word that appears in blue has a hypertext link. However, text in 
the “Table of Contents” and “Index” is not in blue, but each entry has 
a built-in hypertext link.
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When you click a hypertext link, you immediately move to the page 
that contains more information. To return to your original page, click 
the Previous page button .

You can also navigate the document by clicking the bookmarks, which 
are located to the left of the window that displays the manual pages.

Chapter 
Descriptions

This manual is divided into the following chapters:

■ Chapter 1, “Introduction,” provides an overview of 4D Write.

■ Chapter 2, “Interface,” provides a detailed description of the 4D Write 
interface.

■ Chapter 3, “Managing 4D Write Documents,” explains how to create 
and open 4D Write documents within your database and in external 
windows.

■ Chapter 4, “Entering and Editing Text,” describes how to perform basic 
text operations in 4D Write document windows.

■ Chapter 5, “Formatting Text,” shows how to customize the appearance 
of 4D Write documents. 

■ Chapter 6, “Working With Pictures,” describes the 4D Write built-in 
features for managing pictures. 

■ Chapter 7, “Using Dynamic References,” explains how to use 
information from your 4th Dimension database in 4D Write 
documents.

■ Chapter 8, “Printing,” describes how to print 4D Write documents.

■ Appendix A, “4D Write Shortcuts”, describes various keyboard 
shortcuts.

Conventions This manual uses certain conventions to help you understand the 
material.

The following explanatory notes are used:

Note Text emphasized like this provides annotations and shortcuts that will 
help you use 4th Dimension more productively.
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4D Server Throughout the manual, 4th Dimension and 4D Server/4D Client are 
referred to simply as 4th Dimension. Differences between the operation 
of the two products are explained in 4D Server notes, which provide 
information about using 4D Server/4D Client. This information is 
provided only when the operation of 4D Server/4D Client differs from 
that of 4th Dimension.

Notes like this alert you to important pieces of information and to sit-
uations where data might be lost.

In addition, all table names are shown in brackets in the text to help 
distinguish them from the names of fields, forms, and other items. For 
instance, the Companies table is written as the [Companies] table.
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1 Introduction

This chapter provides basic information about 4D Write. It includes 
the following:

■ An overview of 4D Write’s capabilities

■ Integration with 4th Dimension

Overview
The 4D Write plug-in extends word-processing capabilities to your 
4th Dimension databases. It is one of several plug-ins that, together 
with 4th Dimension, form the 4th Dimension environment. 4D Write 
allows you to include documents such as letters, reports, memos, and 
notes in your 4th Dimension forms. When used in a form, a 4D Write 
area appears as part of your data, just like a name or any other piece of 
information.

You can also treat 4D Write as a separate application by using it in 
external windows. Your work within these windows can be 
independent of your database or linked to information in your 
database or in other plug-ins.
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Integration with 4th Dimension

4D Write with a 
4th Dimension 
Database

4D Write offers more than the typical word-processing features. As part 
of the 4th Dimension environment, 4D Write operates in conjunction 
with 4th Dimension databases.

4D Write enables you to attach word-processing documents to each 
record in your database. The following figure shows a letter attached to 
a record of the Correspondence table.

Text is typed directly in the document and is saved with the record, 
like any other field entry.

4D Write documents can also use data from 4th Dimension records. 
You can write reports and letters that automatically import or extract 
information from the database. For example, the letter shown in the 
above figure draws the person’s name and address from the record to 
which it is attached.
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4D Write as an 
Independent 
Application

You can also use 4D Write in an external window as a stand-alone 
application with special access to the 4th Dimension database.

The following figure shows a promotional letter that includes fields 
from a 4th Dimension database.

Field references 
in text
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2 Interface

Introduction
4D Write can either be used in an included area or in an external win-
dow. Whichever you choose, the interface elements remain identical. 
The purpose of this chapter is to describe the 4D Write interface and to 
explain how it allows you to access the 4D Write features.

Note In this chapter, we will usually use the term window to designate 
either a 4D Write area or a 4D Write window. When necessary, the 
distinction will be made explicitly.
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The 4D Write Window
The 4D Write window appears as follows:

The 4D Write window consists primarily of the following elements:

■ A text area, which you can divide;

■ A menu bar, located at the top of the 4D Write window;

■ Four toolbars, located below the menu bar;

■ A horizontal ruler, located above the text area;

■ A status bar, located at the bottom of the window; and

■ Two scroll bars and two splitters.

Menu Bar

Toolbars

Ruler

Text area

Status Bar

 

Splitter

Splitter

Vertical scrollbar

Horizontal scrollbar

Help tip
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Splitting the 
4D Write Window

4D Write allows you to split the text area into several panes. Dividing 
the text area into panes enables separate scrolling of each part of the 
document. The document area can be divided both horizontally and 
vertically. Splitting the document area is useful when you want to 
simultaneously enter, modify or compare text located in different 
places in the document.

Splitting the document area vertically allows you to display several 
areas of the current document side by side.

❿❿❿❿ To split a window vertically:

1 In the 4D Write window, move the cursor over the split box located to 
the left of the horizontal scroll bar.
The cursor becomes a split indicator.

2 Drag the split indicator to where you want to position the border of 
the new pane.
You will now have two independent sub-windows:

❿❿❿❿ To split a window horizontally:

1 In the 4D Write window, move the cursor over the split box located 
above the vertical scroll bar.
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The cursor becomes a split indicator.

2 Drag the split indicator to where you want to position the border of 
the new pane.
You will now have two independent sub-windows.

You can easily combine two different kinds of divisions - vertical and 
horizontal:

Of course, any changes made in one sub-window are immediately 
reflected in the others.

❿❿❿❿ To remove a pane:

1 Move the cursor over the border of the pane you want to delete.
The cursor becomes a split indicator.

2 Double-click on the border.
OR
Drag the line to the starting point of the sub-window in order to close 
it.
The pane disappears.
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❿❿❿❿ To move the border between two panes:

1 Move the cursor over the border that you want to move.
The cursor becomes a split indicator.

2 Drag the border to its new location.

❿❿❿❿ To move the insertion point into a particular pane:

1 Click or drag in the pane to locate the insertion point or make a 
selection, just as you would normally.
Note that only one pane will show the current selection or insertion 
point at a time. Any keys which would normally scroll the window or 
change the insertion point or the selection will only affect the view or 
the selection in that pane, until you click or make a selection in a 
different pane.

The Menu Bar and 
the Toolbars

The menu bar is displayed at the top of the 4D Write window:

There are four toolbars in 4D Write:

These toolbars are designed to provide quick access to certain features 
that would otherwise require the use of menu commands. For more 
information on the functions of these toolbars, refer to “4D Write 
Toolbars” on page 52.

Moving the Menu Bar or 
a Toolbar

The 4D Write menu bar as well as the toolbars can be moved to any 
side of the 4D Write window. They can also be displayed as floating 
palettes when located above the text area or outside the 4D Write 
Window.

❿❿❿❿ To move the 4D Write menu bar or a tool bar:

1 Place the mouse cursor above the handle located to the left of the 
menu or tool bar.
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2 Click and hold down the left mouse button.
The cursor becomes a cross and you can drag the menu bar.

3 Drag the bar to another location in the upper part of the window.
OR
Drag the bar to the left, right or bottom edge of the editing area . 
OR
Move the bar over the text area or outside the 4D Write window.

4 Release the mouse button.

■ If you have moved the bar in the upper part of the 4D Write win-
dow, it appears at its new location.

■ If you have moved the bar to the left, right, or bottom edge, it 
appears attached to that side of the window.

■ If you have moved the bar to the text area or outside the 4D Write 
window, it is then displayed as a palette:

Note If you close the Menu bar palette, you will need to use the following 
key combination to display the menu bar again:
Ctrl+Shift+M on Windows
Cmd+Shift+M on Mac OS

Toolbars placed 
in the window 
frame
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The Ruler The ruler displays the position and type of tab stops, the position of 
margins and the position of the first line indent. The ruler consists of 
two main parts:

■ The ruler itself:

This part displays the location and type of tab stops as well as the 
location of the margins.

■ A pop-up menu is located at the left end of the ruler.

This menu allows you to select the type of tab to set when you click in 
the ruler.

For more information about how to use the ruler, refer to “Setting 
Tabs” on page 118.

The Status Bar The status bar is located at the bottom of the 4D Write window. It 
displays, from left to right: the current page number; the total number 
of pages in the document; the line and column number of the cursor 
location; and the status of the CAPS LOCK and NUM LOCK keys. It 
also displays a progress bar when a time-consuming operation is being 
executed.

The 4D Write Menus
4D Write has nine menus, as well as a contextual menu which is avail-
able at all times:

■ The File menu
This menu is used for printing, for managing files and to access prefer-
ences.

First Line Indent 
marker

Left Margin marker

Tab Stop 
marker

Right 
Margin marker
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■ The Edit menu
This menu is used to access standard features such as Cut/Paste, undo 
or re-do operations and to access Find/Replace features. It also allows 
you to modify the character case and to select the whole document.

■ The View menu
This menu is used to choose how the document is displayed.

■ The Insert menu
This menu is used to insert variables (date and time, page number), 
pictures, page breaks, columns, tables and 4D expressions.

■ The Style menu
This menu is used to define the style and case attributes of the selected 
text.

■ The Colors menu
This menu is used to select a color for characters or style attributes.

■ The Paragraph menu
This menu allows you to define the line spacing and the justification 
of the currently selected paragraph or paragraphs. It also allows you to 
select and insert bullets, and to copy/paste the ruler.

■ The Format menu
This menu provides access to the format dialogs for style sheets, char-
acters, paragraphs, tab stops, borders and columns.

■ The Tools menu
This menu lets you display the table wizard, check the spelling, display 
and edit the document information (title, subject, author and notes) 
and display document statistics (word count, number of characters, 
paragraphs and so on). It also allows you to update or freeze 4D refer-
ences in the document.

■ The contextual menu
This menu can be used to access different actions depending on where 
you click.
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The File Menu The File menu allows you to access the standard file management 
features, the printing features and the preferences:

■ New
Selecting this command displays a new blank document in the text 
area. If the document on which you are working is not saved, a dialog 
box appears to give you the option of saving that document first.

■ Open
Selecting the Open menu command opens the standard Open file 
dialog box that corresponds to the platform you are working on.

■ Save
Selecting the Save menu command saves the current document at its 
current location. If the document on which you are working is a new 
document, selecting the Save menu command has the same effect as 
selecting the Save as... menu command.

■ Save as...
Selecting the Save as... menu command displays the standard Save file 
dialog box of the operating system.
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■ Preferences...
Selecting the Preferences... menu command displays the Document 
Preferences dialog box:

This dialog box lets you set document preferences, such as ruler units, 
header and footer options, binding options, widow and orphan 
control and the spellchecking mode. For more information on how to 
use this dialog box, refer to “Setting Preferences” on page 78.

■ Page Setup...
Selecting the Page Setup... menu command displays the Page Setup 
dialog of the current printer.
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■ Print Preview
Selecting the Print Preview menu command displays the print preview 
window:

The Print Preview window displays the pages of the document as it will 
be printed. It also allows you to start or cancel the printing. For more 
information about this window, refer to “Previewing the Document” 
on page 206.

■ Print...
Selecting the Print... menu command displays the Print dialog box for 
the current printer.
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■ Print merge...
Selecting the Print merge... menu command displays the Print Mailing 
dialog box:

This dialog allows you to choose a selection of records for each of 
which a version of the current document will be printed. For more 
information about how to use this dialog box, refer to “Printing a 
Merge Document” on page 204.

■ Goto Full Window
This command expands the 4D Write window to full-screen size 
(Mac OS) or to the size of the application window (Windows). The 4D 
Write menu bar temporarily replaces the 4th Dimension menu bar.

The Edit Menu The Edit menu allows you to:

■ Copy/Paste text and pictures,

■ Cancel or repeat the last operation executed by the program,

■ Find and replace formatting or text,

■ Select all of the text (including the pictures that are in the text flow),

■ Modify the character case for the current selection,

■ Display the current selection,

■ Go to a specific page.
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The Edit menu offers the following commands:

■ Undo
Selecting the Undo menu command reverses the last action taken by 
the user. If the last action cannot be undone, the command menu is 
dimmed and its title becomes Cannot Undo.

■ Redo
Selecting the Redo menu command repeats the last action cancelled by 
the user. If the last action cannot be repeated, the menu command is 
dimmed and its title becomes Cannot Redo.

■ Cut
Selecting the Cut menu command removes the current selection and 
places it in the clipboard.

■ Copy
Selecting the Copy menu command copies the current selection and 
places it in the clipboard.

■ Paste
Selecting the Paste menu command inserts a copy of the contents of 
the clipboard at the location of the insertion point, or replaces a selec-
tion with the contents of the clipboard if anything is selected.

Note If the contents of the clipboard is a picture, 4D displays the Paste 
Picture... dialog box. This dialog box allows you to set where the 
picture will be pasted (floating or within the text, for example). For 
more information, refer to “Inserting a Picture in the Text or in the 
Page” on page 170.

■ Delete
Selecting the Delete menu command deletes the current selection.
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■ Select All
Selecting the Select All menu command selects all the elements present 
in the area being edited (characters, tables and pictures).

Note If Page View mode is selected, and the cursor is located in either the 
header or footer area, only the contents of that area will be selected.

■ Find...
Selecting the Find... menu command displays the Find dialog box:

The Find dialog box is used to define character, style, border or format 
searches. For more information on how to use this dialog box, refer to 
“Finding Text” on page 93.

■ Find Next
Selecting the Find Next menu command triggers a search based on the 
last character or format search you performed.
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■ Replace...
Selecting the Replace... menu command displays the Replace dialog 
box:

This dialog box allows you to define searches in the same way the Find 
dialog box does. It also allows you to define a character string that will 
replace the string you searched for. Replacements are not limited to 
characters and can be extended to character, paragraph, border and 
style formats. For more information about replacing characters, refer to 
“Finding and Replacing Sequences of Characters” on page 104.

■ Replace Next
Selecting the Replace Next menu command triggers a search based on 
the last character or format search you performed, followed by a 
replacement identical to the last replacement executed.

■ Change Case
Selecting the Change Case menu command displays a submenu:

This submenu allows you to modify that character case of the current 
selection.

■ lower case converts the selected text to lower case.

■ UPPER CASE converts the selected text to upper case.
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■ Title Case converts the first letter of each word in the selection to 
upper case.

■ tOGGLE CASE converts all upper case letters in the selection to 
lower case and vice-versa.

■ Show Selection
Selecting the Show Selection menu command scrolls the document in 
order to display either the insertion point or the current selection. If 
either is already displayed, this command has no effect.

■ Goto Page...
Selecting the Goto Page... menu command displays the Goto Page 
dialog box:

For more information about this dialog box, refer to “Going to a 
Specified Page” on page 86
Once you have entered a page number, clicking OK displays the 
corresponding page.

The View Menu The View menu allows you to:

■ Select Page View mode.

■ Select the elements that you want to display in the 4D Write window 
(toolbar, rulers, headers, footers, 4D references, pictures, invisible char-
acters, frames, menu bar and status bar).

The menu commands of the View menu are the following:

■ Normal
Selecting the Normal menu command displays the document as an 
uninterrupted series of paragraphs without headers or footers. When 
this mode is selected, a check mark is displayed next to the Normal 
menu command. Selecting this option unchecks the Page menu com-
mand.
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■ Page
Selecting the Page menu command displays the document as a succes-
sion of separate pages, with header and footer areas. When this mode 
is selected, a check mark is displayed next to the Page menu com-
mand. Selecting this option unchecks the Normal menu command.

■ Toolbars
Selecting the Toolbars menu command displays a submenu:

In this submenu, toolbars whose names are preceded by a check mark 
are displayed. When there is a check mark next to it, selecting the 
name of a toolbar hides the corresponding toolbar. When there is no 
check mark next to it, selecting the name of a toolbar displays the cor-
responding toolbar.

■ Rulers
Selecting the Rulers menu command can either hide or display the rul-
ers. When rulers are displayed, a check mark is displayed next to the 
Rulers menu command. 

Note When the Page mode is selected, both horizontal and vertical rulers 
are displayed. When the Normal mode is selected, only the horizontal 
ruler is displayed. The Rulers menu command only affects the rulers 
that are displayed by the current view mode.

■ Header
When in Page mode, selecting the Header menu command displays 
the document’s header area. The header area is displayed in a separate 
area located at the top of the current page. When the Normal mode is 
selected, this command is disabled since the Normal mode cannot dis-
play the header area.

■ Footer
When in Page mode, selecting the Footer menu command displays 
the document’s footer area. The footer area is displayed in a separate 
area located at the bottom of the current page. When the Normal 
mode is selected, this command is disabled since the Normal mode 
cannot display the Footer area.

Note For more information, refer to “Creating Headers and Footers” on 
page 112.
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■ References
Selecting this command displays the values of the references. When a 
check mark appears before the References menu command, references 
are displayed; otherwise the computed values of references are dis-
played.

Note For more information about displaying values or references, refer to 
“Showing References or Values” on page 198.

■ Pictures
When a check mark is displayed next to the Pictures menu command, 
4D Write displays the pictures. When no check mark is displayed next 
to the Pictures menu command, 4D Write displays frames instead of 
pictures. This makes the display faster.

Note This menu command also affects the printing and displaying of 
pictures. For more information, refer to “Working with Pictures” on 
page 169.

■ Invisible Characters
When a check mark is displayed next to the Invisible Characters menu 
command, 4D Write displays invisible characters. Selecting this menu 
item when it is checked un-checks it, and vice-versa.

Note For more information, refer to “Showing Invisible Formatting 
Characters” on page 129.

■ Margins
This menu command is only accessible when Page mode is selected. In 
this case, selecting the Margins menu command displays or hides the 
margins of the document. When margins are displayed, a check mark 
is displayed next to the Margins menu command.

■ Horizontal Scrollbars
Selecting Horizontal Scrollbars displays or hides the horizontal scroll-
bar. When the horizontal scrollbar is displayed, a check mark is dis-
played next to the Horizontal Scrollbars menu command.

■ Vertical Scrollbars
Selecting Vertical Scrollbars displays or hide the vertical scrollbar. 
When the vertical scrollbar is displayed, a check mark is displayed next 
to the Vertical Scrollbars menu command.
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■ Menu Bar
Selecting Menu Bar displays or hides the menu bar. When the menu 
bar is displayed, a check mark is displayed next to the Menu Bar menu 
command. When the menu bar is hidden, you can display it again by 
pressing the following combinations of keys: Ctrl+Shift+M (Windows) 
or Command+Shift+M (Mac OS).

Note For more information, refer to “The Menu Bar and the Toolbars” on 
page 21. 

■ Status Bar
Selecting Status Bar displays or hides the status bar. When the status 
bar is displayed, a check mark is displayed next to the Status Bar menu 
command.

The Insert Menu The Insert menu allows you to insert variables (date and time, page 
number), pictures, page breaks, column breaks, HTML expressions, 
hypertext, and 4D expressions. If the insertion point is located in the 
text, the element is inserted at the insertion point; otherwise it replaces 
the current selection.

The Insert menu includes the following menu commands:
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■ Date and Time...
Selecting the Date and Time... menu command displays the Insert Date 
dialog box.

This dialog box lets you select the current date, the current time, or 
both as well as their display formats. For more information about this, 
refer to “Inserting the Date and Time” on page 182.

■ Page Number...
Selecting the Page Number... menu command displays the Insert Page 
Number dialog box.

Once the type and format are selected, clicking OK inserts the page 
number or the number of pages at the location of the insertion point. 
For more information, refer to “Inserting the Page Number or the 
Number of Pages” on page 183.
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■ Special Character...
Selecting Special Character... displays the Select Special Character dia-
log box:

This dialog box allows you to pick a specific character while viewing it 
beforehand. For more information, refer to “Inserting a Special Charac-
ter” on page 92.

■ Soft Hyphen
Selecting the Soft Hyphen menu command inserts a hyphen at the cur-
sor location. For more information, refer to “Inserting and Removing 
Hyphens” on page 91.

■ Non Breaking Space
Selecting the Non Breaking Space menu command inserts a non break-
ing space at the insertion point. For more information, refer to “Insert-
ing a Non-Breaking Space” on page 92.

■ Column Break
Selecting the Column Break menu command inserts a column break at 
the insertion point. For more information, refer to “Managing Column 
Breaks” on page 166.

■ Page Break
Selecting Page Break inserts a page break at the insertion point. For 
more information, refer to “Creating a Page Break” on page 167.
374D Write User Reference Manual



Chapter 2  Interface
■ HTML Expression...
Selecting HTML Expression... displays the HTML Expression dialog 
box: 

This dialog box allows you to insert all types of HTML expressions 
(URLs, style tags, photos, etc.) where the cursor is located. For more 
information, refer to the chapter “Using Dynamic References” on 
page 181.

■ Hyperlink...
Selecting Hyperlink... displays the following dialog box:

This dialog box allows you to insert various types of hypertext links
into your 4D Write documents. For more information, refer to the 
chapter “Using Dynamic References” on page 181.
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■ 4D Expression
Selecting the 4D Expression menu command displays the Insert 4D 
Expression dialog box:

This dialog box allows you to select a field or to define a 4D expression. 
For more information about this dialog box, refer to “Referencing 4D 
Fields and Expressions” on page 185.

The Style Menu The Style menu allows you to modify style attributes for the current 
selection. Style attributes can be combined by selecting styles 
sequentially.

■ Plain
Selecting the Plain menu command allows you clear all the style 
attributes that may have been applied to the current selection. Case, 
font, size and color attributes are not affected by this function.

■ Bold
Selecting the Bold menu command applies the bold style to the cur-
rent selection.
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■ Italic
Selecting the Italic menu command applies the italic style to the cur-
rent selection.

■ Shadow
Selecting the Shadow menu command applies the shadowed style to 
the current selection. This style is not the standard Mac OS Shadow 
effect, but an attribute defined by 4D Write. This makes the attribute 
available on both Windows and Mac OS platforms.

■ Strikethrough
Selecting the Strikethrough menu command scores out the current 
selection.

■ Underline
Selecting the Underline command menu displays a submenu that 
allows you to choose a type of underline.

■ No underline removes any underlining applied to the current selec-
tion.

■ Single underline underlines the selection with a single stroke.

■ Word underline underlines only the individual words of the selec-
tion with a single stroke.

■ Double underline underlines the current selection with a double 
line.

■ Hatched underline underlines the current selection with a dotted 
line.

■ Superscript
Selecting Superscript applies the superscript attribute to the current 
selection.

■ Subscript
Selecting Subscript applies the subscript attribute to the current selec-
tion.

■ Capitals
Selecting Capitals displays the characters in the current selection in 
upper case (the case in which the text was typed is still stored but not 
shown).
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■ Small Capitals
Selecting Small Capitals displays the current selection, using uppercase 
characters of the next lower size to display text entered in lower case.

Note Please note that, during a character search, a small capitals character is 
not considered as an uppercase character. In other words, an “a” 
character will be displayed as “A” if you select the small capitals style 
attribute. It will however be returned by a search for the “a” character. 
For more information, refer to “Changing Text Attributes” on 
page 131. 

The Colors Menu The Colors menu will allow you to modify color attributes of the 
selected elements.

For a selected piece of text, the elements for which you can set the 
color are the following:

■ Characters

■ Character background

■ Stroke of the Strikethrough effect

■ Line that underlines a piece of text

■ Shadow for the Shadowed effect

■ Paragraph background

■ Text borders

The menu commands of the Colors menus and their effects are the fol-
lowing:

■ Text
Selecting the Text menu command displays a color submenu. The 
color selected using this submenu will be applied to the current text 
selection.
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■ Back
Selecting the Back menu command displays a color submenu. The 
color selected using this submenu will be applied to the background of 
the current text selection.

■ Strikethrough
Selecting the Strikethrough menu command displays a color submenu. 
If the Strikethrough style is selected for the current selection, the 
selected color will apply to the stroke of the Strikethrough effect. If the 
Strikethrough style is not selected for the current selection, the 
selected color will be stored and will appear if the Strikethrough style is 
selected at a later time.

■ Underline
Selecting the Underline menu command displays a color submenu. If 
the Underline style is selected for the current selection, the selected 
color will apply to the line of the Underline effect. If the Underline 
style is not selected for the current selection, the selected color will be 
stored and will appear if the Underline style is selected at a later time.

■ Shadow
Selecting the Shadow menu command displays a color submenu. If the 
Shadow style is selected for the current selection, the selected color 
will apply to the shadow of the Shadow effect. If the Shadow style is 
not selected for the current selection, the selected color will be stored 
and will appear if the Shadow style is selected at a later time.

■ Borders Back
Selecting the Borders Back menu command displays a color submenu. 
The selected color will apply to the background of all the paragraphs of 
the current selection.

■ Borders Line
Selecting the Borders Line menu command displays a color submenu. 
If borders are selected for the current selection, the selected color will 
apply to those borders. If no borders are selected for the current selec-
tion, the selected color will be stored and will appear if borders are 
selected at a later time.

Note For more information, refer to “Setting Colors” on page 126. 
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The Paragraph 
Menu

The Paragraph menu allows you to modify the following settings for 
the selected paragraphs:

■ Whether or not the paragraph has a bullet, as well as the character 
used for the bullet,

■ The alignment,

■ The line spacing.

It also allows you to copy the contents of the ruler for a paragraph and 
apply it to other paragraphs.

The commands of the Paragraph menu are the following:

■ Copy Ruler
Selecting the Copy Ruler menu command copies the current settings of 
the ruler. The copied settings are the following: tab type and location, 
first line indent, and margin settings as well as all the paragraph 
attributes.

Note If you select several paragraphs, the ruler can only be copied if it is 
identically defined for each of those paragraphs.

■ Paste Ruler
Selecting Paste Ruler pastes the ruler that was copied previously onto 
the clipboard using the Copy Ruler menu command. The pasted infor-
mation concerns the type and location of tabs as well as all paragraph 
attributes (alignment, line spacing, margins, borders).

Note For more information, refer to “The Ruler” on page 113.
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■ Bullets
Selecting the Bullets menu command displays the following submenu:

This submenu allows you to select a specific type of bullet for the para-
graphs of the current selection. The selected bullet will appear at the 
beginning of the first line of the paragraph. If you select the Other sub-
menu command, the Select Special Character dialog box is displayed1.

For more information on the use of the Select Special Character dialog 
box, refer to “Setting Bullets” on page 122.

Note Only the default bullets share the same appearance on both Windows 
and Mac OS platforms.

■ Align Left
Selecting the Align Left menu command aligns the paragraphs in the 
selection with their left margins.

■ Align Center
Selecting the Align Center menu command centers all the paragraphs 
of the selection between their margins.

1. The standard fonts Zapf Dingbats (Mac OS) and Windings (Windows) must 
be installed on the machine.
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■ Align Right
Selecting the Align Right menu command aligns the paragraphs in the 
selection with their right margins.

■ Full Justification
Selecting the Full Justification menu command fully justifies all para-
graphs of the selection between their margins.

■ Single Spaced
Selecting the Single Spaced menu command applies the default line 
spacing to all the paragraphs of the selection.

■ 1.5 Line Space
Selecting the 1.5 Line Space menu command applies a line spacing of 
one and a half lines to all the paragraphs of the selection.

■ Double Spaced
Selecting the Double Spaced menu command applies a line spacing of 
two lines to all the paragraphs of the selection.

■ Other
Selecting the Other menu command displays the Other Line Spacing 
dialog box:

The line spacing that is entered in this dialog box will be applied to the 
selected paragraphs. For more information, refer to “Setting Line Spac-
ing” on page 117. 

The Format Menu The Format menu allows you to access the dialog boxes that set 
character, paragraph, tab, border and column formats. It also enables 
you to access the style sheet management dialog box.
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■ Character...
Selecting the Character... menu command displays the Character 
dialog box.

This dialog box allows you to set several character attributes of the 
selection at once. For more information on how to use this dialog box, 
refer to “Changing Several Text Attributes at Once” on page 133.

■ Paragraph...
Selecting the Paragraph... menu command displays the Paragraph 
dialog box.

This dialog box allows you to set the paragraph properties for the 
selected paragraphs. For more information on how to use this dialog 
box, refer to “Formatting Paragraphs” on page 113.
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■ Tabs...
Selecting the Tabs... menu command displays the Tabs dialog box.

This dialog box allows you to define the location and type of the tab 
stops for the selected paragraphs. For more information on how to set 
tabs, refer to “Setting Tabs” on page 118.

■ Borders...
Selecting the Borders... menu command displays the Borders dialog 
box:

This dialog box allows you to select the location and type of borders 
you want to apply to the selected paragraphs. For more information on 
this point, refer to “Setting Borders for a Paragraph” on page 143.
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■ Style Sheets...
Selecting the Style Sheets... menu command displays the Style Sheets 
dialog box:

This dialog box allows you to create, modify, import and apply style 
sheets. For more information on style sheets, refer to “Managing Style 
Sheets” on page 135.

■ Columns...
Selecting Columns... displays the Columns dialog box.

This dialog box allows you to set the width, spacing and number of 
columns in the document. For more information about columns in 
4D Write, refer to “Managing Columns” on page 162.
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The Tools Menu The Tools menu lets you select several utility features such as the table 
wizard, spellchecking, document statistics and information. Using the 
Tools menu also allows you to display either values or references and to 
either force an update of the references or to freeze them, as well as to 
activate or deactivate the Draft mode.

The Tools menu contains the following menu commands:

■ Table Wizard...
Selecting the Table Wizard... menu command displays the table wiz-
ard:

The table wizard allows you to define the table settings when creating 
a table. For more information about creating tables, refer to “Managing 
Tables” on page 148.
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■ Spelling...
Selecting the Spelling... menu command starts the checking of the 
document from the current cursor position. If the spellchecker 
encounters a mistake, the following dialog box is displayed:

For more information, refer to “Using a Spellchecker” on page 107.

■ Document Information...
Selecting the Document Information... menu command displays the 
Document Information dialog box:

In this dialog box, you can store additional information with your doc-
ument. This includes a title, subject, author, company and any notes. 
Once you have entered this data, click OK to close the dialog box and 
validate your entry or Cancel to ignore the changes.

Note For more information, refer to “Managing Document Information” on 
page 80.
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■ Document Statistics...
Selecting Document Statistics... displays the Document Statistics dialog 
box:

This dialog box displays statistics related to the current document. It 
includes the total number of lines, pages, characters, words, 
paragraphs, pictures, and database references (fields, formulas) as well 
as memory-related information. For more information, refer to 
“Viewing Document Statistics” on page 82. 

■ Compute References Now
Selecting the Compute References Now menu command recomputes 
all references and expressions in the document based on the current 
values in the database. For more information, refer to “Computing Ref-
erences” on page 201. 

■ Freeze Document
Selecting the Freeze Document menu command replaces each refer-
ence by its current value and converts it into a character string. This 
action cannot be canceled. For more information, refer to “Freezing 
References” on page 200.

■ Draft Mode
Selecting the Draft Mode menu command enables you to activate or 
deactivate this mode during data entry in a 4D Write document. When 
this mode is activated, a check mark appears next to the command in 
the menu. Draft mode enables an accelerated display of characters in 
certain cases. For more information, refer to “Activating the Draft 
Mode” on page 109.
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The Contextual 
Menu

A contextual menu appears when the user right clicks (Windows and 
Mac OS) or Control+clicks (Mac OS) in a 4D Write document. 

This menu offers several standard actions (editing actions such as copy 
or paste), access to various editors, as well as insertion functions. The 
actions offered in the menu will differ depending on where the user 
clicks: headers, footers, text or pictures.

4D Write Toolbars
4D Write toolbars are located in the upper part of the 4D Write win-
dow.

Toolbars are used to quickly access features that are used often. There 
are four toolbars in 4D Write:

■ The Standard toolbar

■ The Format toolbar

■ The Style toolbar

Example of the contextual 
menu (click on header)
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■ The Borders toolbar

The Standard 
Toolbar

The Standard toolbar is organized into several groups of buttons:

■ File management buttons

■ Print management buttons

■ Character search buttons

■ Cut/Copy/Paste buttons

■ Undo and Redo buttons

■ View management buttons

■ Insertion of current date and time buttons

■ Zoom management pop-up menu.

The File Management 
Icons

These are the file management buttons:

From left to right, these buttons are: the New Document button, the 
Open Document button and the Save Document button.

Clicking the New Document button displays a new blank document in 
the text area. If the document on which you are working is not saved, a 
dialog box appears asking if you want to save the current file before 
opening a new document.

Clicking the Open Document button opens the standard Open file 
dialog box that corresponds to the platform you are working on. If the 
document on which you are working is not saved, a dialog box is 
displayed asking if you want to save the current file before opening 
another document.

Clicking the Save Document button saves the current document at its 
current location. If the current document is a document that was never 
saved before, a Save file dialog box is displayed.
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The Print Management 
Buttons

The print management buttons consist of the following two buttons:

From left to right the two buttons are: the Print Preview button and 
the Print button.

Clicking the Print Preview button has the same effect as selecting the 
Print Preview menu command in the File menu. For more information, 
refer to “The File Menu” on page 25.

Clicking the Print button has the same effect as selecting the Print 
menu command in the File menu. For more information, refer to “The 
File Menu” on page 25.

The Find Button Clicking the Find button has the same effect as selecting the Find 
menu command in the Edit menu. For more information, refer to “The 
Edit Menu” on page 28.

The Copy/Paste 
Management Buttons

The copy/paste buttons consist of the following three buttons:

From left to right the three buttons are: the Cut button, the Copy 
button and the Paste button.

Clicking the Cut button has the same effect as selecting the Cut menu 
command in the Edit menu. For more information, refer to “The Edit 
Menu” on page 28.

Clicking the Copy button has the same effect as selecting the Copy 
menu command in the Edit menu. For more information, refer to “The 
Edit Menu” on page 28.

Clicking the Paste button has the same effect as selecting the Paste 
menu command in the Edit menu. For more information, refer to “The 
Edit Menu” on page 28.

The Undo 
and Redo Buttons

The Undo and Redo buttons are displayed as follows:

Clicking the Undo button has the same effect as selecting the Undo 
menu command in the Edit menu. For more information, refer to “The 
Edit Menu” on page 28.
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Clicking the Redo button has the same effect as selecting the Redo 
menu command in the Edit menu. For more information, refer to “The 
Edit Menu” on page 28.

The View Management 
Buttons

There are two view management buttons:

From left to right these buttons are: the View Invisible button and the 
View References button.

Clicking the View Invisible button has the same effect as selecting the 
Invisible Characters menu command in the View menu. For more 
information, refer to “The View Menu” on page 32.

Clicking the View References button has the same effect as selecting 
the References menu command in the View menu. For more 
information, refer to “The View Menu” on page 32.

The Insertion Buttons There are two insertion buttons:

From left to right these buttons are: the Insert Current Hour button 
and the Insert Current Date button.

Clicking the Insert Current Hour button inserts the current time at the 
insertion point. The time format is then “HH:MM”. The time is 
inserted as text and not as a reference (equivalent to not checking the 
Automatic update option in the date and time insertion dialog box)

Clicking the Insert Current Date button inserts the current date at the 
insertion point. The date format is then “Day, Month Day of the 
month, YYYY” (Friday, March 5, 1999 for example). The date is 
inserted as text and not as a reference (equivalent to not checking the 
Automatic update option in the date and time insertion dialog box).
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Zoom Menu This combo box is used to set the zoom value for displaying the 
4D Write area:

You can choose a predefined value to enlarge or reduce the display or 
enter a custom value (in %) between 25 and 500. 

The Format Toolbar The Format Toolbar consists of three button sets:

■ Text alignment buttons;

■ Line spacing buttons; and

■ The bullet button.

The Text Alignment 
Buttons

There are four text alignment buttons:

From left to right, the buttons are: the Align Left button, the Align 
Center button, the Align Right button and the Full Justification button. 
This set of buttons allows you to set the text alignment of the current 
selection.

Clicking the Align Left button aligns the paragraphs of the current 
selection to the left. The effect of this button is identical to the Align 
Left menu command from the Paragraph menu.

Clicking the Align Center button centers the selected paragraphs 
between their margins. The effect of this button is identical to the 
Align Center menu command from the Paragraph menu.

Clicking the Align Right button aligns the paragraphs of the current 
selection with their right margins. The effect of this button is identical 
to the Align Right menu command from the Paragraph menu.
56 4D Write User Reference Manual



4D Write Toolbars
Clicking the Full Justification button fully justifies the current 
selection. The effect of this button is identical to the Full Justification 
menu command from the Paragraph menu.

The Line Spacing 
Buttons

There are three line spacing buttons:

From left to right, these buttons are: the Single Spaced button, the 1.5 
Line Space button and the Double Spaced button. These buttons allow 
you to modify the line spacing for the current selection.

Clicking the Single Spaced button applies the default line spacing to 
the current selection. The effect of this button is identical to the Single 
Spaced menu command of the Paragraph menu.

Clicking the 1.5 Line Space button applies a line spacing of one and a 
half lines to all the paragraphs of the selection. The effect of this 
button is identical to the 1.5 Line Space menu command of the 
Paragraph menu.

Clicking the Double Spaced button applies a line spacing of two lines 
to the current selection. The effect of this button is identical to the 
Double Spaced menu command of the Paragraph menu.

The Bullet Button Clicking the Bullet button inserts a bullet at the beginning of the first 
line of each paragraph that belongs to the current selection. The style 
of bullet shown is determined by the bullet paragraph formatting 
option of each paragraph. Clicking once more on the Bullet button 
will remove the bullets.

The Style Toolbar The Style Toolbar consists of the following:

■ Style Sheet drop-down list

■ Font drop-down list
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■ Font size drop-down list

■ Style buttons

The Style Sheet Drop-
down List

The style sheet drop-down list allows you to select a style sheet and 
apply it to the current selection. The style sheets that appear in that list 
are the style sheets that are available in the current document. 

The Font Drop-down List The font drop-down list allows you to select a font and apply it to the 
current selection. The fonts that appear in this list are the fonts that 
are currently installed in your system. These fonts are the same as the 
fonts available in the Characters dialog box.

The Font Size Drop-
down List

The font size drop-down list allows you to select a font size and apply 
it to the current selection.

The Style Buttons There are three style buttons:

From left to right these buttons are: the Bold button, the Italic button 
and the Single Underline button.

Clicking the Bold button applies the Bold style to the current selection 
or removes it if it was already selected. The effect of this button is 
identical to that of the Bold menu command from the Style menu.

Clicking the Italic button applies the Italic style to the current selection 
or removes it if it was already selected. The effect of this button is 
identical to that of the Italic menu command from the Style menu.

Clicking the Single Underline button applies the Single underline style 
attribute to the current selection or removes it if it was already 
selected.
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The Borders Toolbar The Borders toolbar consists of two button sets:

■ Individual border buttons

■ Frame buttons

The Borders toolbar allows you to separately or globally define borders 
for the paragraphs of the current selection. 

Note The default frame style is the 1-pt standard line. If a special frame style 
has been defined for the current paragraph, it is applied. For more 
information about frame style, refer to “The Borders Dialog Box” on 
page 143. 

The Separate Borders 
Buttons

There are four separate borders buttons:

From left to right these buttons are: the Left Border button, the Top 
Border button, the Right Border button and the Bottom Border 
button. These buttons allow you to define the borders of the 
paragraphs in the current selection separately.

Clicking the Left Border button displays the left border of the 
paragraphs of the current selection.

Clicking the Top Border button displays the top border of the 
paragraphs of the current selection.

Clicking the Right Border button displays the right border of the 
paragraphs of the current selection.

Clicking the Bottom Border button displays the bottom border of the 
paragraphs of the current selection.
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The Frame Buttons There are three frame buttons:

From left to right these buttons are: the All Borders button, the Inside 
Borders buttons and the No Borders buttons. These buttons allow you 
to set several paragraph borders at once.

Clicking the All Borders button displays the external borders that 
outline the paragraphs of the current selection.

Clicking the Inside Borders button displays the external borders that 
outline the paragraphs of the current selection as well as the inside 
borders of all the paragraphs of the selection.

Clicking the No Borders button removes any borders present in the 
selection.
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Documents

This chapter explains how to create, open, and save 4D Write 
documents in both database records and in external windows. 

The following topics are covered in this section: 

■ Multi-platform and format document management

■ Opening a document in an external window

■ Creating a 4D Write area in a form

■ Creating, opening and saving a document

■ Setting preferences for a document

■ Viewing document information

■ Viewing document statistics.

Multi-platform Document Management
4D Write, like 4th Dimension and 4D Server, is a multi-platform 
program. This means that a database created under Mac OS that uses 
4D Write can be opened and run under Windows with no 
modifications, and vice versa.
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Format Management
4D Write allows you to use different file formats when opening or sav-
ing a file. Those formats appear in the drop down lists in the Open File 
and Save File dialogs boxes.

The file formats available in 4D Write are the following :

■ 4D Write Document
This format is the 4D Write native format. A 4D Write document saved 
using this format will keep all its features. This format is available for 
both opening and saving a document. 

■ 4D Write Template
This format is the 4D Write native format for templates. For more 
information about the templates in 4D Write and their use, refer to  
"Saving a Document as a Template" on page 76. This format is available 
for both opening and saving a document.

■ 4D Write 6.0 Document
This is the native format for the previous version of 4D Write. This 
format is available only when opening a document.

■ RTF Document
RTF stands for Rich Text Format. It allows file transfer between 
platforms while keeping basic formatting intact. This format is 
available for both opening and saving a document.

■ Word Document
This format is the Microsoft Word® documents’ native format. This 
format is available for opening and saving documents. 4D Write saves 
these documents in Word 97 format under Windows and in Word 98 
format under Mac OS.

Open File dialog box Save File dialog box
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■ HTML Document
HTML stands for Hypertext Mark-up Language. This format is primarily 
used for generating Web pages. This format is available for both 
opening and saving a document. 4D Write uses CSSs in order to 
convert the styles and formats as closely as possible to the original 
document. For more information about the elements supported, refer 
below to paragraph “Conversion of Documents into HTML” on 
page 63. 

■ Windows Text Document
This format is the basic Windows text format. It does not embed any 
character formatting and it uses the Windows extended ASCII table. 
This format is available for both opening and saving a document.

■ Macintosh Text Document
This format is the basic Mac OS text format. It does not embed any 
character formatting and uses the Mac OS extended ASCII table. This 
format is available for both opening and saving a document.

■ Unicode Text Document
The unicode format is designed to avoid the character conversion that 
takes place when a document is opened on another platform, or on 
another system. It also allows the contents to be always retrieved 
independently of the script manager.

Conversion of 
Documents into 
HTML

The table below specifies the elements that are supported when 
converting 4D Write documents into HTML:

Attributes HTML Conversion

Normal Style Yes
Bold Style Yes
Italics Style Yes
Strikethrough Style Yes
Superscript Style Yes
Subscript Style Yes
Shadow Style No
Underline Yes (single underline) - other variants of underlining 

are converted into single underlining
Font Yes
Font size Yes
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Note 4D Write uses QuickTime by Apple® to convert pictures contained in 
your documents to the JPEG format. For this conversion to be correct, 
make sure that you have installed the complete version of QuickTime 
on your machine (the “minimum” version does not enable the 
creation of JPEG files). 

File Equivalents 
under Mac OS and 
Windows

The following table indicates the file equivalents of 4D Write 
documents on Mac OS and Windows.

Foreground and 
background colors

Yes (texts and borders) - colors for strikethrough 
and shadow text and for underlines are not con-
verted. 

Bullets Yes (“black square” and “white circle” bullets) - 
other types of bullets are replaced by standard bul-
lets

Alignment Yes
Spacing Yes
Indentation Yes
Borders Yes
Tabs Yes, replaced by spaces (nbsp)
Pictures in text Yes (QuickTime must be installed on the machine 

doing the conversion)
Background picture No
Hypertext links Yes (standard links) - links that open a document or 

execute a 4D method are not converted.

Document
Mac OS Windows

Type Creator Extension 

4D Write Document 4WR7 4DW7 4W7
RTF TEXT 4DW7 RTF
Windows Text only TEXT 4DW7 TXT
Mac OS Text only TEXT 4DW7 TXT
Unicode Text Document TEXT 4DW7 TXT
HTML Document TEXT MOSS HTML
Word6/95 Document W6BN MSWD DOC
Word98 Document W8BN MSWD DOC
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Opening a 4D Write Document in an External Window
You can use 4D Write in its own window. When used in its own 
window, 4D Write operates as if it were a separate application.

❿❿❿❿ To open 4D Write in an external window:

1 If you are not in the User environment, choose User in the Mode 
menu.

2 Choose 4D Write from the Tools menu.

Note If the 4D Write menu command is not available from the Tools menu, 
4D Write has not been correctly installed in your environment. In this 
case, refer to the 4th Dimension Installation Guide.

A 4D Write document opens in an external window. 

Windows

Minimize/
Maximize/Close 
buttons

4D Write menu 
bar

4th Dimension 
menu bar
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The external window contains the 4D Write menu bar. The menus in 
this menu bar allow you to manage your document. For example, use 
the Style menu to apply a different style to selected text. The 
4th Dimension menus remain available in the standard menu bar at 
the top of your screen.

The external window also contains four toolbars. The role of these 
toolbars is to make access to specific features easier and faster. For 
example, to apply the Bold character style you can either select Bold 
from the Style menu or click the  icon in the Character toolbar. 
Toolbars also increase your control over the 4D Write interface since 
they can be moved within the 4D Write window or be used separately 
as palettes.

The ruler below the 4D Write toolbars allows you to set the margins, 
first line indent, and tabs.

The Standard toolbar allows you to quickly access some of the features 
that are accessible through the File, Display, and Insert Menus.

The Format toolbar allows you to set paragraph alignment, line 
spacing and the presence of bullets at the beginning of paragraphs.

The Style toolbar allows you to set the format of characters and to 
select a style.

Macintosh

4D Write menu 
bar

4th Dimension 
menu bar

Minimize/
Maximize/Close 
buttons
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The Borders toolbar allows you to set the features of the borders for a 
paragraph.

4D Write windows also contain splitters that allow you to divide the 
document area and therefore display different areas of the same 
document at the same time. For more information about splitters, refer 
to paragraph “Splitting the 4D Write Window” on page 19.

The document area below the ruler is where you edit your document. 

Opening Multiple 
Documents

You can open additional 4D Write windows by choosing 4D Write 
from the Tools menu. Operating several 4D Write documents at the 
same time enables you to compare documents, copy and paste 
between documents, and move from one document to another simply 
by clicking in the appropriate window.

The titles of all the open windows appear at the bottom of the Window 
menu. You can bring a 4D Write document to the front by choosing it 
from the Window menu.

Adjusting the 
Window Size and 
Proportions

❿❿❿❿ To adjust the window size under Windows:

1 Click on the lower right-hand corner of the window.
The pointer becomes a double-headed arrow.

Window
name

Open
windows
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2 Drag the corner or border until the window is the desired size. 

Note You can also modify the height and width of a window under 
Windows by clicking on its borders.

❿❿❿❿ To adjust the window size on the Macintosh:

1 Drag the Size box in the bottom right-hand corner of the window.

Maximizing the 
Window

❿❿❿❿ To expand a 4D Write window to take up the full screen:

1 Under Windows, click the Maximize button, or choose Maximize in 
the Control menu.
On the Macintosh, click the Zoom box.
Note that the 4th Dimension menu bars remain at the top of the screen 
unlike in Full page mode (see the paragraph “Expanding a 4D Write 
Area to Full Screen” on page 73).

Closing Documents To close an external window at any time:

1 Click on the Close box of the window.
OR
Under Windows, choose the Close command in the Control menu.

Creating and Using a 4D Write Area in a Form
You can create 4D Write areas in any database form. You can use 
4D Write in an input form, providing a document in each record for 
notes, reports, letters, or other information. You can also use a 
4D Write area in an output form to display or print a document.
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The following figure shows a 4D Write area in an input form. A letter is 
being created for Mark Vandergaard. The letter will be saved 
automatically with Mark’s record when the record is accepted.

Creating the 
4D Write Area

❿❿❿❿ To create a 4D Write area in a form:

1 If you are not already in the Design environment, choose Design from 
the Mode menu.
The Structure window appears, showing the database tables and fields.

To save the contents of the 4D Write area with each record in a table, 
you must create a Picture or BLOB field in a way that associates it with 
the area. As with all plug-ins, the contents of a 4D Write area can be 
stored in a Picture field. You can also store a 4D Write area in a BLOB 
field.

Steps 2, 3 and 7 are only necessary if you want to save the contents of 
the area with each record.

2 Add a Picture or BLOB field to the table whose form will have the 
4D Write area.
For information on creating a Picture or BLOB field, refer to the 
4th Dimension Design Reference manual.

Box to 
switch to 
full page 
mode

Document 
area

4D Write area

4D Write 
menu bar

4th Dimension 
record
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3 Give the Picture or BLOB field a name ending with an underscore (_).
For example, you can name the field Letter_.

4 In the Form editor, open the form where you want to add a 4D Write 
area.
This form must belong to the table containing the Picture or BLOB 
field associated with the area.

5 Use the Plug-in area Object tool to draw an area for 4D Write.

Plug-in area inserted 
in the form 

Plug-in area tool
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Of course, it may be necessary to resize the areas so that they fit the 
form. 

6 Click the Type drop-down list of the Property List and select 4D Write:

The Type list contains all the plug-ins installed in the database. 

In the form editor, the object now displays the following message:

7 In the Variable name box, name the 4D Write area by entering the 
name of the Picture or BLOB field, minus the underscore. 
For example, if you named the Picture or BLOB field Letter_, you 
would name the 4D Write area Letter.

Giving the 4D Write area this name associates it with the field, 
ensuring that its contents will automatically be saved with each record. 
In this case, use the automatic 4D buttons otherwise you will have to 
manually save the area using 4D commands. If you do not 
automatically save the contents of the area, 4D Write will give you the 
opportunity to save the contents of the area on disk when you accept 
the record.
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The plug-in area displays the 4D Write icon, the area name, and the 
message that the document will be saved with the Picture or BLOB 
field.

Proper Naming of 
4D Write Areas

If the area name does not correspond with the Picture or BLOB field 
name or if the field does not exist, 4D Write warns you that the 
document will not be saved with the record— the document could be 
saved if a Picture or BLOB field with the appropriate name existed.

Note The 4D Write plug-in area name is a variable. This variable can only be 
a process variable. It is not possible to use inter-process variables 
(where names start with <>) or local variables (where the names start 
with $) as plug-in area names. For more information on the different 
types of variables in 4D, please see the 4th Dimension Language Reference 
manual.

Saving the 4D Write 
Document as a Separate 
File

In some cases, you may not want the document to automatically be 
saved with the record. For example, you might want to store your 
documents on disk and load them procedurally. In this case, you 
would not want to create a Picture or BLOB field to store the 
documents.

Renaming the Area If you later want to automatically save the document with the record, 
you can go back and rename the 4D Write area. If the area name does 
not correspond with the Picture or BLOB field name, you can correct 
the name by double-clicking on the 4D Write area in the form. This 
shows the property list for the 4D Write area, so you can type the 
correct name in the Variable name box.

If the Picture or BLOB 
Field Does Not Exist

If the Picture field or BLOB does not yet exist, you can create the 
Picture or BLOB field in the Structure window. In fact, it does not 
matter which you create first—the Picture field or the 4D Write area. If 
you wish, you can create the 4D Write area on the form first and then 
go back and create the corresponding Picture or BLOB field.

Using the 4D Write 
Area in a Form

When using 4D Write in a form (in the User environment), the 
program menu bars appear above the 4D Write area. You can select the 
4D Write menu commands as well as those of 4th Dimension menus.
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The possibilities offered using this mode are plentiful. For more 
information, refer to the chapter “Using Dynamic References” on 
page 181.

4D Write allows you to use the included area as a full-screen as with 
any document.

Expanding a 4D Write 
Area to Full Screen

❿❿❿❿ To view a 4D Write area at full screen size:

■ Choose Goto Full Window from the File menu.
OR
Click the Maximize button or choose Maximize from the Control 
menu (Windows). 

On both platforms, the document expands to fill the entire screen and 
4D Write’s menu bar temporarily replaces 4th Dimension’s menu bar. 
If the 4D Write area on the form is too small to be used without being 
expanded, it is displayed as a grey area:

When you click this area during data entry, the document area 
automatically expands to full screen size.

Note The size below which the 4D Write area is displayed as a button is 400 
pixels wide and 550 pixels high (if these settings are set lower the area 
will be displayed as a gray area in User mode). You can modify these 
values as well as the title of the 4D Write area using the WR SET AREA 
PROPERTY command. This mechanism does not apply to the area 
display in the form editor in Design mode.

Returning to the Form When the document window is expanded, Goto Full Window in the 
File menu changes to Return to Form.

❿❿❿❿ To reduce the window and return to the form:

1 Choose Return to Form from the File menu, 
OR
Click the Close box.
OR
Under Windows, select Close from the Control menu.
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Creating a New Document
You can create a new blank document in either an external window or 
a 4D Write area at any time. In either case, the new document replaces 
the current document. If you have made changes to the current 
document, you will be prompted to save the changes before 4D Write 
opens the new document.

❿❿❿❿ To create a new document:

1 Choose New from the 4D Write File menu.

Opening Documents in 4D Write 
You can open documents in any 4D Write external window or 
4D Write area. The file formats 4D Write can open are described in 
paragraph “Format Management” on page 62.

❿❿❿❿ To open a document in an external window or 4D Write area:

1 Choose Open from the 4D Write File menu.
A standard Open File dialog box appears.

2 Choose a file format from the Format pop-up menu in order to see 
only the corresponding files.

3 Select a document.

4 Click Open.
The newly opened document replaces the current document in the 
current 4D Write window.

Note Only native 4D Write documents remain open. When a native 
document is displayed in the 4D Write window, it cannot be accessed 
by any other application. Conversely, non-native 4D Write documents 
are read and then closed. When such a document is displayed in the 
4D Write window, the standard Save file dialog box is opened if the 
user selects the Save menu command, as for a new document. 
74 4D Write User Reference Manual



Saving 4D Write Documents
Saving 4D Write Documents
You can save the text entered in a 4D Write document regardless of 
whether the document was created in an external window or in a 
form. 4D Write offers several ways to save documents.

■ As part of a record

■ As a Mac OS or Windows file

■ As a template for a 4D Write area

Saving a Document 
with a Record

If you have created a 4D Write area on a form and have created a 
Picture or BLOB field to store the area’s contents, any text entered in 
the area is automatically saved with each record when the record is 
accepted. For more information, refer to the paragraph “Creating and 
Using a 4D Write Area in a Form” on page 68. 

You can also save a document created in a 4D Write area as a separate 
file. Saving a Document as a File

Saving a Document 
as a File

Any document that you create using 4D Write can be saved as a 
separate file. You use the familiar Save and Save As… menu items from 
the 4D Write File menu to save and update individual documents. 

Documents you have saved can be opened by choosing Open from the 
4D Write File menu. It makes no difference whether the document has 
been created in an external window or in a form; the document can be 
saved or opened in either place.

❿❿❿❿ To save a 4D Write document as a file:

1 Choose Save as… from the 4D Write File menu.
Note that you choose this menu item from the 4D Write File menu, 
rather than from the 4th Dimension File menu.

4D Write displays the Export dialog box.

2 If necessary, choose the file format in which you would like to save the 
document from the Save as type: pop-up menu.
By default, 4D Write documents are saved in the standard 4D Write file 
format. You can also save the current document in other formats.

For more information about the file formats and their meanings, 
please refer to "Format Management" on page 62.

3 Enter a unique filename for the document.
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4 Click Save.
4D Write saves the document under the filename you entered.

❿❿❿❿ To update a document you have saved: 

1 Choose Save from the 4D Write File menu. 
The original file is updated.

Saving a Document 
as a Template

You may need to create a standard document containing elements that 
are the same for every document, such as a standard report format or 
letter heading. Instead of recreating the elements each time, you can 
save the document as a template used by every document displayed in 
a particular 4D Write area in a form.

■ Static areas (labels, pictures...) will never change.

■ Variable areas (database field references, 4D expressions...) will be 
computed dynamically, depending on the current record data.

Note You can create templates only for 4D Write areas on forms; they 
cannot be used for external windows. When you use 4D Write in an 
external window opened using the Tools menu, the Save as Template 
menu item is disabled.

The saved template is used by every document displayed in the 
4D Write area. Each document starts with the same template, but any 
unique modifications you make to a document are saved with the 
record. There can be only one template for each 4D Write area on a 
form.
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The 4D Write area in the following figure uses a template to display 
the name and address from the person’s record. Each person’s record 
displays the name and address in the same manner.

❿❿❿❿ To save a 4D Write document as a template:

■ Choose Save as Template from the 4D Write File menu.
4D Write automatically assigns the filename and location of the 
templates, so no Save File dialog box is displayed when you choose 
Save as Template.
4D Write saves the document, giving it the same name as the 4D Write 
area on the form, plus an underscore and the “.4wt” extension. For 
example, the template file for the “WPArea” area is named 
“WPArea_.4wt”.

By default, with 4th Dimension and 4D Server, templates are stored in 
the database folder. 

However, in a client-server configuration, it is possible to store and/or 
load templates onto client machines using the WR SET AREA PROPERTY 
command. In this case, each client machine can have its own 
templates. These templates are then stored: 

■ Under Mac OS, at the following location: (User folder) Library:Appli-
cation Support:4D:4D Write Templates:DatabaseName folder

Template displays 
name and address
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■ Under Windows, at the following location: Documents and set-
tings\User\Application data\4D\4D Write Templates\DatabaseName 
folder

You can also create a template by saving a 4D Write document as a 4D 
Write Template type and giving it the same name as the 4D Write area, 
plus an underscore and the “.4wt” extension. It must be put in the 
templates folder. 

You can temporarily disable the use of a particular template file by 
changing the template filename.

❿❿❿❿ If you modify the template and want to incorporate the changes: 

■ Choose Save as Template from the 4D Write File menu again. 
4D Write asks if you would like to replace the existing template file. 
Clicking the OK button updates the template.

Setting Preferences
4D Write lets you set preferences for a document. You can choose the 
ruler units as well as various page layout and numbering characteristics 
for the document.

❿❿❿❿ To set preferences for the current document:

■ Choose Preferences... from the 4D Write File menu.
The Document Preferences dialog box appears
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Page The “Page” area allows you to set the following options:

■ First Page is:
This menu allows you to select the side of the first page. Selecting Right 
sets the side of the first page to Right. Selecting Left sets the side of the 
first page to Left.

■ First Page Number:
This box allows you to set the page number of the first page. Automatic 
page numbers will be updated accordingly.

Tip You can start page numbering at 1 in 4D Write regardless of the actual 
page number within the document. In order to do this, select a value 
equal to 2-X in the First Page Number area, where X is the actual page 
number of the document. 
If, for example, you wanted to begin numbering with 1 but starting on 
page 12, enter -10 in the Preferences dialog box. The reason for this is 
that 4D Write does not consider page numbers that are ≤ 0.

■ Binding:
This box allows you to set the value of the space left for the binding of 
your document. If the Opposite pages option is checked, the value 
entered will be applied to opposite pages as it is required when binding 
a book of double-sided pages. If the Opposite pages option is not 
checked, the value of the binding is always applied to the same side of 
the page, as required in binding a book of single-sided pages. The 
Binding value is expressed in the unit selected in the Units drop-down 
list.

■ Opposite pages:
The space allocated to the binding is set to manage double-sided pages 
when this option is checked. When this option is not selected the 
space allocated to the binding remains constant for left and right 
pages, as required for single-sided pages.

Global Settings This area has only one option: Units. This option is used to set the unit 
used to display the ruler of the document as well as, in general, all the 
dimensions expressed in 4D Write, whether directly in the interface or 
by programming.

Headers and Footers This area is used to configure specific headers and footers. 

■ Different on first page: Checking this check box will allow you to 
set different headers and footers for the first page of the document.
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■ Different on left and right pages: Checking the option will allow 
you to set different headers and footers for the left and right pages. 
If this option is left unchecked, the headers and footers will be set 
once for both types of pages.

Paragraph This area is used to configure the following options:

■ Default Tab Spacing
This box allows you to set the default value for “automatic” tab 
spacing in your document. This value will be applied to all the para-
graphs that do not have custom settings.

■ Widow and Orphan Control
Checking this box will prevent the first line of a paragraph from 
being left at the end of a page, and it will also prevent the last line 
of a paragraph from being left at the beginning of a page. 

Spellchecker 
Settings

This area has only one option: Checking as you type. It is used to set 
the spellchecker to verify the text being edited. When this option is 
checked, any words that seem to be spelled incorrectly are immediately 
underlined in the document. 
When this option is not checked, spellchecking must be carried out 
using the Spelling... command in the Tools menu of 4D Write (for 
more information about this, refer to paragraph “Using a Spellchecker” 
on page 107). 

Note This is a global option for the 4D Write plug-in: it is set for all the 
documents opened during the session.

Managing Document Information
4D Write allows you to enter or view additional information about a 
document. This information can be valuable in the case of multi-user 
databases.

You can give a title, a subject, an author and a company name to each 
document. You can also write additional notes, or set the document in 
read-only mode. 

❿❿❿❿ To view or modify the document information:

1 Select Document Information... from the Tools menu.
The Document Information dialog box appears.
80 4D Write User Reference Manual



Managing Document Information
2 Add or modify any information you need:

3 Click OK to save the information.

Locking a Document You can lock a 4D Write document. A locked document can be opened 
or viewed by any user, but cannot be modified.
When a locked document is open, all 4D Write functions allowing text 
modification are disabled. Only viewing, printing and searching 
commands are allowed. Interface management commands are also 
enabled.

❿❿❿❿ To lock a document:

1 Check the Locked option in the Document Information dialog box for 
that document.

2 Click OK. 
The document is immediately locked. Any menu commands or icons 
allowing text modification are disabled. 

❿❿❿❿ To unlock a document:

1 Uncheck the Locked option in the Document Information dialog box 
of the document.

2 Click OK. 
The document again becomes freely editable.
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Viewing Document Statistics
You can display the number of lines, pages, characters, words, 
paragraphs, and pictures in your document, as well as the size of your 
document and the number of database objects it includes. In some 
cases, it will allow you to free memory.

❿❿❿❿ To view these statistics:

1 Choose Document Statistics... from the 4D Write Tools menu.
4D Write displays a Document Statistics dialog box with information 
about the document. 

Text ■ Lines: number of lines in the document. A paragraph is made of one 
or several lines.

■ Pages: number of pages in the document. 

■ Characters: characters are the smallest units of a document. Spaces 
and carriage returns are characters. 
Characters from inserted references or page numbers are not taken 
into account. 

■ Words: a word is a set of chained characters located between two 
space characters or a space character and a punctuation character.

■ Paragraphs: paragraphs are the basic units of a document. Each car-
riage return character creates a new paragraph. 
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■ Pictures: number of pictures pasted in text flow.

■ Pictures in Page: number of pictures pasted on a page of the docu-
ment. When a picture is pasted to a page “on every page”, a single 
occurrence is made compatible.

■ Soft Hyphens: number of hyphens inserted into the document.

■ Page Breaks: number of manual page breaks inserted into the docu-
ment.

■ Column Breaks: number of manual column breaks inserted into the 
document.

References ■ Database Objects: number of fields, expressions or 4D methods 
inserted in the document.

■ Date and Time: number of date and time references inserted into 
the document.

■ Page Number: number of page number references inserted into the 
document.

■ Hyperlinks: number of hypertext links inserted into the document.

■ RTF Expressions: number of RTF expressions inserted into the docu-
ment.

■ HTML Expressions: number of HTML expressions inserted into the 
document.

Memory ■ Document Size: size in bytes of document.

■ Picture Cache Size: size in bytes of application memory occupied by 
the picture cache. If you need to free up memory you can click on 
the Clear cache button. In this case, the picture display will be 
momentarily slowed.

■ Under Buffer Size: size in bytes of application memory occupied by 
the cancel buffer. This buffer is designed to sequentially save opera-
tions that you have completed within your document so that you 
can eventually cancel an operation. If you need to free up memory, 
you can click on the Clear buffer button. Be careful, you cannot 
undo a previous operation once the buffer is cleared.
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This chapter describes how you interact with the 4D Write windows in 
your database. It also explains how to perform basic text editing 
operations, such as entering, deleting, selecting and searching for text.

The chapter includes explanations of the following:

■ Navigating in a document

■ Entering and editing text

■ Finding and replacing text

■ Using a spellchecker

■ Activating the Draft mode.

Browsing the 4D Write Window
The 4D Write window contains a blank area in which you can type 
and display documents. You can display the 4D Write window as an 
external window or as part of a record.

Scrolling The vertical and horizontal scroll bars work as in all Macintosh and 
Windows applications, regardless of whether you are using 4D Write in 
an external window or in a form. Use the scroll bars to move through 
the document and bring hidden areas into view.
854D Write User Reference Manual



Chapter 4  Entering and Editing Text
Scrolling does not change the position of the insertion point (the 
flashing vertical bar which shows where your typing will appear) or the 
current selection. After scrolling to another part of the document, you 
can return to the location of the insertion point or the selection by 
choosing Show Selection from the Edit menu. If a large block of text is 
selected, Show Selection scrolls the document to the top of the 
selected text.

Note In addition to the standard scroll keys, 4D Write also allows you to use 
shortcuts to facilitate document navigation. These shortcuts are listed 
in Appendix A on page 211.

Going to a Specified 
Page

The Goto Page... command in 4D Write’s Edit menu presents a dialog 
box where you enter the number of the page to which you want to go:

❿❿❿❿ To go to a specific page:

1 Choose Goto page... from the Edit menu.
The Goto Page dialog is then displayed.

2 Enter the page number of the page to which you want to go.

3 Click OK.

Note The page number you enter is the page number as the document will 
be printed, taking into account the page numbering as it is defined in 
the Preferences.

Entering and Selecting Text
You enter text by typing on your keyboard. In a new document, you 
start on the first line. In a document already containing text, you can 
enter text on any existing line.

❿❿❿❿ To enter text:

1 Position the pointer where you want to enter text, then click.
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A blinking insertion point appears where you clicked. When you start 
a new document, the insertion point automatically appears at the 
beginning of the first line.

2 Begin typing your document.
4D Write automatically wraps at the paragraph margin to create new 
lines as you type. This is commonly referred to as “word wrap.” Press 
Return (Macintosh) or Enter (Windows) only when you want to start a 
new paragraph.

You can also enter text copied into the Clipboard. Choose Paste from 
either the 4th Dimension or the 4D Write Edit menu to enter the 
contents of the Clipboard into your document at the insertion point, 
or to replace the current selection with the contents of the clipboard if 
you have part of the document selected.

Correcting Mistakes If you make a mistake, you can correct it using standard word-
processing techniques. 

❿❿❿❿ To remove one or more characters to the left of the insertion point:

■ Under Windows, use the Backspace key.
On the Macintosh, use the Delete key.

❿❿❿❿ To remove the character to the right of the insertion point:

■ Under Windows, press the Delete key.
On the Macintosh, press Shift-Delete or the Del key (available on some 
keyboards).

❿❿❿❿ To type over text:

■ Select the text and type the replacement text.

Undo/Redo In order to provide you with more flexibility when editing your 
document, 4D Write manages a sequential queue of all the “Undoable” 
actions. If you have modified your document and do not like the 
result, you can undo, one at a time, all the actions you have performed 
on the text. You can undo many kinds of changes, including typing, 
text replacements, and formatting changes.
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If, when canceling actions, you cancel some actions that you did not 
want to cancel, 4D Write allows you to “redo” those actions. Once you 
start canceling actions the Redo command becomes activated. This 
command operates in the same way as the Undo command does. It 
manages the same queue of actions as the Undo command does.

Note The only actions that cannot be undone are changes to the document 
settings (margins, tabulations, preferences and picture settings).

❿❿❿❿ To undo a change you made to your document:

■ Choose Undo from the 4D Write Edit menu.
Choosing this menu item will undo the last change you made.

❿❿❿❿ To redo an action that was just canceled:

■ Choose Redo from the 4D Write Edit menu.
Choosing this menu item will re-do the last change you undid.

Note If you edit the text after having undone a queue of actions, you cannot 
redo them. 

Selecting Text 
to Edit

You can revise text after you’ve typed it. Select the text—anything 
from a single character to the entire document—and then apply a 
command or action to it.

❿❿❿❿ To select an area of text:

■ Click to set the insertion point and drag the cursor in either direction.
To extend the selection after you have released the mouse button, hold 
down the Shift key while you click and drag some more.

❿❿❿❿ To select a single word and its following space (if any):

■ Double-click the word.
To extend the selection by whole words, select a word by 
double-clicking it and then Shift-click in either direction, or hold down 
the mouse button on the second click and drag.
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❿❿❿❿ To select all the text in the document:

■ Choose Select All from the 4D Write Edit menu.

Note 4D Write also offers several keyboard shortcuts to speed up text 
selection. For more information, refer to Appendix A on page 211.

Removing Text You can discard text completely or keep a copy of it on the Clipboard. 
Text copied into the Clipboard can be pasted into another document 
or another application.

❿❿❿❿ To remove text permanently:

1 Select the text you want to remove.

2 Choose Clear from the 4D Write Edit menu.
OR
Press the Backspace or Delete key.

❿❿❿❿ To remove selected text while keeping a copy of it on the Clipboard:

1 Select the text you want to remove.

2 Choose Cut from the 4D Write Edit menu.

You usually cut text from your document when you want to move it to 
a new location.

Any text you remove can immediately be restored to its original 
position by choosing Undo from the 4D Write Edit menu.

Replacing Text

❿❿❿❿ To replace text:

1 Select the text you want to replace. 

2 Type the new text over the selection.
OR
Choose Paste from the 4D Write Edit menu to replace the text with 
the contents of the Clipboard.

❿❿❿❿ To replace text with a blank line (carriage return):

1 Select the text you want to replace.

2 Under Windows, press the Enter key.
On the Macintosh, press the Return key.
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To restore any text that you have replaced, choose Undo from the 
4D Write Edit menu.

Moving or Copying 
Text

Revisions often involve moving text from one place to another. You 
can cut a sentence from one paragraph and paste it into another. You 
can also copy a selection, leaving the original in place, and paste the 
copy onto another page.

❿❿❿❿ To move or copy text:

1 Select the text you want to move or copy.

2 Choose Cut or Copy from the 4D Write Edit menu.
Cut removes the selection. Copy leaves the original selection in place. 
Both commands store the selected material in the Clipboard, where it 
remains until it is replaced by the next selection you cut or copy.

3 Click to set the insertion point where you want to place the material 
from the Clipboard.
You can insert the text into the original document or into another 
one. 

4 Choose Paste from the 4D Write Edit menu.
The cut or copied text appears at the insertion point.

Note • When using other applications that support RTF format, you can use 
the clipboard to copy/cut and paste in order to transfer text from one 
application to the other. In this case, the styles will be maintained.
• When you copy then paste text between two 4D Write areas, any 
style sheets present in the selection are also moved. If necessary, the 
style sheets of the selection are created in the destination document.
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Dragging and 
Dropping Text

4D Write lets you move or copy text (as well as pictures) within the 
same area or between two different areas. 

A selection of text or a picture can be moved using the mouse. Under 
Windows, the cursor changes to in order to indicate that a drag and 
drop is being carried out. Under MacOS, a shadow follows the object 
being moved. An insertion point indicates the destination of the 
moved object:

Note When a picture is inserted in a 4D Write area using drag and drop, it is 
automatically pasted into the text. For more information about 
managing pictures, refer to the chapter “Working with Pictures” on 
page 169. 

Data are moved when the drag and drop is carried out within the same 
or between two different 4D Write areas, i.e. they are removed from 
the original area. If you only want to copy the data, hold down the Ctrl 
(Windows) or Command (MacOS) key during the operation.

Note Dragging and dropping can also be managed by programming, for 
example to trigger custom actions. For more information about this, 
refer to the 4D Write Language Reference manual. 

Inserting and 
Removing Hyphens

After text is written, you can insert hyphens within words to enhance 
the page layout. You can manually insert “hard” hyphens into your 4D 
Write documents using the “-” key. You can also use 4D Write Edit 
menu commands to insert and remove hyphens automatically; these 
are “soft” hyphens. If a word with a soft hyphen is relocated to where 
it does not require the hyphen (for example, in the middle of a line), 
the hyphen does not appear. It will reappear if the word is later put in 
a position where it requires it again. You can insert any number of soft 
hyphens in a word to make it break at the proper place when it is at 
the end of a line.

The Soft Hyphen command is disabled if the insertion point is next to 
a punctuation character, such as a period, comma, or parenthesis.

❿❿❿❿ To insert a soft hyphen:

1 Place the cursor where the word is to be separated at the end of a line.
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2 Select the Soft Hyphen command in the 4D Write Insert menu.
The word is hyphenated.
You can view hyphens which have been inserted when invisible 
characters are shown (see “Showing Invisible Formatting Characters” 
on page 129). 

Inserting a Special 
Character

4D Write can assist you to insert any character in the current font. This 
is particularly useful with foreign-language characters or symbols for 
which you can’t remember the correct keystrokes.

❿❿❿❿ To Insert a special character:

1 Choose Special Character from the Insert menu.
The Select Special Character dialog box is then displayed:

2 Select the font in which the character is supposed to be displayed.
The characters available in that font are displayed.

3 Select the character you want to insert
OR
Enter its ASCII code in the text box.

4 Click OK.
The character is then inserted at the insertion point.

Inserting a Non-
Breaking Space

4D Write allows you to insert non-breaking space characters. A non-
breaking space replaces a standard space character in order to keep two 
words together on one line rather than allowing a line to break 
between them.

❿❿❿❿ To insert a non-breaking space character:

1 Click where you want to insert a non-breaking space character.

2 Choose Non Breaking Space from the Insert menu.
OR
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Under Windows: press the Alt key and type 0160.
Under Mac OS: press Option+Space bar.
4D Write inserts a non-breaking space. When invisible characters are 
displayed, non-breaking spaces appear as blank characters, while 
standard space characters appear as points (.). 

Finding Text
You can use 4D Write to locate occurrences of:

■ a particular character sequence, 

■ particular character formatting,

■ particular paragraph formatting,

■ particular border formatting,

■ a paragraph or sequence of characters that uses a particular style sheet,

■ any combination of the conditions listed above.

To perform such a search, you will use the Find dialog box, in which 
all the search criteria will be defined.

Overview In 4D Write, a character search is based on two types of criteria:

■ the actual sequence of characters,

■ the character, paragraph and border formats as well as the style sheet 
that are applied to the sequence of characters.

If more than one format is specified, text will only be located that 
matches all of the formats specified. For example, specifying both the 
sequence of characters and the format parameters focuses the search 
on that sequence of characters with that specific formatting. Specifying 
only a format will focus the search on all the sequences of characters to 
which this format was applied. For more information about setting a 
character search, refer to the section “Setting a Character Search” on 
page 98
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The Find Dialog Box You can access the Find dialog box by choosing Find from the Edit 
menu or by clicking on the icon in the Standard toolbar. 

The Find dialog box includes one entry area, one display area, three 
check boxes and four format buttons. It also includes the standard 
Cancel and Find buttons that allow you to respectively cancel or trigger 
the search.

The Entry Area The Entry area is the area in which you will enter the actual sequence 
of characters you are looking for in your document. 4D Write records 
all the sequences of characters you have looked for since the opening 
of the current document. Clicking on the arrows  located next to 
the entry area displays a drop-down menu that includes all the 
sequences of characters you have been looking for in that document:

This feature allows you to select a sequence of characters you have 
already searched for, without having to re-enter it.

The Format Buttons The format buttons give you access to specific settings you may search 
for. These settings are dealt with in four separate categories, each of 
which corresponds to a button: Character, Paragraph, Borders and 
Style Sheets. This allows you to extend the search to a sequence of 
characters with a specific character format or, for instance, to search 
for any paragraph that uses a specific style sheet.

❿❿❿❿ To set a character format for a search:

1 Click on the Character button .
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The following dialog is then displayed:

This dialog box is identical to the Character format dialog box.

2 Set the character format you want to search for by setting it as you 
would in the Character format dialog box.
For more information on how to set a character format, refer tothe 
section “Changing Several Text Attributes at Once” on page 133.

3 Click OK to confirm your settings.
The Find dialog box is then displayed and the preview area displays the 
character settings you just entered.

❿❿❿❿ To set a paragraph format for a search:

1 Click on the Paragraph button .
The following dialog box is then displayed:

This dialog box is identical to the Paragraph format dialog box.
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2 Set the paragraph format you want to search for by setting it as you 
would in the Paragraph format dialog box.
For more information on how to set a paragraph format, refer tothe 
section “Setting Paragraph Formats Using the Paragraph Dialog Box” 
on page 123.

3 Click OK to confirm your settings.
The Find dialog box is then displayed and the preview area displays the 
paragraph settings you just entered.

❿❿❿❿ To set a border format for a search:

1 Click on the Borders button .
The following dialog box is then displayed:

This dialog box is identical to the Borders format dialog box.

2 Set the border format you want to search for by setting it as you 
would in the Borders format dialog box.
For more information on how to set a border format, refer tothe 
section “Setting Borders for a Paragraph” on page 143.

3 Click OK to confirm your settings.
The Find dialog box is then displayed and the preview area displays the 
border settings you just entered.

❿❿❿❿ To select a style sheet for a search:

1 Click on the Style Sheets button .
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The following dialog box is then displayed:

This dialog box displays the list of style sheets available for the 
document.

2 Click on the style sheet to be included in the search.

3 Click OK to confirm your settings.
The Find dialog box is then displayed.

The Preview Area The preview area displays the format criteria, other than the sequence 
of characters, that you have defined in your search. The following is an 
example of what the preview area would display if you had set the 
options to find any sequence of characters that uses the Arial font 
located in a single-spaced paragraph with left alignment.

The Search Options There are three character options that can be set using the three check 
boxes of the Find dialog box:

■ Full word
When this option is selected, 4D Write will look for the sequence of 
characters that was entered in the entry area, but will only select the 
occurrences where the sequence is a specific word. For example if the 
sequence of characters you are looking for is “part”, 4D Write will 
select “part” as a whole word but will not select “part” in “partition”.
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■ Case sensitive
When this option is checked, 4D Write will only stop on the sequence 
of characters whose case matches the one entered in the entry area.

■ Wrap
When this option is selected the search will loop through the entire 
document. If this option is not selected, the search will go from the 
insertion point to the end of the document.

Setting a Character 
Search

❿❿❿❿ To define a character search:

1 Choose Find from the Edit menu.
OR
Click the Find icon .
4D Write displays the Find dialog box.

2 Type the text you want to locate in the Find text box.
In addition to entering text, you can paste Tab or Return characters in 
the Find area to search for those characters.

3 Select all options you want.
To find the text only when it appears as a whole word, click the 
Full word check box.

To find the text only when it occurs with the capitalization as you 
typed it in the Find area, click the Case sensitive check box.

To perform the character search in the whole document, click the 
Wrap check box. For more information about the Wrap option, refer to 
the section “The Search Options” on page 97.

You can add more specific search criteria by defining specific formats 
using the format buttons. For information about how to use those 
possibilities, refer to the section “The Format Buttons” on page 94.
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4 Click the Find button.
4D Write closes the dialog box and locates and selects the first 
occurrence of text that matches the criteria you entered in the dialog 
box.

5 To locate and select the next occurrence of the text, choose Find Next 
from the 4D Write Find menu.
4D Write continues the search until it either encounters another 
occurrence of the sequence of characters, or reaches the end of the 
document (if the Wrap option was not selected), or the insertion point 
(if the Wrap option was selected).

Finding and Replacing Text and Formats
4D Write allows you to locate and replace the following:

■ a particular character sequence,

■ particular character formatting,

■ particular paragraph formatting,

■ particular border formatting,

■ a paragraph or sequence of characters that uses a particular style sheet,

■ any combination of the conditions listed above.

A “Find and Replace” operation can be of two types. You can locate a 
sequence of characters and replace them with another sequence of 
characters. For more information about finding and replacing 
sequences of characters, refer to the section “Finding and Replacing 
Sequences of Characters” on page 104. You can also locate formats or 
style sheets and replace them by other formats or style sheets. For more 
information about finding and replacing formats, refer to the section 
“Finding and Replacing Formats” on page 105.
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The Replace Dialog 
Box

The Replace dialog box is the dialog box in which you define both the 
Find criteria and the Replace criteria.

It consists of the following elements:

■ The “Replace” area, which is identical to the Find area in the Find 
dialog box (see “The Find Dialog Box” on page 94).

This area is where you define the sequence of characters or format you 
want to replace. If you have already searched for a sequence of 
characters or a format in the current document, the replace area 
reflects the last search you performed. 

■ The “With” area

This area is where you define the sequence of characters or format that 
is intended to replace the sequence of characters or format 4D Write is 
searching for. In the case of a format replacement, it also is the area in 
which the new format to apply will be defined.

“Replace” area: Defines 
search parameters

“With” area: Defines 
replacement elements

Format buttons

Dialog buttons
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4D Write records all the sequences of characters you have used in the 
Replace dialog box since the opening of the current document. 
Clicking on the arrows located next to the entry area displays a 
drop-down menu that includes all the sequences of characters you 
have used as replacement sequences:

This feature allows you to select a sequence of characters already used 
in the Replace dialog box, without having to re-enter it.

■ The dialog buttons

These buttons allow you to command the Replace actions or to close 
the Replace dialog box.

■ The format buttons
The format buttons give you access to specific settings you may want 
to set. These settings are dealt with in four separate categories, each of 
which corresponds to a button: Character, Paragraph, Borders and 
Style Sheets. This allows you to define replacement formats that will 
either be applied to the replacement sequence or to the sequence 
selected by the search. 

❿❿❿❿ To set a replacement character format:

1 Click on the Character button .
The following dialog box is then displayed:
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This dialog box is identical to the Character format dialog box. 

2 Set the character format you want to apply by setting it as you would 
in the Character format dialog box.
For more information on how to set a character format, refer tothe 
section “Changing Several Text Attributes at Once” on page 133.

3 Click OK to confirm your settings.
The Replace dialog box is then displayed and the preview area displays 
the character settings you just entered.

❿❿❿❿ To set a paragraph format to apply:

1 Click on the Paragraph button .
The following dialog box is then displayed:

This dialog box is identical to the Paragraph format dialog box.

2 Set the paragraph format you want to apply by setting it as you would 
in the Paragraph format dialog box.
For more information on how to set a paragraph format, refer tothe 
section “Setting Paragraph Formats Using the Paragraph Dialog Box” 
on page 123.

3 Click OK to confirm your settings.
The Replace dialog box is then displayed and the preview area displays 
the paragraph settings you just entered.

❿❿❿❿ To set a border format to apply:

1 Click on the Borders button .
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The following dialog box is then displayed:

This dialog box is identical to the Borders format dialog box.

2 Set the border format you want to apply by setting it as you would in 
the Borders format dialog box.
For more information about how to set a border format, refer to the 
section “Setting Borders for a Paragraph” on page 143.

3 Click OK to confirm your settings.
The Replace dialog box is then displayed and the preview area displays 
the border settings you just entered.

❿❿❿❿ To select a style sheet for a search:

1 Click on the Style Sheets button .
The following dialog box is then displayed:

This dialog box displays the list of style sheets available for the 
document.

2 Click on the style sheet you want to apply.

3 Click OK to confirm your settings.
The Replace dialog box is then displayed.
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Finding and 
Replacing 
Sequences of 
Characters

❿❿❿❿ To locate and replace a sequence of characters:

1 Choose Replace... from the Edit menu.
4D Write displays the Replace dialog box.

2 Type the text you want to locate in the Replace text box.

3 Select all options you want in the Replace area.
To find the text only when it appears as a whole word, click the 
Full word check box.

To find the text only when it occurs with the capitalization as you 
typed it in the Replace text box, click the Case sensitive check box.

To perform the character search throughout the whole document, click 
the Wrap check box. For more information about the Wrap option, 
refer to the section “The Search Options” on page 97

You can add more specific search criteria by defining specific formats 
using the format buttons. For information about how to use those 
possibilities, refer to the section “The Format Buttons” on page 94.

4 Type the replacement text in the With text box.
In addition to entering text, you can paste Tab or Return characters in 
the With area to use them as replacement characters.

5 Select all options you want in the With area.
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You can add specific formats to the replacement sequence. For 
information about how to use these possibilities, refer to the section 
“The Format Buttons” on page 94.

6 Click the Replace button
OR
Click the Replace all button
If you click on the Replace button, 4D Write closes the dialog box, 
then locates and replaces the first occurrence of text that matches the 
criteria you entered in the dialog box.

If you click on the Replace all button, 4D Write closes the dialog box, 
then locates and replaces all the occurrences of text that matches the 
criteria you entered in the dialog box.

7 To locate and replace the next occurrence of the text, choose 
Replace Next from the 4D Write Find menu.
4D Write continues the search until it either encounters another 
occurrence of the sequence of characters, or reaches the end of the 
document (if the Wrap option was not selected) or the insertion point 
(if the Wrap option was selected).

Note Selecting Check Boxes in the Borders and Characters dialogs:
You may need to click a check box twice to select it. When you first 
enter the expanded Replace dialog box, the check boxes appear greyed 
(Windows) or strikethrough (Mac OS) to indicate that the style 
attributes are not part of the search or replace criteria. When you click 
such a check box, it is deselected and becomes empty. When you click 
it again, the check box is selected.

Finding and 
Replacing Formats

❿❿❿❿ To locate and replace a format:

1 Choose Replace... from the Edit menu.
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4D Write displays the Replace dialog box.

2 DO NOT type any text in the Replace text box and make sure this text 
box is empty.

3 Define the format or combination of formats you want to replace, 
using the four format buttons. 
For information on how to use the format dialogs, refer to the section 
“The Format Buttons” on page 94.

4 Define the replacement formats, using the four format buttons of the 
With area. 
For information on how to use the format dialogs, refer to the section 
“The Format Buttons” on page 94.

5 DO NOT type any text in the With text box and make sure this text 
box is empty.

6 Click the Replace button
OR
Click the Replace all button
If you click on the Replace button, 4D Write closes the dialog box, 
then locates the first occurrence of characters whose formats match 
the formats you entered in the dialog box and replaces them by the 
replacement formats.

If you click on the Replace all button, 4D Write closes the dialog box, 
then locates every occurrence of characters whose formats match the 
formats you entered in the dialog box and replaces them by the 
replacement formats.
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7 To locate and replace the next occurrence of formats, choose 
Replace Next from the 4D Write Find menu.
4D Write continues the search until it either encounters another 
occurrence of the sequence of characters, or reaches the end of the 
document (if the Wrap option was not selected) or the insertion point 
(if the Wrap option was selected).

Using a Spellchecker
4D Write includes a spellchecker available in several languages. 

The current language of the 4D application will be used for checking 
the spelling. The SET DICTIONARY command of the 4th Dimension 
language can be used to change the current dictionary. 

You can spellcheck your document “on the fly” (i.e. when typing the 
text), or at any time using the menu command.

On-the-fly checking (a global option for the 4D Write plug-in) is set in 
the document preferences (seethe section “Spellchecker Settings” on 
page 80). 

❿❿❿❿ To check the spelling in your document:

1 Place the insertion point in the document where you want to perform 
the check.
OR
If you want to check part of the document, select that part of the 
document.

2 Choose Spelling... from the 4D Write Tools menu.
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The checking begins immediately. If the spellchecker encounters a 
mistake, the following dialog is displayed:

The following options are available:

■ Ignore: The possible mistake will not be corrected and the checking 
resumes.

■ Ignore All: Any occurrence of the current possible mistake will be 
ignored and the checking resumes.

■ Change: The selected possible mistake is replaced by the suggested 
correction displayed in the Change to area, and the checking resumes.

■ Change All: The selected possible mistake and all its other occurrences 
are replaced by the suggested correction displayed in the Change to 
area, and the checking resumes.

■ Add: The possible mistake is left untouched and is added to the current 
user dictionary, then the checking resumes.

■ Close: Stops the checking and closes the dialog. The text is left 
untouched.

If the correction displayed in the Change to area does not suit your 
needs, you can either select another one from the Suggestions area by 
clicking it or manually enter a new correction in the Change to area.

3 Choose an option. 
If you choose to continue checking, the dialog box will appear again 
when a new error is encountered. 

Possible mistake

Action buttons

Suggested correction

Other suggestions
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When the spellchecker has finished checking the document or selected 
text, 4D Write displays a warning dialog box to indicate that the 
spellcheck has been completed. 

Activating the Draft Mode
By default, character entry is carried out in 4D Write using the 
WYSIWYG mode; in other words, data presentation on the screen is 
identical to what you get when printing. This mode uses character font 
definitions supplied by the driver of the current printer. 

This feature can sometimes entail a noticeable slowdown of character 
display during data entry. The cause is generally either the operating 
system, the print driver or the utilities installed on the computer.

In this case, you can deactivate the WYSIWYG mode by selecting the 
Draft Mode command in the Tools menu. Note that printing is always 
carried out in WYSIWYG mode.
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5 Formatting Text

4D Write enables you to customize the appearance of documents. You 
can perform basic formatting changes to paragraphs by setting 
paragraph margins, first line indent, alignment, line spacing, and tabs. 
You can also modify selected text to display and print in a different 
font, font size, style, or color. For example, you can select the title of a 
book and make it italic. 

You can use custom style sheets to apply several text attributes at once. 
For example, if you want document headings to appear in 14 point 
text and in the Avant Garde font, you can define a Heading style sheet 
with these attributes. Once a style sheet is defined, you can apply it to 
text anywhere in your document.

In this chapter, you will learn how to:

■ Create headers and footers

■ Set the margins, first line indent, borders and tabs for a paragraph

■ Set text alignment and line spacing

■ Change the font, font size, style, and color attributes of text

■ Manage character and paragraph style sheets

■ Manage colors for the text and its style separately

■ Insert page breaks

■ Insert arrays

■ Manage columns

■ Insert column breaks
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Creating Headers and Footers
Initially, a document consists of only the main body of text. In 
4D Write, the main body of text is called the document portion of the 
text. A document first opens in the Normal view mode. In this mode, 
you can modify anything in the main body of text.

Later, you may want to add headers and footers to your document. The 
header of a document contains material that appears at the top of each 
page, such as the name of the document or your company logo. The 
footer contains material that appears at the bottom of each page, such 
as the chapter name and/or the page number. 

You can display or modify headers and footers only if your document 
is in the Page view mode. 4D Write also allows you to differentiate 
headers and footers depending on which page type they are (first page, 
left page or right page). For more information on this feature, refer to 
“Setting Preferences” on page 78.

❿❿❿❿ To create a header or footer:

1 Choose Page from the View menu.
4D Write displays both header and footer areas.

2 Enter the text you want in the header or footer. 
In addition to entering text, you can add pictures, references to data or 
the current date or page number. A current date reference 
automatically displays the current date. For more information on how 
to insert the current date or the current page number, refer respectively 
to “Inserting the Date and Time” on page 182 or to“Inserting the Page 
Number or the Number of Pages” on page 183. For information on 
referencing data, refer to Chapter 7.

3 To return to the main document, click in the main editing area.
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Resizing Headers 
and Footers

❿❿❿❿ To resize a header or footer area:

1 Choose Page from the View menu.
4D Write displays both header and footer areas and the vertical ruler is 
displayed.

2 Click in the Header or Footer area.
The vertical limits of the area are displayed on the vertical ruler.

3 Place the mouse cursor over the upper or lower limit of the area.
The cursor becomes a double-sided arrow.

4 Drag the upper or lower limit of the area to its new location.

The footer or header area is then modified accordingly.

Formatting Paragraphs

The Ruler The 4D Write ruler appears just below the toolbars. You can use the 
ruler to set margins, vertical separators and tab stops.

The ruler shows the settings for the paragraph in which you are 
working. The Left and Right Margin markers show the margin settings. 
The tab stop markers and the First Line Indent marker indicate where 
the tabs and first line indent are located.

After you press Return (Mac OS) or Enter (Windows), 4D Write creates 
a new paragraph with the same ruler settings as the previous one. This 
lets you continue the document with the same formatting from one 
paragraph to the next. You can use the ruler to change some of the 
settings for the paragraph in which you are typing. When you select 
one or more paragraphs, you can change the settings for all of them at 
once.

First Line Indent 
marker

Left Margin marker

Tab Stop marker

Right 
Margin marker
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The ruler lets you change the position of: 

■ left and right margins

■ tab stops

■ the first line indent.

Displaying and Hiding 
the Ruler

You can hide the ruler when you do not need it by choosing Ruler 
from the 4D Write View menu. To show the ruler again, simply choose 
Ruler from the 4D Write View menu once more. When the ruler is 
displayed, a check mark is displayed next to the Ruler menu command.

Selecting 
Paragraphs

❿❿❿❿ To select a single paragraph:

■ Click anywhere in the paragraph.

❿❿❿❿ To select several paragraphs:

■ Drag through the paragraphs to select them.

❿❿❿❿ To select every paragraph in the body of the document:

■ Choose Select All from the 4D Write Edit menu.

Setting the Margins 
and First Line indent

Using the ruler, you can position the left and right margin for the 
currently selected paragraphs.

On the ruler, grey triangles  mark the left and right margins. 
The First Line Indent marker  indicates where the first line of each 
paragraph begins. 

When you open a new document, the margins are preset based on the 
width of a standard 8.5 inch page. The left and right margins are 
located 2.5 cm away from the paper borders. Using the ruler you can 
change those values as long as they remain smaller than the values set 
for the document margins. When moving the left paragraph margin, 
the first line indent is moved accordingly. 

First Line Indent 
marker

Left Margin marker

Tab Stop marker

Right 
Margin marker
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You can change the location of the left margin, the right margin, and 
the first line indent by dragging their markers to the left or right. All 
three markers move independently and you can position the left and 
right margins to within an inch apart.

❿❿❿❿ To set the left or right margin using the ruler:

■ Drag the Left or Right Margin marker  to the desired position.
4D Write displays dotted lines down the page as guides to help you 
align margins.

Note When dragging the markers, they snap to a grid set to 0.25 cm (or 1/8 
of an inch or 10 pixels). To temporarily deactivate the grid, hold down 
the Command key (Mac OS) or the Ctrl key (Windows) while dragging 
the marker.

❿❿❿❿ To set the left or right document margin using the ruler:

1 Select the Page mode by choosing Page from the view menu.

2 Drag the Left  or Right  Margin marker to the desired position.
4D Write displays margin guides to help you align margins. Left and 
Right margin guides appear as dotted lines when you drag the margin 
markers.

To set the first line indent:

■ Drag the First Line Indent marker .
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Aligning Text 4D Write lets you align text with the left or right margin, center text 
between the margins, or fully justify text so it is aligned with both 
margins like text in newspaper columns. 

You can set text alignment using the text alignment icons on the 
Format toolbar or the menu items in the Paragraph menu. 

❿❿❿❿ To align text with the left margin using the ruler:

■ Click the  icon or choose Align Left from the Paragraph menu.

❿❿❿❿ To align text with the right margin using the ruler:

■ Click the  icon or choose Align Right from the Paragraph menu.

❿❿❿❿ To center text between the left and right margins using the ruler:

■ Click the  icon or choose Align Center from the Paragraph menu.

❿❿❿❿ To align text to both the left and right margins using the ruler:

■ Click the  icon or choose Full Justification from the Paragraph 
menu.

Centered text

Left aligned text

Right aligned text

Format

Text alignment buttons
toolbar
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Setting Line Spacing 4D Write lets you determine the spacing between lines in a paragraph. 
The following figure shows a paragraph with double-spacing and 
another paragraph with single-spacing.

To change line spacing, you can use either the Format toolbar or the 
4D Write Paragraph menu. Both offer single, one-and-a half, and 
double-spacing.

You can also use the Paragraph menu to set the line spacing to a 
different value.

❿❿❿❿ To choose single-spacing:

■ Click the  icon or choose Single Spaced from the Paragraph menu.

❿❿❿❿ To choose one-and-a-half-spacing:

■ Click the  icon or choose 1.5 Line Space from the Paragraph menu.

Double-spacing

Single-spacing

Single-spacing
One-and-a-half spacing
Double spacing
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❿❿❿❿ To choose double-spacing:

■ Click the  icon or choose Double Spaced from the Paragraph menu.

❿❿❿❿ To set a custom value for the line spacing:

1 Select Other... from the Paragraph menu.
The Other Line Spacing dialog box is then displayed:

2 Enter the number of lines that you want to set the new line spacing to.

3 Click OK.

Setting Tabs By default, documents are preset with tab stops every centimeter across 
the page. You can use these tab stops even though they do not appear 
on the ruler. Just press Tab to move the insertion point to the next tab 
stop. You can also set other tab stops anywhere along the ruler. The 
default spacing between tabs can be set in the Preferences dialog box. 
For more information on this point, refer to “Setting Preferences” on 
page 78.

Note When you set a tab stop, any preset tab stops to the left of it are 
removed.

Creating Tabs Using the 
Ruler

❿❿❿❿ To set a tab stop using the ruler:

1 Click on the drop-down menu located on the left of the ruler.
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This menu allows you to select the type of tab stop that you want to 
insert.

2 Select the type of tab stop.

3 Click in the ruler to insert the tab stop.
The tab stop is inserted where you click. You can modify its location by 
dragging it on the ruler.

❿❿❿❿ To move a tab marker:

■ Drag it to the right or left.

Note When dragging the markers, they snap to a grid set to 0.25 cm (or 1/8 
of an inch or 10 pixels). To temporarily deactivate the grid, hold down 
the Command key (Mac OS) or the Ctrl key (Windows) while dragging 
the marker.

❿❿❿❿ To delete a tab marker:

■ Drag it anywhere below the ruler.
For more information, refer to “Changing Tab Alignment and Fill 
Characters” on page 121.

Creating Tabs Using the 
Tabs Dialog Box

When you want to set one or more tabs at the same time for a 
paragraph, it is more convenient to use the Tabs dialog box. Using this 
dialog box you can define the type of a tab stop, its position and the 
fill character you want to use.

4D Write uses different tab markers to indicate tab alignment. 

Note The vertical separator operates like a left-aligned tab but it also displays 
a vertical separator at its location. It is mainly used in tables.

Tab Marker Alignment

Left-aligned
Decimal 
Center-aligned
Right-aligned
Vertical separator
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The following table illustrates the use of tabs and fill characters.

❿❿❿❿ To create a tab setting, follow these steps:

1 Choose Tabs... from the Format menu.
OR
Double-click in the ruler.
The Tabs dialog box appears.

The tab markers defined for the current paragraph are listed in the Tabs 
area. The types of tab markers are listed in the Alignment area. The 
types of fill characters for leaders are listed on the right.

2 Click on the Add button to create a tab stop.
The Add button creates a new entry in the Tabs area.

3 Enter the new position value in the position area.

4 Click the Set button.

Dashes used as 
fill characters

Left-aligned

Decimal

Center-aligned

Right-aligned
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The new position value for the tab is then updated in the Tabs area.

5 Click the Alignment radio button for the type of tab you want.

6 Click the Leading radio button for the fill character you want. 
4D Write lets you select dots, dashes or a solid line. You can also enter 
any character by clicking the Other radio button and by entering the 
fill character you want. 

7 Click OK.
To close the dialog box without putting the changes you made into 
effect, click the Cancel button.

❿❿❿❿ To delete a tab setting, follow these steps:

1 Choose Tabs... from the Format menu.
The Tabs... dialog box appears.

2 In the scrollable area, select the tab you want to delete.

3 Click the Delete button.
The tab stop is removed from the scrollable area.

4 Click the OK button.
The setting for this Tab is removed from the current paragraph.

Changing Tab 
Alignment and Fill 
Characters

❿❿❿❿ To change the type, alignment or fill character of a tab, follow these 
steps:

1 On the ruler, double-click the tab marker.
OR
Choose Tabs... from the Format menu.
The Tabs dialog box appears.

The tab markers defined for the current paragraph are listed in the Tabs 
area. The types of tab markers are listed in the Alignment area. The 
types of fill characters for leaders are listed on the right.

2 Click on the tab stop you want to modify.

3 Enter the new position value in the position area.

4 Click the Set button.
The new position value for the tab is then updated in the Tabs area.

5 Click the Alignment radio button for the type of tab you want.
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6 Click the Leading radio button for the fill character you want. 
4D Write lets you select dots, dashes or a solid line. You can also enter 
any character by clicking the Other radio button and by entering the 
fill character you want. 

7 Click OK.
To close the dialog box without putting the changes you made into 
effect, click the Cancel button.

Setting Bullets 4D Write allows you to set a bullet type for the paragraph currently 
selected. You can choose between six standard bullets (black square, 
white square, black circle, white circle, diamonds and clubs), or set 
your own character as a bullet.

Note Bullets use the Windings font under Windows and the Zapf Dingbats 
font under Mac OS — except the Black Circle bullet which uses the 
current font. 

❿❿❿❿ To select a standard bullet:

1 Choose Bullet from the Paragraph menu.
A hierarchical menu is then displayed.

2 Select the standard bullet you want to display.

❿❿❿❿ To select a customized bullet:

1 Choose Bullet from the Paragraph menu.

A hierarchical menu is then displayed.

2 Select Other...
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The Select Special Character dialog box is then displayed:

3 Select the character you want to use as a bullet.
OR
Enter its ASCII code in the text box.

4 Click OK.
The bullet is then displayed at the beginning of the paragraph and will 
remain as a paragraph setting.

Setting Paragraph 
Formats Using the 
Paragraph Dialog 
Box

Using the Paragraph dialog box you can define various formats for a 
paragraph:

■ The left and right margins

■ The first line indent

■ The bullet character

■ The line spacing

■ The alignment.
1234D Write User Reference Manual



Chapter 5  Formatting Text
The Paragraph dialog box is displayed by selecting Paragraph... from 
the Format menu.

The Paragraph dialog box is divided into three main areas.

■ The Indentation area
This area is where you can set the values for the margins and the first 
line indent.

■ The Format area
This area is where you can set the alignment, the bullets and the line 
spacing.

■ The preview area
This area is the area where the preview of the current properties you 
selected is displayed. Each time you modify the settings of the dialog 
box, the preview is updated.
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The Paragraph dialog box also includes five buttons:

■ The Cancel button closes the paragraph dialog box and cancels any 
modification that was done since it was last opened.

■ The OK button applies the selected formatting to all paragraphs in the 
current selection.

■ The Default button sets all the paragraph formatting back to the 
default values set for the current style sheet (if any).

■ The None button removes any formatting applied to the paragraph.

■ The Revert button reverts the formatting options to their initial values.

❿❿❿❿ To set the margins in the Paragraph dialog box:

1 Check the Indentation check box.
This activates the spaces for entering values for the indents.

2 Enter the values for setting the margins.
Left corresponds to the left margin, Right corresponds to the right 
margin and First line corresponds the first line indent.

❿❿❿❿ To set the alignment:

1 Check the Alignment check box.
When the check box is checked, it activates the drop-down menu.

2 Select the setting you want to use from the Alignment drop-down 
menu.

❿❿❿❿ To select a bullet:

1 Check the Bullet check box.
Once it is checked, it activates the Bullet drop-down menu.

2 Select the setting you want to use from the Bullet drop-down menu.
If you choose the Other... item, the Select Special Character dialog box 
is then displayed. For more information on how to use this dialog box, 
refer to “Setting Bullets” on page 122.

❿❿❿❿ To set the line spacing:

1 Check the Line Spacing check box.
When the check box is checked, it activates the entry area.

2 Enter the line spacing value you want to use.
This number must be expressed in number of lines.
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Setting Colors
4D Write allows you to assign colors to the text and to its style 
attributes separately. You can, for instance, set a different color for a 
piece of text and for the line that underlines it. Different colors can be 
set for the following:

■ Text characters

■ Background of the text

■ Strikethrough line

■ Underline line

■ Shadow effect

■ Border background

■ Border line

Setting a Color 
for a Character

❿❿❿❿ To set a color for the current selection of characters:

1 Select Text in the Colors menu.
A hierarchical menu is then displayed.

2 Select the color you want to apply to the selection.
Once you have selected the color, it is applied to the characters of the 
current selection. If you choose to define a custom color, select Other... 
For more information on how to define a custom color, refer to 
“Setting a Custom Color on Windows” on page 128 or to “Changing 
Several Text Attributes at Once” on page 133, depending on the 
platform you are currently using. 
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Setting a Color for a 
Style Effect

To set a color for a style effect applied to the current selection of 
characters:

1 Select the style effect in the Colors menu.
The corresponding hierarchical menu is then displayed.

Notes • For the Strikethrough and Underline menu commands, an 
“Automatic” item is displayed at the top of the hierarchical menu. 
Selecting this item will assign the color that is currently selected for the 
text.
• For the Back and Borders Back menu commands, a “None” 
command is displayed at the top of the hierarchical menu. Selecting 
this item will assign no color to the corresponding style effect, making 
the background transparent.

2 Select the color you want to apply to the selection.
Once you have selected the color, it is applied to the style effect for the 
current selection. If you choose to define a custom color, select Other... 
For more information, see the following paragraphs. 

Back Strikethrough Underline Shadow Borders Back Borders LIne
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Setting a Custom Color 
on Mac OS

After you choose Other... from the Colors submenu, the Apple color 
picker dialog box appears, enabling you to create a custom color. 

The Apple color picker dialog box will vary according to the Mac OS 
version that you are using and the color chart selected. For more 
information, refer to the Mac OS documentation.

Once you have chosen the color, click OK to apply it to the selection.

Setting a Custom Color 
on Windows

After you choose Other... from the Colors submenu, the expanded 
Color dialog box appears, enabling you to select a basic or custom 
color. Click on the Define Custom Colors button to display the color 
palette. 

New color

List of color charts

Color wheel

Brightness selector

Brightness
Basic colors
 

Custom colors
palette 

Color matrix
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For more information about this dialog box, refer to the Windows 
documentation.

Once you have created a new color, click on the Add to Custom Colors 
button to insert it in the custom colors palette. To apply the new color 
to 4D Write, select it in the custom colors palette and click on OK.

Showing Invisible 
Formatting 
Characters

You can display the characters that show where the Tab, Return (or 
Enter), spaces, hyphens, page breaks and column breaks (in Page mode) 
are located. Ordinarily, these characters are invisible. 

❿❿❿❿ To show invisible formatting characters:

■ Choose Invisible Characters from the 4D Write View menu.
The invisible characters appear: 
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The following table describes each formatting character.

Copying Paragraph 
Formatting

You can copy paragraph settings and apply them to other paragraphs 
to ensure that all paragraphs to which you apply the settings have 
exactly the same formatting. Copying paragraph settings also lets you 
quickly change an element of a document. For example, after you 
change the formatting of a heading, you can easily apply the new 
formatting to headings throughout the document.

The following paragraph format settings are copied. These settings are 
shown in the 4D Write formatting Ruler.

■ Margins and first line indent

■ Alignment

■ Line spacing

■ Tabs

■ Borders

■ Background colors

❿❿❿❿ To copy paragraph formatting:

1 Click in the paragraph whose formatting you want to copy.

2 Choose Copy Ruler from the 4D Write Paragraph menu.
4D Write stores the paragraph settings separately from the normal 
clipboard. The contents of the Clipboard are not affected.

3 Click in the paragraph to which you want to apply the copied settings.
You can apply the paragraph settings to more than one paragraph by 
selecting them before the next step.

4 Choose Paste Ruler from the 4D Write Format menu.
The formatting you copied is applied to the selected paragraphs.

 Character Description

Indicates a tab
Indicates a hard carriage return
Indicates a space
Indicates a soft hyphen
Indicates a page break
Indicates a column break
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Changing Text Attributes
The font, type size, style, and color used for text are text attributes. 
When you create a new document, 4D Write automatically sets the 
font to Arial under Windows or New York under Mac OS, the size to 12 
point, the style to plain, and the color to black. Any text that you type 
will have those attributes.

If you change any text attributes, 4D Write applies the new settings to 
text as you type. You can apply different attributes to text you have 
already typed by selecting the text and then changing the attributes. 
You can view the attributes of any text by clicking within the text and 
choosing Characters from the Format menu or using the Style Toolbar. 
Check marks appear in the menus next to the text attributes that are in 
effect.

Changing the Font All fonts installed in your system appear in the font drop-down list of 
the Style toolbar menu and are available for use in your documents.

❿❿❿❿ To change the font:

1 Select the text you want to change or click where you want to type 
text using a new font.

2 Choose the font from the font drop-down list of the Style toolbar.

If you had selected text before this step, the font of the selection 
changes to the one chosen. If you type new text, it will appear in the 
chosen font.
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Changing Text Size Text size is measured in points. A point is roughly equal to 1/72 inch. 
The font size drop-down list shows sizes ranging from 8 to 72 points.

❿❿❿❿ To change the text size:

1 Select the text you want to resize or click where you want to type 
using a different text size.

2 Choose the size from the font Size drop-down menu.

When you choose a size, it is applied to your selection. 4D Write 
adjusts the line spacing, if necessary, to accommodate the new size.

Note You can enter a value directly into the value box if you want to assign a 
size that is not available in the list. The value must range from 1 to 
255. 

Changing Text Style Styles can help you emphasize text or enhance a document’s 
appearance.

❿❿❿❿ To change the style of text:

1 Select the text you want in a different style or click where you want to 
type using a new style.

2 Choose a style from the 4D Write Style menu.
Styles include Plain, Bold, Italic, Underline, Strikethrough, Shadow, 
Superscript, and Subscript. You can apply more than one style to 
selected text. If you want to modify the case of the selection you can 
also select Capitals or Small capitals.

After you choose a style, your selection changes to the new style and a 
check mark appears next to the style in the Style menu. If a style is in 
effect for only part of your selection, a dash is displayed to the left of 
the style name.

Note If you want to select the Bold, Italic or Underline style you can use the 
respective icons  located in the Style toolbar.
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Changing Several 
Text Attributes at 
Once

You can easily change several text attributes at once. Using the 
Character dialog box, you can change the font, size, color, and style of 
text. You can also set the color for the style effects. These attributes are 
applied to the currently selected text or, if no text is selected, to the 
text that you type.

If you want to use the same combination of attributes many times, you 
can create a custom style sheet. A style sheet specifies a collection of 
attributes. You apply a style sheet to text by selecting the text and 
choosing the style sheet name from the Style Sheet drop-down list in 
the Style toolbar.

❿❿❿❿ To change several text attributes in the Character dialog box:

1 Select Character... from the 4D Write Format menu.
The Character dialog box appears.

The dialog box shows the font, font size, color, and styles currently in 
effect and provides sample text with those attributes.

2 To change the font, choose the font from the Font scrollable list.
OR
Enter its name in the Font area.

3 To change the color for either the text or the style effects selected, 
choose the color from the Colors picture menus.

Current font and font size

Style attributes

Font list

Underline status

Style effects color
Preview area
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You can choose any of the basic colors available in the picture menu or 
create a custom color by selecting Other... For information on creating 
a custom color, refer to the “Setting a Custom Color” sections in this 
chapter.

4 To change the text size, enter the size in the Size area or select a size 
in the Size list.

5 Select the check boxes for the style attributes you want.
Styles include Bold, Italic, Shadow, Strikethrough, Superscript, and 
Subscript. You can also select the character case using the Capitals and 
Small Capitals check boxes. 

■ Clicking once on a check box will select it. 

■ Clicking twice will “gray” it, which means that this attribute will be 
left unchanged in your selection. If, for instance, the Bold attribute 
is set only for certain characters in your selection, the Bold check 
box will appear in grey. Leaving that check box in gray will leave 
the Bold attribute untouched.

■ Clicking a third time will deselect it. When a checkbox is dese-
lected, the attribute will be removed from the selection if it was 
applied; otherwise, it will just be ignored. 

Note Some attributes cannot be selected concurrently. For example, you 
can’t select both the Small Capitals and Capitals attributes. 

6 Select the underline attribute you want in the Underline drop-down 
list.
You can choose Single underline to display only one line under the 
selection, Word underline to underline only individual words, Double 
underline to display two lines under the selection or Hatched 
underline to display a dotted underline.

7 To validate the attributes you set, click OK.
To return to the original text attributes and start over, click on the 
Revert button. To close the dialog box without applying any changes, 
click the Cancel button. To go back to the default settings (if any) that 
apply to the current selection, click the Default button. To remove all 
the attributes for the current text selection, click the Unknown button.
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Managing Style Sheets
4D Write manages two types of style sheets. Style sheets that apply 
only to characters and style sheets that apply to paragraphs. You can 
create your own style sheets in a document. Each character style sheet 
specifies a combination of attributes that can be applied to text. For 
example, you might specify a Header style sheet that creates text in 
18 point, Bold style, in the Avant Garde font. A paragraph style sheet 
allows you to set attributes for a paragraph, which includes the 
character formats, border settings, tab settings and paragraph settings.

The Style Sheet pop-up menu lists the available style sheets for the 
document. You use this menu to apply existing style sheets to the text 
in your document. 

Style sheets apply only to the current document. They do not apply to 
all documents, even if the documents are in a 4D Write area. You can 
save style sheets and load them into other documents. You can also 
use documents containing style sheets as templates for 4D Write areas. 
For more information on templates, refer to the paragraph “Saving a 
Document as a Template” on page 76.

When copying text, 4D Write includes the style sheets present in the 
selection. When pasting, 4D Write checks that each style sheet exists 
in the destination document. If the style sheet does not exist, it is 
created; if the style sheet exists and its properties are identical, it will 
be used. However, if the style sheet exists but its properties are 
different, it is used but the text keeps its original appearance. To use 
the style sheet properties of the destination document, it will be 
necessary to re-apply them.
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Defining a Custom 
Style Sheet

❿❿❿❿ To define a new custom style sheet:

1 Choose Style Sheets... from the Format menu.

The Style Sheets dialog box appears. It displays the list of style sheets 
for the current document. In the center, the preview area can either 
display the definition or a sample of the style sheet currently 
highlighted in the style sheet list.

2 Click the New... button to create a new style sheet.
The following New Style Sheet dialog box is displayed.

This dialog box allows you to specify which properties you want to use 
as a starting point:

■ the current text properties,

■ the properties of an existing style sheet,

■ no text properties at all.

3 Choose the option you want to start with.
Selecting Empty will define no properties for the new style sheet. 
Selecting Using current text properties will assign the properties of the 
current selected text to the new style sheet. Selecting Using a copy of 
style sheet will assign the properties of that style sheet to the new style 
sheet. If you choose this option, you need to select a style sheet from 
the drop-down list located to the right of the radio buttons.
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4 Click the Create button.
The following dialog box is then displayed:

If you chose a starting point that uses preset properties this dialog box 
displays them accordingly. 

In this dialog box you can define a shortcut that will trigger the 
application of the style sheet, edit the name of the style sheet and 
define the settings of the style sheet.

5 Click in the Name text box and edit the name of the style sheet.

6 Click in the Shortcut text box and enter the character you want to use 
as a shortcut.

This character will have to be used with the combination of the 
Command-Shift keys on Mac OS and Ctrl-Shift under Windows.

Note It is recommended that you use numbers as shortcuts in order to avoid 
potential conflicts with normal 4D Write shortcuts.

7 Using the drop-down list, select whether the style sheet will apply to 
paragraphs or to characters.
If you choose Applies to Characters, the Borders, Paragraph and Tabs 
buttons become disabled.
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8 Click the Character button to set the character properties.
For more information on how to set character attributes, refer to 
“Changing Several Text Attributes at Once” on page 133.
If you selected Applies to Characters as the scope of this style sheet, 
you will not need to set any parameters for borders, tabs and 
paragraphs, therefore you can directly go to step 12.

9 Click the Borders button to set the borders properties of the style 
sheet.
For more information on how to set border attributes, refer to “Setting 
Borders for a Paragraph” on page 143.

10 Click the Paragraph button to set the paragraph properties of the 
style sheet.
For more information on how to set paragraph attributes, refer to 
“Setting Paragraph Formats Using the Paragraph Dialog Box” on 
page 123.

11 Click the Tabs button to set the tab properties of the style sheet.
OR
Deselect the Set Tabs check box if you do not want to set tab 
properties.
For more information on how to set tab properties, refer to “Setting 
Tabs” on page 118.

You can now make sure the properties you have defined are correct by 
checking the preview area. If you want to check the style sheet 
definition, click the Description tab control. The preview area will then 
display the settings defined for that style sheet.

12 Click the OK button to create the style sheet.
OR
Click the None button to reset all the settings to zero and start over.
OR
Click the Revert button to go back to the original settings.
OR
Click the Cancel button to cancel all the settings and go back to the 
Style Sheets dialog box.
138 4D Write User Reference Manual



Managing Style Sheets
Once you click OK, the style sheet is automatically saved and the Style 
Sheets dialog box is displayed again.

13 Click the Close button.
This style sheet can then be selected from the Style sheet drop-down 
list. 

Modifying a Style 
Sheet

❿❿❿❿ To modify an existing style sheet:

1 Choose Style Sheets... from the Format menu.
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The Style Sheets dialog box appears. It displays the list of style sheets 
for the current document.

2 In the Styles list, click on the style sheet you want to edit.

3 Click the Edit... button.
The Edit Style Sheet dialog box is then displayed.

The preview area as well as the style sheet settings reflect the current 
settings of the selected style sheet.

4 Modify any style sheet attribute, according to your needs. 
For more information on the Edit Style Sheet dialog box, refer to 
“Defining a Custom Style Sheet” on page 136. 

You can now make sure the properties you have defined are correct by 
checking the preview area. If you want to check the style sheet 
definition, click the Description tab control; the preview area will then 
display the settings defined for that style sheet.

5 Click the OK button to validate the modifications of the style sheet.
OR
Click the None button to reset all the settings to zero and start over.
OR
Click the Revert button to go back to the original settings.
OR
Click the Cancel button to cancel all the settings and go back to the 
Style Sheets dialog box.
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Once you click OK, the style sheet is automatically modified and the 
Style Sheets dialog box is displayed again.

6 Click the Close button.
If the style sheet was already applied in the document, the following 
dialog box appears:

■ Apply style sheet modifications will dynamically apply all modifica-
tions anywhere the style sheet was used.

■ Leave document unchanged will apply modifications only when 
the style sheet is used subsequently. 

Saving and Loading 
Style Sheets

Style sheets created in the Style Sheets dialog box are saved in the 
document file. You can then import the style sheets into any other 
4D Write document.

❿❿❿❿ To import style sheets from another document:

1 Select Style Sheets from the Format menu.
The Style Sheets dialog box appears.

2 Click the Import... button.
An Open File dialog box appears.

3 Select the document from which you want to import the style sheets 
file and click the Open button.
The style sheets are loaded into the document. After the style sheets 
are loaded, they immediately become available to the document.

Imported style sheets are added to existing style sheets. You can import 
style sheets with the same names as existing ones. 

4 Click the Close button.
The Style Sheets dialog box closes.
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Applying Custom 
Style Sheets

Applying a Character 
Style Sheet

❿❿❿❿ To apply a character style sheet to text:

1 Select the text to which you want to apply the style sheet.

2 Choose the character style sheet from the Style Sheet drop-down list 
in the Style toolbar.

OR
Use the shortcut (if any) associated with the style sheet.
The text is given the attributes of the selected style sheet.

Applying a Paragraph 
Style Sheet

❿❿❿❿ To apply a paragraph style sheet to a paragraph or a selection of 
paragraphs:

1 Place the cursor in the paragraph to which you want to apply the 
paragraph style sheet.
OR
Select some text in the paragraph to which you want to apply the 
paragraph style sheet.
OR
Select text that overlaps all the paragraphs to which you want to 
apply the paragraph style sheet.

2 Choose the paragraph style sheet from the Style Sheet drop-down list 
in the Style toolbar.
OR
Use the shortcut (if any) associated with the style sheet.
The paragraph is then given the attributes of the selected paragraph 
style sheet.
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Applying a Style 
Throughout a 
Document

4D Write allows you to update the formatting of all the text in the 
document that uses a particular style sheet. This feature is useful when 
you want to make sure that all the occurrences of text that use that 
style sheet accurately respect the style sheet attributes.

❿❿❿❿ To update a style sheet throughout the document:

1 Select Style Sheets... from the Format menu.
The Style Sheets dialog box is displayed. 

2 In the Styles list, select the style sheet you want to update throughout 
the document. 

3 Click the Apply button.
All the attributes of that style sheet are applied to each occurrence of 
text that uses it. 

Deleting a Style 
Sheet

You can delete a style sheet at any time. Text that uses that style sheet 
will remain unchanged but it will cease to be defined as using that 
style sheet.

❿❿❿❿ To delete a style sheet:

1 Select Style Sheets... from the Format menu.
The Style Sheets dialog box is displayed. 

2 In the Styles list, select the style sheet you want to delete. 

3 Click the Delete button.
The style sheet is deleted as well as any reference to it.

Setting Borders for a Paragraph
4D Write allows you to define borders for a paragraph. A border setting 
can be defined for either a separate paragraph or a paragraph style 
sheet.

The Borders Dialog 
Box

The Borders dialog box is where borders are set. This dialog box is used 
when you design a style sheet that uses border formats or when you 
want to set borders for a paragraph or a set of paragraphs.
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When you click the Borders... button in the Edit Style Sheet dialog 
box, or when you select Borders... from the Format menu, the Borders 
dialog box is displayed:

This dialog box consists of three main areas:

■ The Borders area:

This area is where borders can be selected. It consists of seven check 
boxes and a preview area. The preview area displays the border 
according to the check boxes you selected.

■ The Left, Top, Right and Bottom check boxes
When these check boxes are selected, the corresponding border is 
set for the paragraph. When they are grayed, it means that the cor-
responding border is not selected for each paragraph that belongs to 
the current selection. In this case, leaving the check box untouched 
will leave the setting for that border untouched.

■ The All check box
When this check box is selected, it selects the Left, Top, Right and 
Bottom check boxes and the corresponding borders.
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■ The Between paragraphs check box
When this check box is selected, a border is displayed between the 
paragraphs of the selection (if there is more than one).

■ The From Text check box
When this check box is selected, the entry area located next to it 
allows you to set the distance between the upper, lower, right and 
left limits of the characters and the border lines.

■ The Frame style area:

This area is where the frame of the borders can be selected. Clicking on 
the frame type will assign it to the borders.

■ The Colors area:

This area is where the colors for the border lines and the border 
background will be selected.

Note The last option will display your system Custom color palette. 

Lines picture menu Back picture menu
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The color selected in the Lines picture menu will apply to the line of 
the borders. The color selected in the Back picture menu will apply to 
the background of the borders.

The Borders dialog box also includes five buttons:

■ The Cancel button
This button closes the Borders dialog box. If the Borders dialog box was 
called from another dialog box (Edit Style Sheet, Find or Replace), 
clicking on the Cancel button brings back the dialog box from which it 
was called.

■ The OK button
This button closes the Borders dialog box and validates its contents. If 
the Borders dialog box was called from another dialog (Edit Style Sheet, 
Find or Replace), clicking on the OK button brings back the dialog box 
from which it was called.

■ The Default button
This button assigns the default settings to the Borders dialog box. 
Default settings are typically style sheet settings that were altered for 
the selected paragraph before the Borders dialog box was opened.

■ The None button
This button resets all the settings back to zero in the Borders dialog 
box. Clicking on the None button deselects any borders, frame styles 
or colors.

■ The Revert button
This button assigns the original settings back to the Borders dialog box. 
The original settings are the settings that were first displayed when you 
opened the Borders dialog box.

Line color

Background 
color
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❿❿❿❿ To define and apply a border setting to a paragraph or a selection of 
paragraphs:

1 Place the cursor in the paragraph to which you want to apply the 
border settings.
OR
Select some text in the paragraph to which you want to apply the 
border settings.
OR
Select text that overlaps all the paragraphs to which you want to 
apply the border settings.

2 Select Borders... from the Format menu.
The Borders dialog box is then displayed:

3 Select the borders by clicking on the corresponding check boxes.
For more information about the meaning of these check boxes, refer to 
“The Borders Dialog Box” on page 143.

4 Select the frame type by clicking on the frame in the Frame style area.

5 Select the colors you want to use for lines and backgrounds in the 
Colors area.

6 Click OK to validate the modifications you just made.
OR
Click the None button to reset all the settings to zero and start over.
OR
Click the Revert button to go back to the original settings.
OR
Click the Default button to go back to the default style sheet settings.
OR
Click the Cancel button to cancel all the settings and go back to the 
Style Sheets dialog box.
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Managing Tables
4D Write manages graphical tables, although they are actually stored 
as formatted paragraphs. This means that if a table needs significant 
modification, it is often easier to re-create it. 

4D Write allows you to insert and define graphical tables in your 
documents. For each table you can:

■ Select predefined table templates,

■ Define the number of rows and columns,

■ Set an automatic text format,

■ Set different automatic values and styles for each column,

■ Set different automatic values, colors and styles for specific rows.

The Table Wizard In 4D Write, tables are created and modified using 4D Write’s Table 
Wizard. The Table Wizard is displayed by selecting Table Wizard... in 
the Tools menu.

The Table Wizard appears as follows:
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The Table Wizard mainly consist of three pages and a preview area:

■ The Template page
This page is where you can select a template for the table, define the 
table size and set the global text format.

■ The Columns page
The Column page is where you can define column widths, and assign 
automatic values as well as custom text formats.

■ The Rows page
The Rows page is where you can select the line spacing between rows, 
select predefined values for the first and last rows, and set a color and a 
text format for specific rows.

■ The Preview area
The preview area displays a preview of the table as you set it; 
modifications are displayed on the fly.

The Template Page The Template page is the default page on which the table wizard 
opens:

This page consists of three elements:

■ The Table Type drop-down list:
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Selecting an item from this list will apply the corresponding template 
to the table you are creating.

■ The Size area:

This is where you set the number of rows and columns for the table 
you are creating, by respectively entering these numbers in the Rows 
and Columns boxes. 
You are allowed to create up to 500 rows and 100 columns. 

■ The Text Format area:

This area is where you select the format of the text that will be entered 
in the table. The Font drop-down list lets you select the font that will 
be applied to the text. The Size drop-down list lets you select the size of 
the font that will be applied to the text. The Vertical separator check 
box lets you choose whether you want to display separators between 
columns. When you click the More... button, the Character dialog box 
is displayed. For more information on how to use this dialog box, refer 
to the section “To change several text attributes in the Character dialog 
box:” on page 133.
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The Columns Page The Columns page is where you define the format and automatic 
contents for columns:

This page consists of three main interface elements:

■ The Style for drop-down list:

This list allows you to select the column where the settings in the 
Columns page will be applied. For example, if you select Column 1, the 
settings that will be defined in the Values and Format areas will only 
apply to the first column. If you want to set the format of several 
columns, you will need to select one column at a time and define their 
formats separately.

■ The Values area:

The Values area is where you select predefined values for the current 
column. 
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A radio button offers you three choices:

■ None
If you select this choice, no predefined value will be used for the 
current column.

■ Predefined
This can be used to fill the selected column with values that are 
incremented automatically by 4D Write. If you select this choice, 
the Start Value area is activated. You can select a predefined value 
type from the drop-down list, then set the value with which the 
sequence must start. The sequences of predefined values are the fol-
lowing:
• 1,2, 3, for standard numbering,
• a, b, c or A, B, C for “alphabetical numbering”,
• i, ii, iii or I, II, III for Roman numbering,
• Monday, Tuesday for days,
• January, February for months.
For more information on selecting a predefined value, refer to 
“Inserting a Predefined Value as an Automatic Column Value” on 
page 159.

■ 4D Field
If you select this choice, the field value is then inserted in each row 
and the number of rows will depend on the number of selected 
records. Since you then benefit from the Order by and Query fea-
tures of 4D, you can narrow your record selection and rearrange it. 
For more information on selecting a field as a column value, refer to 
“Inserting a 4D Field as an Automatic Column Value” on page 156.

■ The Format area:

This is the area where you select the format and alignment of the text 
that will be entered in the column. When selected, it overrides the 
format defined on the Template page. It also allows you to define the 
alignment for the text and the column width. This area consists of the 
following elements:

■ The Alignment drop-down list
This list lets you choose the alignment between Left, Centered, 
Right and Decimal.
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■ The Fixed Width check box
When this option is selected, it activates the value box located next 
to the check box. You can then enter a fixed value for the width of 
the current column.

■ The Text Format button
Clicking on this button opens the normal Character formatting dia-
log box, so that you can choose character formatting for the con-
tents of the column. For more information about how to use the 
Character formatting dialog box, refer to the section “To change 
several text attributes in the Character dialog box:” on page 133.

The Rows Page The Rows page is where you define the style, color and automatic 
contents for rows:

This page consists of three main interface elements:

■ The Style for drop-down list:

This list allows you to select the row to which the settings that are 
currently set on the Columns page will apply. For example, if you 
select Odd Rows, the settings that will be defined in the Values and 
Format areas will only apply to the odd rows of the table. If you want 
to set the format for several types of rows, you will need to select one 
type of row at a time and define their formats separately. 
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The types of rows available are:

■ First Row
The chosen settings will only apply to the first row.

■ Odd Rows
The chosen settings will only apply to odd rows, excluding the first 
and last rows.

■ Even Rows
The chosen settings will only apply to even rows, excluding the last 
row.

■ Last Row
The chosen settings will only apply to the last row.

■ The Values area:

The Values area is where you select predefined values for the current 
type of rows. A radio button offers you two choices:

■ None
If you select this choice, no predefined value will be used for the 
current column.

■ Predefined
If you select this choice, the Start Value box is activated. This allows 
you to select a type of predefined value from the drop-down list and 
to define which value to start with. The values you can select are:
• 1,2, 3, for standard numbering,
• a, b, c or A, B, C for “alphabetical numbering”,
• i, ii, iii or I, II, III for roman numbering,
• Monday, Tuesday for days,
• January, February for months.
For more information on selecting a predefined value, refer to 
“Inserting a Predefined Value as an Automatic Row Value” on 
page 159.
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■ The Colors area:

The Colors area is where you can select a color separately for the lines 
and background of the current type of rows.

■ The Format area:

This area is where you select the format and alignment of the text that 
will be entered in the row. When selected, it overrides the format 
defined on the Template page. It also allows you to define the border 
formats. 

This area consists of the following elements:

■ The Line Spacing value box
This box is where you enter the line spacing value for the current 
type of rows.

■ The Leave Empty check box
When this option is selected, the row will remain empty even in 
columns for which you have selected automatic values.

■ The Text Format button
Clicking on this button calls the Character dialog box. For more 
information on how to use the Character dialog box, refer to the 
section “To change several text attributes in the Character dialog 
box:” on page 133.

■ The Borders button
Clicking on this button calls the Borders dialog box. For more infor-
mation on how to use the Borders dialog box, refer to “The Borders 
Dialog Box” on page 143.
1554D Write User Reference Manual



Chapter 5  Formatting Text
Setting Predefined 
Values

4D Write allows you to set automatic values in your tables. There are 
two types of automatic values:

■ 4D fields and 4D formulas,

■ Predefined values such as automatic numbering, months, days.

4D Write allows you to insert 4D fields or formulas in columns only 
and also manages predefined values in both rows and columns.

Inserting a 4D Field as an 
Automatic Column Value

❿❿❿❿ To insert a 4D field as an automatic column value:

1 Select Table Wizard... from the Tools menu.
The Table Wizard is then displayed.

2 Click on the Columns tab control.
The Column page is displayed.

3 In the Style for drop-down list, select the column in which you want 
the 4D field to appear.

4 Choose  in the Value area.

5 Click the Field selection button .
The Insert 4D Expression dialog box is then displayed:
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On the Field page, you can select the field that will be inserted. In the 
Format area, you can select one of the predefined display formats or 
define a specific display format. For more information on display 
formats, please refer to the 4th Dimension User Reference manual. For 
more information on how to use the Insert 4D Expression dialog box, 
refer to “Referencing 4D Fields and Expressions” on page 185.

6 Expand the hierarchical list of the table that contains the field you 
want to insert.

7 Double-click on the field that you want to insert as a value.
It is then displayed in the area next to the 4D Field button.

The numbers of selected records for that table is displayed at the 
bottom of the Values area. For each record, the value of the record will 
be displayed in a row.

8 If you want to select specific records, click the Find... button.
The Query editor is then displayed:

Edit the query as you would in 4D. For more information on queries, 
please refer to the 4th Dimension User Reference manual.
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Once you are done executing your query and if the number of records 
matches the size of the table, the Column page is displayed again and 
the number of records is modified accordingly. If the number does not 
match the array, the following dialog box is then displayed:

If you click on the Leave Unchanged button, the Column page is 
displayed again and the size of the table remains unchanged. If you 
click on the Resize button, the Column page is displayed again with 
the number of rows modified to match the number of records.

9 If you want to modify the sort order, click the Sort... button.
The 4D Order by dialog box is then displayed:

You can then define the sort order. For more information about 
defining the sort order, please refer to the 4th Dimension User Reference 
manual. Once the sort is defined, it is used to set the sequence of 
values in the table.

10 Once you are done defining your selection and sorting it, you are 
finished with the insertion of 4D fields as values.
You can then continue with the creation of the table.
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Inserting a Predefined 
Value as an Automatic 
Column Value

❿❿❿❿ To insert a predefined value as an automatic column value:

1 Select Table Wizard... from the Tools menu.
The Table Wizard is then displayed.

2 Click on the Columns tab control.
The Columns page is displayed.

3 In the Style for drop-down list, select the column in which you want 
the predefined values to appear.

4 Choose  in the Values area.

5 Select the type of predefined value from the Values drop-down list.

For more information on the options you can select, refer to “The 
Columns Page” on page 151.

6 Select the Start Value.
The Start Value is always a number but it will apply to any kind of 
selected value. For example, if you enter 2 as a start value and select the 
month value, the first value will be February.

7 Once you are done with the Predefined value settings, proceed with 
the remainder of the table configuration.

Inserting a Predefined 
Value as an Automatic 
Row Value

❿❿❿❿ To insert a predefined value as an automatic row value:

1 Select Table Wizard... from the Tools menu.
The Table Wizard is then displayed.

2 Click on the Rows tab control.
The Rows page is displayed.
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3 In the Style for drop-down list, select the row type in which you want 
the predefined values to appear.
For more information on the Style for drop-down list, refer to “The 
Rows Page” on page 153.

4 Choose  in the Values area.

5 Select the type of predefined value from the Values drop-down list.

For more information on the options you can select, please refer to 
“The Rows Page” on page 153.

6 Select the Start Value.
The Start Value is always a number but it will apply to any kind of 
selected value. For example, if you enter 2 as a start value and select the 
month value, the first value displayed will be February.

7 Once you are done with the Predefined value settings, proceed with 
the remainder of the table configuration.

Creating a Table Before creating a table, you should check that the element to be 
entered in the table will fit in the columns. Since 4D Write does not 
manage the concept of cells, you must make sure that the columns are 
large enough to contain the data.

❿❿❿❿ To create a table:

1 Select Table Wizard... from the Tools menu.
The Table Wizard is then displayed.

2 On the Template page, select the template by selecting it from the 
Table Type drop-down menu:
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3 Enter the number of rows and columns in the Rows and Columns 
boxes.

4 If you want, define a global character format for the table in the Text 
Format area.
For more information on the effect of the character options, refer to 
“The Template Page” on page 149.

5 Click on the Columns tab control to set the column options.
The Columns page is then displayed.

6 Using the Style for drop-down list, select the column you want to 
modify.

7 For the current column, you can either set predefined values or a 4D 
field as automatic values.
For more information on inserting a 4D field as an automatic column 
value, refer to “Inserting a 4D Field as an Automatic Column Value” on 
page 156. For more information on inserting a predefined value as an 
automatic column value, refer to “Inserting a Predefined Value as an 
Automatic Column Value” on page 159.

8 In the Format area, set the alignment, format and width of the current 
column.
For more information on the options of the Format area, refer to “The 
Columns Page” on page 151.

9 Repeat steps 6 through 8 for each column you want to set.

10 Click on the Rows tab control to set the row options.
The Rows page is then displayed.

11 Using the Style for drop-down list, select the type of row you want to 
modify.
For more information on the types of row you can select, refer to “The 
Rows Page” on page 153. 

12 For the current type of row, you can set predefined values as 
automatic values.
For more information on inserting a predefined value as an automatic 
row value, refer to “Inserting a Predefined Value as an Automatic Row 
Value” on page 159.

13 In the Format area, set the border, formats and line spacing of the 
current row.
For more information on the options of the Format area, refer to “The 
Rows Page” on page 153.
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14 Using the Back and Row picture menus, select a color for the line and 
for the background of the selected type of rows.

15 Repeat steps 11 through 14 for each type of row you want to set.

16 Click OK to create the table.

Note Since 4D Write does not manage cells in tables as rows and columns, 
once a table is created it is usually easier to create it again than to 
modify it.

Managing Columns
4D Write allows you to manage text columns in your documents. 
When you set columns in a 4D Write document, they apply to the 
whole document. In 4D Write, columns are chained from the left-most 
column to the right-most column. In other words, when entering text, 
the text flow will start filling the left column and continue with the 
column directly to the right until it reaches the end of the page. Once 
the end of the page is reached, the text flow cycles through the next 
page. In order to be able to balance the page settings, 4D Write also 
allows you to insert column breaks.

Note For a proper display of columns, you should always select the Page 
viewing mode.

The current section will describe how to:

■ Set columns in a document,

■ Modify columns in a document,

■ Insert and remove a column break in a column.
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The Columns Dialog 
Box

The Columns dialog box is where you define the column settings for 
the current document. The Columns dialog box is displayed by 
selecting Columns... from the Format menu:

It consists of two main areas:

■ The Columns area
This area is where you can define the number of columns, their width 
and the space between them.

The Columns area includes the following interface elements:

■ The Number drop-down list:
This list allows you to select the number of columns that will 
appear in the document. No more than ten columns can be created.

■ The Width box
This box is used to set the width of the columns. The value entered 
is applied to each column and has no influence on the number of 
columns. If there is not enough room to accommodate the value 
entered, 4D Write will select the highest possible value and reduce 
the Spacing value accordingly.

■ Spacing
This box is used to set the space between columns. If there is not 
enough room to accommodate the value entered, 4D Write will 
select the highest possible value and reduce the Width value accord-
ingly. 4D Write will always maintain a minimum value for the col-
umn width.
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■ The Vertical separator check box
When this check box is selected, a vertical separator is displayed 
between the columns.

■ The Preview area
This area displays in real-time the effect of the value you are entering 
in the Columns area.

Setting Columns for 
a Document

❿❿❿❿ To define columns in a 4D Write document:

1 Select Columns... from the Format menu.
The Columns dialog box is then displayed:

2 Choose the number of columns from the Number drop-down list.
The preview area is modified accordingly.

3 Enter the value for the column width in the Width area.
OR
Enter the value for the space between columns in the Spacing area.
Setting only one of these two values lets 4D Write assign a 
complementary value to the other one.

4 Click the OK button.
The 4D Write document is modified according to the column settings.
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Modifying the 
Column Width 
Using the Ruler

❿❿❿❿ To resize a column:

1 Choose Page from the View menu.
The 4D Write ruler displays the column limits.

2 Place the mouse cursor over the column limit.
The cursor becomes a double-sided arrow.

3 Drag the limit of the column to its new location.
The column is then modified accordingly.

Modifying the 
Column Settings

❿❿❿❿ To modify the column settings of a 4D Write document:

1 Select Columns... from the Format menu.
The Columns dialog box is then displayed:

Its contents reflect the current settings.

2 Choose the settings you want to modify.
You can modify any parameter from the number of columns to their 
size. For more information on the options you can set, refer to “The 
Columns Dialog Box” on page 163.

3 Enter the value for the column width in the Width area.
OR
Enter the value for the space between columns in the Spacing area.
Setting only one of these two values lets 4D Write assign a 
complementary value to the other one.
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4 Once you have defined the new settings, click the OK button.
The 4D Write document is modified according to the new column 
settings.

Note When modifying the column settings you may want to check the 
position of column and page breaks, since they may need to be moved 
to match the new settings.

Managing Column 
Breaks

Inserting a column break moves characters or paragraphs located after 
the insertion point to the top of the next column. You can use column 
breaks to balance your columns. When inserted, a column break 
appears as follows:

Column breaks are automatically displayed when the invisible 
characters are displayed. In Normal view mode, column breaks are 
always displayed. In Page view mode, they are displayed only when the 
invisible characters are displayed.

❿❿❿❿ To insert a column break:

1 Select Page from the View menu, if you are in the Normal view mode.
The Page view mode is selected and the borders of the columns are 
properly displayed.

Note To work with columns, you must be in Page view mode.

2 Place the cursor where you want to insert the column break in the 
column.
This action establishes the insertion point.

3 Select Column Break from the Insert menu.
The column break is then inserted and any paragraph that was located 
after the insertion point is moved to the next column.

❿❿❿❿ To remove a column break:

1 Click just after the column break, i.e. at the top of the following 
column.

2 Press Backspace.

OR:
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1 Click just before the column break, i.e. at the end of the previous 
paragraph.

2 Press Delete.
The column break is deleted.

Creating a Page Break
4D Write manages page breaks itself when necessary. However, you can 
also set page breaks manually. Specifying where a page break occurs 
can improve the appearance and layout of a document.

❿❿❿❿ To create a page break:

1 Click at the location where you want the page break to occur.
This action establishes the insertion point.

2 Choose Page Break from the 4D Write Insert menu.

In the Normal view mode (and in Page view mode when invisible 
characters are displayed), a dotted horizontal gray line marks the page 
break.

In the Page view mode, a new page is created as shown.

All text to the right of and below the insertion point moves to the top 
of the next page.
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❿❿❿❿ To remove a page break:

1 Click just after the page break to be removed, i.e. at the top of the 
next page.

2 Press Backspace.

OR:

1 Click just before the page break to be removed, i.e. at the end of the 
previous paragraph.

2 Press Delete.
The page break is deleted.
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4D Write allows you to paste pictures into the header, footer, or main 
body of your document. You can use any picture that you can copy to 
the Clipboard. After you paste a picture into a document, you can 
manipulate it in the following ways: move, scale, resize, hide or delete 
the picture.

This chapter describes the 4D Write built-in features for managing 
pictures:

■ Inserting a picture,

■ Resizing a picture,

■ Moving a picture,

■ Hiding and displaying a picture,

■ Deleting a picture.

Inserting a Picture
To insert a picture into a 4D Write document you have two 
possibilities:

1 Copy a picture from the Clipboard and then paste it into the 4D Write 
document using standard commands. 
4D Write allows you to paste pictures that are in the following formats: 
PICT, Bitmap (BMP), and EMF (Windows only).

OR:

2 Insert a 4D picture type expression (field or picture variable).
For more information on inserting 4D expressions, please refer to the 
chapter “Using Dynamic References” on page 181.
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Inserting a Picture in 
the Text or in the 
Page

When you insert a picture in a 4D Write document you have two 
different methods of inserting the picture: you can paste the picture in 
the text flow or in the page. The Paste Picture dialog box appears:

A radio button allows you to select one of two different modes:

■ Paste Picture in Text flow 
Choosing this option will insert the picture in the text flow at the 
insertion point. The picture is controlled by the same page settings 
(such as margins, etc.) as the paragraph into which it is inserted.

■ Paste Picture in Page 
Choosing this mode will anchor the picture to the page, at a set 
location. You can thus manage it separately from the document 
paragraphs. 
The picture is inserted as a background graphics. It is not anchored 
with respect to the text on the page.

When this option is checked, you can set additional parameters 
concerning the placement of the picture. Part of these parameters 
depend on the configuration of the document set in the Preferences 
(for more information about this, refer to the section “Setting 
Preferences” on page 78). 
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Here are the different placement options in accordance with the 
preferences chosen: 

■ in current page
The picture only appears in the current page. 
If, for example, you paste the picture on page 4 and, later on, the 
document has only 2 pages, the picture will no longer appear. 
This option is available regardless of the document configuration.

■ in all pages
The picture appears on each page of the document. This option is 
available when neither of the options concerning the document 
configuration is checked.
OR

■ in all pages (except page one)
This option is available when only the Different on first page property is 
checked. The picture will appear on each page of the document except 
the first one. If you want to insert the picture on the first page, go to 
this page and paste the picture using the “in current page” option.
OR

Preferences Placement options
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■ in right pages (except page one)
This option is available when both the Different on first page and 
Different on left and right pages properties are checked. The picture will 
appear on each right-hand page of the document, except for the first 
page (if it is a right page). If you want to insert the picture on the first 
page, go to this page and paste the picture using the “in current page” 
option.
OR

■ in right pages
This option is available when only the Different on left and right pages 
property is checked. The picture will appear on each right-hand page 
of the document.

■ in left pages (except page one)
This option is available when both the Different on first page and 
Different on left and right pages properties are checked. The picture will 
appear on each left-hand page of the document, except for the first 
page (if it is a left page). If you want to insert the picture on the first 
page, go to this page and paste the picture using the “in current page” 
option.
OR

■ in left pages 
This option is available when only the Different on left and right pages 
property is checked. The picture will appear on each left-hand page of 
the document.

■ Behind Text
The picture will be pasted in the background of the text, which means 
that the text will appear over the picture. Otherwise, the picture will 
cover the text. This option is available regardless of the document 
configuration.

Note In the Normal view, if you choose to insert a picture into the page, the 
picture is inserted and the page is automatically switched to the Page 
view. A check mark will appear next to the Page mode in the View 
menu.

Modifying Picture 
Properties

You can modify the properties of pictures in a 4D Write document at 
any time. These properties are related to position, dimensions and the 
picture’s display mode. The available properties depend on the way the 
picture was inserted (in the text flow or in the page) and the picture 
type (static picture or picture type reference).
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❿❿❿❿ To modify a picture’s properties:

1 Double-click on the picture

Note If the picture is inserted in the page and behind the text, hold down the 
Ctrl (Windows) or Command (Mac OS) key while double-clicking. 

The Picture Properties... dialog box appears,.

2 Modify the properties of the picture

■ The properties of the Position area (for pictures pasted in the page 
only) are described in the section “Moving a Picture” on page 176.

■ The properties of the Dimensions area are described in the follow-
ing paragraph.

■ The properties of the Place Picture area (for pictures pasted in the 
page only) are described in the section “Inserting a Picture in the 
Text or in the Page” on page 170.

■ The properties of the Reference and Display Mode areas are 
described in the section “Picture Display Mode” on page 177.

Scaling a Picture
You can reduce or enlarge a picture pasted in 4D Write in either of the 
following manners:

■ By entering values in the Picture Properties dialog box of the picture,

■ Manually, by pulling on the corners of the picture.

In addition, you can define resizing settings for inserted picture type 
expressions.

Resizing a Picture To resize a picture by entering values:

1 Double-click the picture you want to resize.

Note If the picture is inserted in the page and behind the text, hold down the 
Ctrl (Windows) or Command (Mac OS) key while double-clicking. 
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The Picture Properties dialog box appears. The appearance of this 
dialog box depends on whether the picture was inserted in the text or 
in the page.

2 Define your resize options.

■ Keep proportions
When this option is selected, the “Width” and “Height” entry areas 
are automatically linked to the original dimensions of the picture 
(once it has been resized).

■ Relative
When this box is checked, this option allows you to define the resiz-
ing of an object as a percentage (in relation to the original size of 
the picture).
Otherwise, the dimensions of the picture must be defined in the 
standard unit of the document.

3 Enter values in the “Width” and “Height” areas
If you have checked the Keep proportions option, you only need to 
enter a value for one area.

4 Click OK.
4D Write automatically resizes the picture according to your selected

settings.

❿❿❿❿ To manually resize a picture: 
1 Click the picture you want to resize. 

Note If the picture is inserted in the page and behind the text, hold down the 
Ctrl (Windows) or Command (Mac OS) key while double-clicking. 

Resize options

Picture in Text flow Picture in Page
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Selection handles appear around the picture. The cursor becomes a 
double-arrow cursor when you drag the mouse over one of the 
selection handles.

2 Click on one of the selection handles and resize the picture by 
dragging the mouse. 

■ Use any of the lateral selection handles to enlarge or stretch the pic-
ture.

■ Use any of the corner selection handles to simultaneously resize 
both dimensions.

Note If you wish to conserve the picture’s proportions while manually 
resizing it, simply press the Shift key while moving a corner selection 
handle.

Setting Reference 
Sizes

The Fixed Size option in the Picture Properties dialog box lets you set 
the size of inserted picture type expressions.

In fact, the size of pictures inserted by reference can vary from one 
document to another.

Cursor

Lateral selection handles

Corner selection handles

Size of the 4D reference

Picture in Text flow Picture in Page
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■ If the Fixed Size option is checked, the display rectangle will be 
kept, once the expression has been calculated, regardless of the 
dimensions of the new picture.

Note The resizing mode can also be defined in the “Display Mode” area (see 
“Picture Display Mode” on page 177).

■ If the Fixed Size option is not selected, the display rectangle will be 
adjusted, once the expression has been calculated, to the new 
dimensions of the picture.
The Edit... button allows you to display the expression selection dia-
log box.

Moving a Picture

Picture in Text Flow A picture located in the text flow of the document can only be moved 
using the standard copy/paste functionalities or drag and drop, since it 
is managed as a character. For more information on dragging and 
dropping, refer to the section “Dragging and Dropping Text” on 
page 91. 

Picture in Page When you paste a picture in the background of the page, it appears in 
the upper left corner of the page. You can move the picture to any 
location you wish on the page.

❿❿❿❿ To move a picture inserted in the page:

1 Click on the picture and drag it directly to the desired location using 
the mouse. 

OR

1 Double-click on the picture.

Note If the picture is inserted behind the text, hold down the Ctrl (Windows) 
or Command (Mac OS) key while clicking/double-clicking. 
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The Picture Properties dialog box appears.

2 Enter the new picture coordinates in the Position area
These values are displayed in the standard unit of the document (as 
defined in the Preferences dialog box) and are relative to positioning 
on the left and top of the page.

3 Click OK.

Picture Display Mode
The Picture Properties dialog box features a menu allowing definition 
of the mode in which inserted pictures are displayed. This menu 
determines picture display inside the frame whose size is defined 
within the “Dimensions” area.

Position area
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These settings are useful in case of picture resizing or inserting pictures 
of different sizes.

For example, you want to insert the two following pictures in frames 
with different sizes:

The following display options are available:

■ Truncated (non-centered)

■ Truncated (centered)

Picture Display Mode

Picture in Text flow Picture in Page

Original Pictures
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■ Mosaic

■ Scaled to fit

■ Scaled to fit (proportional)

■ Scaled to fit centered (proportional) 
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Hiding and Showing Pictures
Hiding all of the pictures in a document lets you scroll more rapidly. 
4D Write is preset to show pictures. 

❿❿❿❿ To hide all pictures:

■ Choose Pictures in the 4D Write View menu.
4D Write replaces each picture with a box that has the same 
dimensions. When pictures are hidden, the check mark next to the 
Pictures menu command is removed. 

❿❿❿❿ To show all pictures:

■ Choose Pictures from the 4D Write View menu once again.

Removing a Picture
You can remove a picture from your document by deleting it, cutting 
it, or replacing it with text.

❿❿❿❿ To permanently delete the picture:

1 Click on the picture you want to remove.

Note If the picture is inserted in the page and behind the text, hold down the 
Ctrl (Windows) or Command (Mac OS) key while double-clicking. 

2 Choose Clear from the 4D Write Edit menu, or press the Backspace or 
Delete key.

❿❿❿❿ To remove the picture and copy it to the Clipboard:

1 Select the picture.

2 Choose Cut from the 4D Write Edit menu.

❿❿❿❿ To replace the picture with text:

1 Select the picture.

2 Type the text.

Notes • You can replace a picture by text only when it was inserted in the text 
flow.
• You cannot undo the deletion of a picture that has been pasted in the 
page.
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7 Using Dynamic 
References

4D Write allows you to use dynamic references in your documents. 
Dynamic references are objects whose content is calculated at the 
moment of their insertion, update, or if they simply provoke a certain 
action.

For example, 4D Write allows you to insert standard references, such as 
the current date and time or the page number.

Dynamic references can also be information coming from your 
4th Dimension database. For example, you can create a standard letter 
that you will personalize for each person registered in your database. 
To do this, you simply need to reference the First name and Last name 
fields from your database into your document.
4th Dimension and 4D Write interactions are not limited just to fields 
though. You can use any 4D expression to complete complex tasks 
such as calculating totals or text concatenation. For example, you can 
calculate and insert an employee’s annual salary into your document.

4D Write contains several particular functions that allow you to insert 
“raw” HTML code as well as various types of hyperlinks into your 
documents.

This chapter describes the following operations:

■ Inserting standard references (date and time, page number or number 
of pages),

■ Inserting fields and 4D expressions,

■ Inserting HTML expressions,

■ Inserting hyperlinks,
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■ Freezing reference values,

■ Updating references.

Inserting the Date and Time

Inserting the 
Current Date and 
Time

4D Write allows you to insert the current date and time in a document. 
The date and time can either be dynamically updated or can keep the 
value they had at the time of the insertion.

❿❿❿❿ To insert the current date or the current time or both:

1 Click where you want to insert the date and time.

2 Select Date and Time... from the Insert menu of 4D Write.
The Insert Date dialog appears:

3 Select the date format from the left scrollable list if so desired. 
Otherwise, click on <no date>.
The date will appear in the preview area according to the format you 
entered.

4 Select the time format from the right scrollable list if so desired. 
Otherwise, click on <no time>.
The time will appear in the preview area according to the format you 
entered.

5 Select the Automatic update check box, if you want to be able to 
update the date and time values in the document at a later time.

6 Click the OK button.
The date or time (or both) you selected are then inserted in the 
4D Write document.
182 4D Write User Reference Manual



Inserting the Page Number or the Number of Pages
Shortcut for 
Inserting Current 
Date

If you want to insert the current date into the header or footer of your 
documents, you can use the Insert Current Date shortcut found in the 
contextual menu of 4D Write:

Note For more information about the contextual menu of 4D Write, refer to 
“The Contextual Menu” on page 52. 

This command is only available when you click on a page header or 
footer in the document (which must be displayed in Page mode). The 
date is inserted as static text and not as a reference. 

Updating the Date 
and Time

Provided you selected the Automatic update check box when you 
inserted the date and time value, you can update the date and time 
and any time. To do this, select the Compute References Now 
command in the 4D Write Tools menu.
Keep in mind that this information will also be updated automatically 
each time the document is opened. 

Inserting the Page Number or the Number of Pages
4D Write allows you to easily insert page numbers in your documents. 
You can place them in the headers, footers or even in the body of the 
document.

■ If you insert the page number in the header or footer of the document 
(when working in Page mode), it is automatically updated for each 
page of the document. This allows you to number your pages.

■ If you insert the page number in the body of the document, it displays 
the current page number and will be updated if that page is modified, 
however it will not be repeated for each page. This allows you to 
reference the page numbers of your document.

Insertion of date into page header or footer
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In addition, 4D Write allows you to insert a variable displaying the 
total number of pages of the document. The value is automatically 
updated when the number of pages is modified.

❿❿❿❿ To insert the page number:

1 Click where you want to insert the page number.

2 Select Page Number... from the Insert menu.
The Insert Page Number dialog box appears:

The menu located at the top of the window allows you to select the 
type of pagination variable to insert.

3 Select “Page number” or “Total number of pages” from the menu 
according to your needs.

4 Click one of the following display formats:
You can choose:
• 1,2, 3, for standard numbering,
• a, b, c or A, B, C for “alphabetical numbering”,
• i, ii, iii or I, II, III for Roman numbering.

5 Click the OK button.
The number of the current page or the total number of pages is then 
inserted at the insertion point. 
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Shortcut for 
Inserting Page 
Number

If you want to insert the page number into the header or footer of your 
documents, you can use the Insert Page Number shortcut found in the 
contextual menu of 4D Write:

Note For more information about the contextual menu of 4D Write, refer to 
“The Contextual Menu” on page 52. 

This command is only available when you click on a page header or 
footer in the document (which must be displayed in Page mode). 

Referencing 4D Fields and Expressions
You can insert 4D fields and expressions into a 4D Write document. 
You can display the referenced data either as references or as their 
immediately calculated values based on data from your 4th Dimension 
database.

When fields and expressions are shown as references, they are 
displayed with a grey background and surrounded by reference (« ») 
symbols. 

Insertion of page number
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The following figure shows the use of references in a form letter. The 
letter uses field references for the person’s name and address and an 
expression for the letter’s date.

When the references are converted to values, the values are displayed 
as regular text.

The values from field references and expressions always refer to the 
current record. They are updated whenever the current record changes.

If there is no current record, these values are blank.

Field references for 
name and address

Expression
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Inserting a 
4th Dimension Field

You can insert the contents of a field in a 4D Write document. The 
field information displayed is dynamic. If you change the information 
in the current record, it will be updated when you select Compute 
References Now from the Tools menu of 4D Write or when the 
document is opened subsequently.

4D Write also allows you to insert data into a table in your document 
using the Table Wizard. For more information, refer to “Managing 
Tables” on page 148

You can display and print data from the current record. When the 
document is displayed in a form, the current record is the record being 
displayed. When the document is displayed in an external window, 
the current record is the record currently open on the screen.

You can print merge data from a selection of records to create form 
letters and reports that draw information from each record in the 
selection. For information on printing merge documents, refer to 
“Printing a Merge Document” on page 204.

You can insert a 4th Dimension field using the Insert menu commands 
or the contextual menu (see “The Contextual Menu” on page 52). 

❿❿❿❿ To insert a 4th Dimension database field into a 4D Write document:

1 Click where you want the field to be located and choose the 4D 
Expression... command in the Insert menu.
OR
Right-click (Windows or Mac OS) or Control+click (Mac OS) where you 
want the field to be located and choose the 4D Expression... command 
from the contextual menu. 

Contextual menuInsert menu
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The following dialog box is displayed.

The hierarchical list displays the names of your database tables.

2 Expand the table in which the field is located.

3 Select the field by clicking it in the Field list.
The display formats that match the type of field you just selected are 
displayed in the Format list.

4 If you want to apply a display format to that field, select one from the 
Format area.
OR
Enter a new display format in the editing area located above the 
Cancel button.
For more information about display formats, refer to the 4th Dimension 
Design Reference manual.
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5 Click OK.
The field is added to your document.

Note If the field is a Picture type, the “Paste Picture” dialog box will be 
displayed (see the chapter “Working with Pictures” on page 169.)

Viewing Field Values To view the field values, you must show the values for the referenced 
data. For more information, refer to “Showing References or Values” 
on page 198.

Note Remember that displaying values does not compute references. 

Modifying Field 
References

You can modify included field references at any time regardless of 
whether the values or the references are displayed. You can replace the 
inserted field by another field or by an expression, or even modify its 
display format1. 

❿❿❿❿ To change the field reference:

■ Double-click the field reference.
The Insert 4D Expression dialog box is displayed, enabling you to 
change the field reference.

Inserting a 4D 
Expression

You can insert valid 4D expressions in a document. The following can 
be inserted:

■ 4th Dimension variables

■ Formulas

■ Certain 4th Dimension functions

■ Project methods (under certain conditions)

■ Plug-in functions (through project methods).

Note Only project methods that are explicitly authorized by the 4D 
developer using the SET ALLOWED METHODS command can be inserted 
in a 4D Write document. For more information, refer to the 
4th Dimension Language Reference manual. 

1. With the exception of Picture type fields when the display mode is ‘Val-
ues’.
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Inserting expressions enables you to use the power of 4th Dimension’s 
procedural language within 4D Write documents. You can perform 
calculations, concatenate information from several fields, and so forth.

The following are examples of expressions:

If an expression returns text that includes carriage returns and tabs, 
4D Write formats the text according to the settings of the paragraph in 
which the expression is inserted.

❿❿❿❿ To insert an expression:

1 Click where you want the expression to be located.
The insertion point should now be blinking.

2 Choose 4D Expression... from the Insert menu.

Expression Comment
MyVar A 4th Dimension variable
Current time A 4th Dimension function
Current date-vDate A statement that performs a calculation
Salutation A project method that returns a value (must 

have been explicitly authorized)
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The following dialog box is displayed, listing the database tables by 
default.

3 Click the Expression tab control.
The Expression page is then displayed.

4 Click the Edit... button.

Tabs for selecting 
type of 4D expression

List of expressions 
(empty by default)
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The 4D Formula Editor is then displayed.

This editor displays a list of the database fields, a list of operators and a 
list of 4D commands authorized by default in formulas. 
This third list also contains, when applicable, the names of project 
methods that are “allowed” in formulas. If you want the 4D Write user 
to be able to reference project methods, they must be declared 
explicitly using the SET ALLOWED METHODS command. Similarly, if 
you want for the user to be able to access 4D Write commands (for 
example, WR Count) or 4D commands that cannot be accessed by 
default, you must create and authorize project methods that 
specifically call these commands. For more information, refer to the 
4th Dimension Language Reference manual. 

5 Enter the formula or 4D variable to be inserted. 

■ To build your formula, use the different lists available. For more 
information about using the Formula editor, refer to the 
4th Dimension User Reference manual.

■ To reference a variable, simply enter its name in the entry area. War-
ning: In order for a 4D variable to be inserted into the document, it 
must already exist (i.e. have been set) in the current process. 

6 Click OK to validate your expression.

Tables and fields

Operators

Authorized commands 
(and methods)

Formula editing 
area
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The Insert 4D Expression dialog box is displayed again. This time the 
contents of the Expression page reflect the 4D expression you just 
edited:

7 If you want to apply a display format to this expression, select one 
from the Format area.
OR
Enter a new display format in the editing area located above the 
Cancel button.
For more information about display formats, refer to the 
4th Dimension Design Reference manual.

8 Click OK to insert your 4D Expression in the document.

Viewing Expression 
Values

To view the values of the expressions, refer to “Showing References or 
Values” on page 198. 

Note Remember that displaying values does not compute references. 

Modifying Expressions

❿❿❿❿ To modify an expression:

■ Double-click the expression in the 4D Write document.
The Insert 4D Expression appears, allowing you to change the 
expression.
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Inserting HTML Expressions
4D Write allows you to insert HTML expressions within your 
documents. These expressions will not appear in the original 4D Write 
document but will be inserted as raw HTML once the document is 
saved in HTML format. The HTML text will be interpreted directly by 
Web browsers; it can thus handle any kind of HTML tags. 

❿❿❿❿ To insert an HTML expression:

1 Choose HTML Expression... in the Insert menu.

The following dialog box is displayed:

2 Directly enter or paste HTML code.
194 4D Write User Reference Manual



Inserting HTML Expressions
4D Write accepts any kind of HTML expression (URLs, style tags, 
pictures, etc.).

3 Click the OK button to validate the dialog box.

Note You can use the Ctrl+Return (Windows) or Command+Return 
(Mac OS) keyboard combination to validate the dialog box.

By default (in “Display values” mode), the inserted HTML expression is 
invisible in the document.

4 Save the page in HTML format in order to view the resulting HTML 
expression with a Web browser. 

Viewing and Modifying 
HTML Expressions

You can view the code if you have selected the References command 
in the View menu. For more information on this subject, refer to the 
section “Showing References or Values” on page 198.

When references are displayed, you can also modify HTML code by 
selecting the inserted selection and then choosing the HTML 
Expression... command once again in the Insert menu or by double-
clicking on the expression reference.
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Inserting Hyperlinks
You can insert hyperlinks in your 4D Write documents. These links 
can be any of the following types:

■ URLs (links for HTML navigation),

■ 4D methods (executed with a mouse click),

■ Document access paths.

❿❿❿❿ To insert a hyperlink in a 4D Write document:

1 Choose the Hyperlink... command in the Insert menu.

The Hyperlinks... dialog box is displayed:

2 Enter the link label to appear in the page in the “Text to display” area.

3 Check the “Use URL style” option if you wish to modify the 
appearance of a link.
When this option is checked, the inserted link (regardless of its action) 
takes the default appearance of hyperlink (blue underlined text that 
becomes purple once the link has been viewed). These default colors 
can be modified through programming by using the WR SET 
DOCUMENT PROPERTIES command. When this option is not checked, 
the link’s style is not changed;
you can customize the link.
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4 In the “HyperLink action” area, define the action to be executed once 
the user clicks on the link.
Three actions are available to you:

■ Execute 4D Method: Clicking the link results in the execution of 
the 4D method whose name you listed. You must enter just the 
name of the method.
At the moment of execution, the method received three values in 
the $1, $2, $3 settings: $1 is the 4D Write area reference, $2 is the 
visible label of the link and $3 contains the arbitrary numeric value 
that you optionally entered in the “Reference” area. This value, for 
example, allows you to identify the link.
If an error occurs (for example, the method doesn’t exist), 4D Write 
does nothing.

■ Open URL: Clicking on the link will open (if necessary) your 
machine’s default Web browser and display the defined URL. You 
can enter any type of valid URL. If an error occurs (for example, the 
URL is not valid), the browser will display an error page.

■ Open Document: Clicking the link results in the replacement of 
your current document with the one that you entered in the access 
path. This access path is absolute and uses the syntax of the current 
platform (under Windows, it must be similar to 
C:\Folder\Folder2\Doc.4W7, under Mac OS it must be similar to 
Disk:Folder:Folder:Doc).
Click on the button to the right of the area to display a standard 
open document dialog box that will allow you to set which docu-
ment to open.
If an error occurs (for example, the document does not exist), 
4D Write does nothing.

5 Validate the dialog box.

Viewing and Modifying 
Hyperlinks

When the View/References command is checked, 4D Write displays 
the type of hyperlink (“Open Document,” “URL,” or “4D Method”) as 
well as the link content. For more information on this point, refer to 
the section “Showing References or Values” on page 198.

❿❿❿❿ To modify the type, the content or the options for a hyperlink:

■ Select the link in the page (be sure not to include additional charac-
ters in the selection) and then choose the Hyperlink... command in 
the Insert menu once again.
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■ You can also, in “Display references” mode, double-click on a 
hyperlink reference.

The “Hyperlink” dialog box appears with the current link properties. 

Showing References or Values
When you insert a 4th Dimension expression, 4D Write displays the 
current value of the expression. If you wish to know which field or 
expression is displayed, you must tell 4D Write to display references 
(by choosing References in the View menu). The field or expression 
references (surrounded by << >> characters) that you have inserted 
then appear in your document.

The following table recapitulates the displayed information in terms of 
the type of dynamic reference and the selected display mode: 

Value display Reference display

Date and time Value at moment of insertion “Date and time” label1

Numbers and page numbers Value at moment of insertion
“Page number” and “Number of
pages” labels2

4D fields Field value in current record Field name
4D expressions Result of expression Expression code
HTML expressions Nothing is displayed3 HTML code
Hyperlinks: Method

Label of the link set in the insert 
link dialog box

“URL:” + link content
Hyperlinks: URL “4D Method:” + link content
Hyperlinks: Document “Open Document:” + link content

1. If the “Automatic update” option was checked at the moment of insertion. Refer to the section “Updat-
ing the Date and Time” on page 183
2. Unlike other dynamic references, these values are always automatically updated.
3. Viewing an HTML expression only takes place through an intermediary Web browser (refer to the sec-
tion “Inserting HTML Expressions” on page 194).
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The following windows illustrate examples of dynamic references 
displayed in terms of values and references:

The following example illustrates an HTML expression displayed as a 
reference and the result in a Web browser:

Display values 
(by default)

Date
Page Number
Hyperlink
4D Expression

Number of pages

Display references 

4D Write

Web Browser
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❿❿❿❿ To show the references or the values in a document:

1 Choose References from the View menu.
When references are shown, a check mark is displayed next to the 
References menu command. When values are displayed, the check 
mark is no longer displayed. 
You switch from one display mode to the other one by selecting the 
References menu command alternatively. 

Note This command does not compute references. To do this, refer to the 
section “Computing References” on page 201.

When values are displayed, you can “freeze” them, that is, convert the 
current value into static text and delete the reference. 

Freezing References
Once the values are displayed, you may wish to “freeze” them. 
Freezing references converts their currently displayed values to regular 
text and removes the associated references. This enables you to keep a 
permanent record of a document or portion of a document you 
created. For example, you can freeze a report containing financial data 
so that any further modifications to the data do not impact the report.

❿❿❿❿ To freeze the references:

1 Select the reference(s) that you wish to freeze.

2 Choose the Freeze Selection command in the Tools menu.
All selected references in the selection are frozen.

OR

1 Choose the Freeze Document command in the Tools menu in 4D Write 
(without selecting the reference).
In this case, all references contained within the document are frozen.
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Computing References
Field or expression references inserted in a 4D Write document are 
automatically computed when:

■ The reference is inserted in the document,

■ The document is loaded or opened.

Note Only “Page number” and “Total number of pages” type references are 
automatically updated. 

Consequently, you must force the computation of references each time 
you wish to view or print their new values during the working session. 

❿❿❿❿ To force the computation of the references:

■ Choose Compute References Now from the Tools menu.
The values of the references are instantaneously updated.
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8 Printing 

You can print any 4D Write document in a variety of ways. For 
example, a form letter that includes fields from a 4th Dimension 
database can be print merged to provide a copy for each person in a 
group, or a single letter can be printed for a specific person.

This chapter describes how to:

■ Print only the current document

■ Print merge a document once for each record in a selection

■ Print a document as part of a record

Printing the Current Document
4D Write can create stand-alone documents such as memos, letters, 
and notes in either external windows or in 4D Write areas in forms. 

To print a 4D Write document, choose Print… from the 4D Write File 
menu. Margin settings, page breaks, and any other paragraph 
formatting features incorporated in the document are used during 
printing.

As a general rule, when the references are displayed, they will be 
printed as shown. On the other hand, if the references are being 
displayed as values, these values will be re-computed before the 
document is printed, using the values of fields in current records. This 
applies both to direct printing and to print previews. For more 
information about displaying references or values, refer to “Showing 
References or Values” on page 198.
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The contents of the header and footer are printed, even if the 
document is in Normal view mode where headers and footers are not 
displayed on the screen.

❿❿❿❿ To print a document:

1 If necessary, choose Page Setup... from the 4D Write File menu to 
modify the page setup.
The Page Setup dialog box presents different choices depending on the 
printer driver that you have selected. The 4D Write page setup is 
independent from that of 4th Dimension.

2 Choose Print... from the 4D Write File menu.
4D Write displays the standard Print File dialog box.

3 Click the OK button.
The document is printed.

Printing a Merge Document
You may often use 4D Write to create documents, such as form letters 
and reports, that draw information from records. You can print such a 
document once for each record in the current selection.

The following figure shows a form letter that will be printed for a 
group of people listed in a Customers database. 

Field references

Field references 
for salutation
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Printing a Merge Document
In the letter, field references are inserted for the name and address 
fields. When the letter is print merged, the data from the fields is 
inserted so the correct name and address are printed for each person.

To print such a document, choose Print Merge... from the 4D Write 
File menu. This command prints the document once for each record in 
the current selection. Margin settings, page breaks, and any other 
formatting features are included.

❿❿❿❿ To print merge a document:

1 If necessary, choose Page Setup... from the 4D Write File menu to 
modify the page setup.
The Page Setup dialog box presents different choices depending on the 
printer driver that you have selected. The 4D Write page setup is 
independent from that of 4th Dimension.

2 Choose Print Merge... from the 4D Write File menu.
4D Write displays the Print Mailing dialog box.

3 Click the table you want to use as the master table for this document.
The document will be printed once for each record in the master table. 
The dialog box indicates the number of selected records in the master 
table. 

4 To change the selection of records, click the Find... button.
4D Write displays the 4th Dimension Query editor, which you can use 
to search for a specific group of records. For information on using the 
Query editor, refer to the 4th Dimension User Reference manual.

If no records are selected, the Print... button is disabled.

5 To sort the records from the master file, click the Sort... button.
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4D Write displays the 4th Dimension Order by editor, which you can 
use to sort the records in the selection. For information about using 
the Order by editor, refer to the 4th Dimension User Reference manual.

6 Click the Print... button.
4D Write displays the standard Print File dialog box.

7 Click the OK button.
The document is printed once for each record in the selection.

Previewing the Document
You can preview a document by choosing Print Preview from the 
4D Write File menu. The data for the referenced fields is drawn from 
the first record in the selection.

The following figure shows the letter being previewed on screen.

A set of icons appears at the top of the previewed document.

■ Stop icon: Clicking this cancels the printing and returns you to the 4D 
Write document.

Print icon

Stop icon

Previous Page icon

Next Page icon

Zoom menu
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Printing a Document as Part of a Record
■ Print icon: Clicking this displays the standard print dialog box of your 
operating system.

■ Previous Page icon: Clicking this displays the previous page of the 
document. If there are no previous pages, the icon appears dimmed.

■ Next Page icon: Clicking this displays the next page of the document. 
If the last page is already displayed, the icon appears dimmed.

■ Zoom menu: Clicking this displays a list of zoom ratios. Selecting one 
of these ratios will apply it to the print preview.

Printing a Document as Part of a Record
You may want to print a 4D Write document as part of a record. The 
information in the document appears together with each record just as 
it does on the screen, except that the 4D Write area on the printout 
will expand to print the entire document.

Note The WR SET AREA PROPERTY command allows you to set the 4D Write 
area to be printed with a fixed size. 

4D Write area

4D records
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When you print a record, you follow 4th Dimension printing 
instructions. The 4D Write instructions for page setup, headers and 
footers, page breaks, column breaks and so on, do not apply.

❿❿❿❿ To print a record or group of records:

1 Select the record or records you want to print.
For information on selecting records, refer to the 4th Dimension User 
Reference manual.

2 Choose Print... from the 4th Dimension File menu.
The Print dialog box appears. You use this dialog box to select the form 
you want to use to print the records.

3 Select the form and click OK.
The Page Setup dialog box appears.

4 Make any necessary modifications to the Page Setup dialog box and 
click OK.
The standard Print File dialog box appears

5 Make any necessary modifications to the Print File dialog box and click 
OK.
The records are printed. The 4D Write area behaves like a variable 
frame Text field. The 4D Write area expands vertically to print all the 
information in the document. 
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Printing a Document as Part of a Record
Previewing the 
Record

The following figure shows a record being previewed on the screen. 
You can preview a record before printing by selecting the Print preview 
check box in the Print dialog box.

For more information on variable frame printing, refer to the 
4th Dimension Design Reference.
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A 4D Write Shortcuts

Special Keys
In addition to scrolling, 4D Write offers some shortcuts allowing you 
to quickly navigate and make selections in a document.

 Windows Mac OS Action
+ [Shift] = 
Effect on 
selection (*)

[Home] Moves the insertion point to the beginning of the 
line

X

[End] Moves the insertion point to the end of the line X

[Ctrl]+[Home] [Cmd]+[Home] Moves the insertion point to the beginning of the 
document

X

[Ctrl]+[End] [Cmd]+[End] Moves the insertion point to the end of the 
document

X

[PgUp] Scrolls one page up (does not modify the current 
selection)

[PgDn] Scrolls one page down (does not modify the current 
selection)

[Enter] Inserts a column break or a page break (depending 
on the current mode 

[←] [→] Moves the insertion point one character (left or 
right)

X

[↓ ][↑] Moves the insertion point one line (up or down) X

[Ctrl]+[→] [Cmd]+[→] Moves the insertion point to the beginning of the 
next word

X

[Ctrl]+[←] [Cmd]+[←] Moves the insertion point to the beginning of the 
previous word

X

[Ctrl]+[↑ ] [Cmd]+[↑ ] Moves the insertion point to the beginning of the 
current paragraph

X
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(*) Depending on the initial state of the selection, associating the 
[Shift] key to the shortcut created will enlarge or reduce the text 
selection.

Click Combinations
In addition to scrolling, 4D Write allows you to use the following click 
combinations. 

Note that if you hold down the mouse button and drag on the last 
click, you can select more than one of the thing indicated. So if you 
double-click-and-drag, you will select whole words as you drag. If you 
drag in the left margin, you will select whole lines, and so on.

[Ctrl]+[↓ ] [Cmd]+[↓ ] Moves the insertion point to the end of the current 
paragraph

X

[Ctrl]+[Del] [Cmd]+[Del] Deletes the next word or the letters located to the 
right of the cursor

[Ctrl]+[Bckspce] [Cmd]+[Bckspce] Deletes the next word or the letters located to the 
left of the cursor

 Windows Mac OS Action
+ [Shift] = 
Effect on 
selection (*)

Combination Explanation

Single click Moves the insertion point, deselecting any 
text that was selected

Double-click Selects the word that was double-clicked and 
the following space (if any)

Triple-click Selects the paragraph
Click in left margin Selects the line next to the click
Double-click in left margin Selects the paragraph next to the click
Shift + Click Extends the current selection to the location of 

the click
Ctrl + Click (Windows) or 
Command + Click 
(Mac OS)

Selects the text behind a picture that is pasted 
“in the page” or vice versa

Right click or
Control + Click (Mac OS)

Displays a pop-up contextual menu
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