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4D View

4D View — 4D’s 
built-in spreadsheet 

A spreadsheet is an application containing a grid of cells into which 
you can enter information, execute calculations, or display pictures. 
4D View is a plug-in written for 4th Dimension and 4D Server, 
allowing you to use classic spreadsheet functions within your database 
as well as to execute simulation, projection, analysis or specific 
presentation operations to this type of software. Also, 4D View offers 
advanced functions allowing multiple types of data presentation.

For the user, total integration of 4D View into 4th Dimension means 
being able to take full advantage of 4D View’s power and interface 
while having the specific functions of an advanced spreadsheet 
available.

4D View directly uses information contained in the database without 
having to re-enter it – one of the most powerful elements of the 
program. In fact, once you make reference to values stored in the 
database, you will save a considerable amount of time since any 
changes in the database are immediately made in your spreadsheet and 
vice versa. You can create applications that will help you with 
calculations, preparation of budgets or simulations.

4D View — a 
complete 
spreadsheet

4D View’s two-dimensional configuration, a set of columns and rows, 
integrates into any database and allows creation of reports or 
execution of quick calculations. Formulas can be used for these 
calculations. They can contain references to cells and execute 
calculations with data from these cells. If the data changes, the 
calculations are updated. 
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4D View allows you to enhance your spreadsheet by incorporating 
different fonts, borders and colors for cells and pictures. Your 
presentations will take on an efficiently professional look.
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To customize your print jobs, you can add headers and footers and 
insert the current date and time as well as the page number. You can 
also set column and row repetition during printing.

4D View — a 
powerful list editor

4D View also allows insertion of advanced scroll-down areas in your 
4D forms. Using its built-in language, it allows you to handle 
otherwise-impossible manipulations by using 4D database commands: 
horizontal scroll-down bars, user-resized columns, automatic column 
formatting, copy to clipboard, drag and drop, etc. The content of the 
list can be directly modified either by direct entry in the 4D View area 
or by control objects (pop-up menus, buttons...) with total control of 
entered data. Operations are very quick and control objects respect the 
interface.

Data can be passed to 4D View by using 4D arrays or fields. If two 
columns must be displayed in a screen list form, create two arrays or 
specify two fields that you will pass to 4D View. No area delimiter or 
additional manipulation is necessary.

4D View and 4th Dimension
4D View is more than a simple spreadsheet: built in to the 
4th Dimension environment, it can function with database data.

You can even associate a spreadsheet to each record of your database. 
The spreadsheet data will be updated at the same time as the record. 
Since you can insert as much data as you would like into your 
spreadsheet, it can be used as a multi-valued field.

If you want to use the same document for several spreadsheets, simply 
create a template, into which you can insert text, formulas or pictures. 
This template can perform the same calculations on every record in 
your database.

4D View can also be used in an external window as if it were a stand-
alone application, but still having access to the 4D database. You can 
enter information coming from the database into cells and use a 
formula to summarize them.
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Also, 4D View has a programming language — containing over 
100 routines— which, combined with the richness of the interface and 
the functional power of 4

 

th

 

 Dimension, allows you to manage totally 
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customized 4D View spreadsheets. The description of these 
commands, as well as their usage within your databases, are detailed in 
a separate manual: refer to the 4D View Language Reference manual.

About this Manual

Windows®/
Mac™OS

This manual is for users of 4D View for both Windows and Mac OS.
The information in this manual applies to both platforms. Any 
differences in usage between the Mac OS and Windows version of 
4D View are detailed within the text.

Screen shots are primarily from the Windows version. Both versions 
are presented only in cases where there is a major difference.

Manual content This manual constitutes the 4D View User Reference. It details dialog 
boxes and menu commands of the program as well as all available 
functions in the User environment. Please pay special attention to the 
chapter “Using 4D objects” on page 133, which explains how to take 
full advantage of 4D View’s integration into 4th Dimension.

4D View contains a set of additional commands which are integrated 
into the 4th Dimension language, allowing execution, via 
programming, of any action that can be done in the User 
environment, and providing access to a variety of additional functions. 
These commands give the programmer the ability to guide and analyze 
user actions within a customized application.
The 4D View programming language is detailed in a separate manual, 
the Language Reference manual.
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Introduction
4D View can be used in an included area within a form or in an exter-
nal window. Regardless of the mode used, the available interface ele-
ments are the same. This chapter will describe the 4D View interface 
and its many features.

Note In this chapter, the term “window” will be used invariably to describe 
an external 4D View window or a 4D View included area. If a particular 
comment or note applies specifically to either an included area or a 
window, it will be clearly noted.
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The 4D View Window

 

By default, the 4D View window is presented as follows:
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The 4D View window contains:

■ A visible spreadsheet area,

■ A menu bar and four toolbars, located in the top portion of the win-
dow,

■ A formula bar,

■ Column headers, located above the spreadsheet area,

■ Row headers, located to the left of the spreadsheet area,

■ Two scroll bars with splitters.

Splitting the 
4D View window

4D View allows splitting of the spreadsheet area into several panes.
Once the spreadsheet area has been split, you can view and scroll 
through each pane of the same document independently from the 
other panes. The spreadsheet area can be split vertically and 
horizontally which is useful for simultaneously entering, editing, or 
viewing portions of a table found in different locations of the 4D View 
document.

Menu bar

Toolbar

Formula bar
Column headers

Spreadsheet 
area
Splitter

Row headers

Vertical scrollbar

Splitter 

Horizontal scroll bar 
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Splitting the document area vertically allows you to display several 
areas of the current document side by side.

��     ��   
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❿❿❿❿ To split a 4D View window vertically:

1 In the 4D View window, place the cursor over the split box located to 
the left of the horizontal scroll bar.

The cursor changes into a split indicator:

2 Drag the split cursor to the desired location of the new pane border.
There are now two independent sub-windows:

❿❿❿❿ To split a 4D View window horizontally:

1 In the 4D View window, place the cursor over the split box located 
above the vertical scroll bar:

The cursor changes into a split indicator.
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2 Drag the split indicator to the desired location of the new pane 
border.

 

There are now two independent sub-windows.

��     ��  
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Vertical and horizontal divisions can easily be combined:

Any changes made in one window are immediately reflected in the 
other.

❿❿❿❿ To remove a pane:

1 Place the cursor over the border separating the two panes.
The cursor changes into a split indicator:

2 Double-click the border.
OR
Drag the line to the starting point of the sub-window, as if you were 
going to close it.
The pane disappears.

❿❿❿❿ To resize a pane:

1 Place the cursor over the border separating two panes.



 

The 4D View Window

   

The cursor changes into a split indicator:

 

2 Drag the split indicator to the new desired location.
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The Menu Bar and 
Toolbars

The menu bar is displayed at the top of the 4D View window. It 
contains seven menus:

There are four toolbars in 4D View:

The toolbars are designed to provide quick access to certain features 
that would otherwise require the use of menu commands.

For more information on the functions of these toolbars, refer to the 
paragraph “4D View Toolbars” on page 40.

The formula bar appears below the spreadsheet area:

It allows editing of the formula of the cell being modified.

Moving the Menu 
Bar or a Toolbar

The 4D View menu bar, as well as any toolbar, can be moved to any 
side of the window. They can also be displayed as a floating palette 
above the spreadsheet area or outside the 4D View window.

Settings will be saved for each new 4D View window.

❿❿❿❿ To move the 4D View menu bar or a toolbar:

1 Click the handle located to the left of the bar and hold down the 
mouse button.
A cross-like cursor will appear; the bar is surrounded by a gray frame:

2 Drag the bar to another location in the upper part of the window.
OR
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Drag the bar to the border of the left, right, or lower part of the 
spreadsheet area.
OR
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Move the bar above the spreadsheet area or any other screen area.

3 Release the mouse.

■ The bar will appear in its new location if it was placed in the upper 
part of the window.

■ If the bar is placed on the border to the left, right, or lower part of 
the spreadsheet area, it is built into the window.

■ If the bar is placed above the spreadsheet area, or any other screen 
area, it is displayed as a palette:

Toolbars integrated 
into the window



The 4D View Window

Hiding a bar The menu bar or a toolbar can be hidden if you do not use it or want to 
customize the interface. Note that your parameters are saved for each 
new 4D View window.
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❿❿❿❿ To hide the menu bar or a toolbar:

1 Deselect the name of the bar in the Toolbar submenu of the Display 
menu, or deselect the Menu bar command in the View menu.
A checkmark (√) is placed next to the command when the correspond-
ing bar is displayed.

OR
If the bar is displayed as a palette, click on the close box.
OR
Under Windows, right-mouse click on one of the bars. Under Mac OS, 
right-click or Control+click on one of the bars.
A pop-up menu will appear for the latter. You can either Hide the bar 
on which you have clicked, or Customize the bars.

If you selected the Customize... option, a dialog box appears allowing 
you to deselect the bar(s) that you want to hide.

Re-displaying a bar
❿❿❿❿ To re-display a bar:

1 Select the name of the bar to display in the Toolbar submenu of the 
View menu.
A checkmark (√) is placed next to the command when the correspond-
ing bar is displayed.

OR
Under Windows, right-mouse click one of the displayed bars.
Under Mac OS, right-click or Control+click one of the bars.

List of bars

Display options for 
the bars
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2 Select the Customize... option from the pop-up menu that is 
displayed.

3 In the dialog box displaying the bars, check the option corresponding 
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to the bar that you wish to display.
OR
To re-display the menu bar, use the Ctrl+Shift+M (Windows) or 
Command+Shift+M (Mac OS) keyboard shortcuts.

4D View Menus
4D View includes seven menus:

■ The File menu
This menu is used for printing, exporting, file management and access-
ing preferences.

■ The Edit menu
This menu is used to access standard features, such as Copy/Cut/Paste, 
Undo or Re-do operations, and to access Find/Replace features. It also 
allows setting of names, moves within a document and cell sorting.

■ The View menu
This menu is used to select display options for the spreadsheet, inter-
face elements, pictures, scrollbars, as well as references.

■ The Insert menu
This menu is used to insert cells, column, rows, and page breaks.

■ The Style menu
This menu is used to define style attributes of selected cells, borders, 
column width, and row height. It also allows changing of style sheets.

■ The Tools menu
This menu is used to view and edit document attributes (title, subject, 
author and notes), and to access cell security and calculation mode. It 
also allows updating or freezing of references present in the 4D View 
document.

■ The Database menu
This menu is used to import fields and reports. It also allows linking of 
cells or columns.



4D View Menus

The File menu The File menu allows you to access standard document management 
features, exports, print features as well as preferences. The commands 
for this menu are as follows:
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■ New
Selecting this command displays a new blank document in the spread-
sheet area, replacing the current document. If the document is not 
saved, a confirmation dialog box allows you to save it before display-
ing the new document.

■ Open...
Selecting the Open... menu command displays the standard Open File 
dialog box for your operating system. Selecting a document with this 
dialog box opens the document and displays it in the 4D View win-
dow.

■ Save
Selecting the Save menu command saves the current document in its 
current location. If the current document is a new document, the Save 
command acts the same as the Save As command.

■ Save As...
Selecting the Save As... command displays the standard Save File dialog 
box for your operating system.

■ Save As Template
This command creates a document template on your disk. A template 
is a document that serves as a document starting point for each record.
No Save File dialog box is shown; the document template will be saved 
automatically at the same level as the database structure file. The name 
of the template will be the same as the area, followed by .4PV (for 
example, “MyArea.4PV”). 

■ Export Area
Selecting the Export Area displays a hierarchical submenu that allows 
defining of the area of cells to export:

■ Set sets the set of selected cells as an export area.

■ Clear cancels a previously defined export area.

■ Show displays the selection of cells of the area to export.
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■ Export...
Selecting the Export... command displays the standard create file dia-
log box. The created file contains information related to cells selected 
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as an export area.

■ Preferences...
Selecting the Preferences... command displays the preference setting 
dialog box:

This dialog box allows defining of document preferences, such as 
vertical and horizontal scrollbar display, the number of columns and 
rows of a document, grid characteristics, graphics, and auto resizing. 
For more information on using this dialog box, refer to the paragraph 
“Setting Preferences” on page 74.

■ Print Area
Selecting the Print Area command displays a hierarchical submenu 
allowing setting of the area of cells to print.

■ Set sets the set of selected cells as a print area.

■ Clear cancels the previously defined print area.

■ Show displays the selection of print area cells.
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■ Printing Options...
Selecting the Printing Options... command displays the 4D print set-
tings dialog box:
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This dialog box allows setting of print parameters, such as header and 
footer contents, options, margins and repeats.

■ Page Setup...
Selecting the Page Setup... command displays the print setting dialog 
box for the current printer.
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■ Print Preview...
Selecting the Print Preview... command displays the print preview win-
dow:
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The print preview window displays the document as it will be printed. 
It also allows visualizing of the document page by page and starting of 
printing. For more information, refer to the paragraph “Print 
Preview...” on page 170.

■ Print Document...
Selecting the Print Document... command displays the print dialog box 
for the current printer.

■ Print Formulas...
Selecting the Print Formulas... command allows printing of spread-
sheet formulas.

■ Go To Full Screen
When the 4D View area is included in a form, this menu command 
expands the text area to the size of your screen (Mac OS) or of the 
application window (Windows). The 4D View menu bar replaces the 
4th Dimension menu bar.

The Edit menu The Edit menu is used to:

■ Cut/Copy/Paste cells,

■ Cancel or repeat the last operation executed by the program,

■ Select all cells of a document,
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■ Automatically find and replace a value, a color, a font, or a format,

■ Re-copy, move, clear, name, or sort cells.
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The Edit menu contains the following commands:

■ Undo Action
Selecting the Undo Action menu command reverses the last action 
taken by the user. If the last action cannot be undone, the menu com-
mand is dimmed.

■ Redo Action
Selecting the Redo Action menu command restores the last action can-
celed by the Undo command. If this action cannot be restored, the 
menu command is disabled.

■ Repeat Action
Selecting the Repeat Action menu command repeats the last action 
taken by the user. If this action cannot be repeated, the menu com-
mand becomes Cannot Repeat Action.

■ Cut
Selecting the Cut menu command deletes the current selection and 
places it on the clipboard.

■ Copy
Selecting the Copy menu command copies the current selection and 
places it on the clipboard.

■ Paste
Selecting the Paste menu command places the clipboard content into 
the selected cell.

■ Paste Special...
Selecting the Paste Special... menu command displays the paste special 
dialog box:

■ Values pastes the result of formulas of previously copied cells.

■ Formulas pastes the formulas of previously copied cells. Their 
results may vary depending on where they were pasted in the area.
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■ Formats pastes the formats of the copied cells.

■ Borders pastes the borders of the copied cells.
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■ Select All
Selecting the Select All menu command selects all the cells in the 
spreadsheet.

■ Fill
Selecting the Fill menu command displays a hierarchical submenu to 
define the direction in which to copy:

■ Down copies, within a selection, the content of the top cell(s) into 
the rest of the selection. 

■ Right copies, within a selection, the content of the left-most cell(s) 
into the rest of the selection.

■ Move
Selecting the Move menu command combines the Cut and then Paste 
commands. However, borders are not taken into account. For more 
information, refer to the paragraph “Moving cells” on page 79.

■ Clear
Selecting the Clear menu command displays a hierarchical submenu to 
set which elements to clear.

■ All clears values, formulas, formats and borders for the current selec-
tion,

■ Values only clears values in the current selection. Formulas, formats 
and borders are not touched.

■ Formulas only clears formulas in the current selection. Values, for-
mats and border are not touched.

■ Formats only clears formats in the current selection. Formulas, val-
ues and borders are not touched.

■ Borders only clears borders in the current selection. Formulas, for-
mats and values are not touched.
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■ Other... displays the clear options dialog box:
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The choices in this dialog box are the same as in the hierarchical 
submenu. This dialog box allows combining of various options into 
a single operation.

■ Delete...
When one or more cells are selected, choosing the Delete... command 
menu displays a delete cells dialog box:

■ Up deletes the cell selection and shifts the cells located below the 
current selection in the document.

■ Left deletes the cell selection and shifts the cells located to the right 
of the current selection in the document.

When a column or an entire line is selected (by clicking the header), 
the column or the row is immediately deleted; no dialog box is 
displayed.

■ Find...
Selecting the Find... menu command displays the Find... dialog box:
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This dialog box allows searching of the entire document for a value. 
For more information, refer to the paragraph “Find” on page 80.

■ Find Next
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Selecting the Find Next menu command triggers a new search using 
the last search criteria. This command is disabled if there are no prior 
searches.

■ Replace...
Selecting the Replace... command displays the replace dialog box:

This dialog box allows searching and replacing of a value. For more 
information, refer to the paragraph “Replace” on page 81.

■ Replace Next
Selecting the Replace Next menu command triggers a new replace 
based on the last criteria used. This command is disabled if there are no 
prior replacements.

■ Set Name...
Selecting the Set Name... menu command displays the set cell name 
dialog box:
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This dialog box allows setting a name for a selected cell. For more 
information, refer to the paragraph “Set name” on page 82.

■ Go to...
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Selecting the Go to... command displays the navigation dialog box:

This dialog box allows choosing of the cell to select from the list of 
names of cells previously defined. Validating this choice shifts the 
spreadsheet vertically and horizontally, if necessary, to display the 
target cell. This command is disabled when no cell names have been 
defined in the document.

■ Go To Last Cell
Choosing this command selects and displays the last cell in the spread-
sheet. The last cell is located at the intersection of the right-most col-
umn and the bottom-most row containing a non-empty cell.

■ Sort...
Selecting the Sort... menu command displays the sort cells dialog box:
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This dialog box allows sorting of rows and columns of cells with four 
different sort parameters. For more information, refer to the paragraph 
“Executing Sorts” on page 84.
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The View menu The View menu allows selecting the display of menu bars, formula 
bars, row and column headers, grids, scroll bars, toolbars, page breaks, 
references and pictures.

A checkmark (√) appears in front of displayed elements. To hide an 
element, select its label and the checkmark disappears. To display a 
hidden element, repeat this step: the checkmark re-appears.

The commands for this menu are as follows:

■ Menu Bar
Selecting the Menu Bar menu command hides the menu bar. If the 
menu bar is hidden, you can display it using the Ctrl+Shift+M (Win-
dows) or Command+Shift+M (Mac OS) shortcuts.

Note For more information on managing bars, refer to the paragraph “The 
Menu Bar and Toolbars” on page 17.

■ Formula Editor
The Formula Editor command displays or hides the formula bar at the 
top of the external window or included area.

■ Column Headers
The Column Headers command displays or hides spreadsheet column 
headers.

■ Row Headers
The Row Headers command displays or hides the spreadsheet row 
headers.

■ Grid
The Grid command displays or hides the grids in the spreadsheet.

■ Vertical Scrollbars
The Vertical Scrollbars command displays or hides the vertical scroll-
bar.

■ Horizontal Scrollbars
The Horizontal Scrollbars command displays or hides the horizontal 
scrollbar.
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■ Toolbars
The Toolbars command displays a submenu listing the 4D View tool-
bars.
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In this submenu, toolbars with a checkmark in front of their name are 
displayed. Selecting the name of a toolbar preceded by a checkmark 
will hide it. Selecting a toolbar not preceded by a checkmark displays 
the corresponding toolbar.

Displaying the menu bar and formula bar is managed by an individual 
menu command.

Note For more information on managing bars, refer to the paragraph 
“4D View Menus” on page 20.

■ Page Breaks
The Page Breaks command displays or hides the page limits used dur-
ing printing.

Note To modify the location of page breaks, refer to the paragraph “The File 
menu” on page 21.

■ References
Selecting this command displays the references of variable elements of 
the spreadsheet in place of their values.

Note For more information on inserting variables, refer to the chapter 
“Using 4D objects” on page 133.

■ Pictures
Selecting this command displays pictures as they appear in the spread-
sheet. Pictures are invisible when this command is deselected.
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The Insert menu The Insert menu allows you to insert cells, columns, rows and page 
breaks.
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The commands for this menu are as follows:

■ Cell(s)...
Selecting the Cell(s)... command displays an insert cells dialog box:

■ Down moves cells located under the current selection in the docu-
ment and inserts a selection of empty cells.

■ Right moves cells located to the right of the current selection in the 
document and inserts a selection of empty cells.

The number of empty cells created is equal to the number of cells 
contained in the current selection.

■ Column(s)
Selecting the Column(s) command moves, from the left-most cell of 
the current selection, the set of spreadsheet columns to the right and 
inserts one or more column(s). The number of empty columns created 
is equal to the number of columns contained in the current selection 
of cells.

■ Row(s)
Selecting the Row(s) command moves, from the top-most cell of the 
current selection, the set of spreadsheet rows to the bottom and inserts 
one or more column(s). The number of empty rows created is equal to 
the number of rows contained in the current selection of cells.

■ Page Break
Selecting the Page Break command displays a submenu allowing you 
to select the type of page break to insert:

■ Insert a Column Break inserts a column break to the left of the left-
most cell of the current selection

■ Insert a Row Break inserts a row break above the top-most cell of 
the current selection.
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The Style menu The Style menu allows setting of styles for cells, frames, columns and 
rows. It also allows accessing the style sheet definition dialog box.
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The commands for this menu are as follows:

■ Cell(s)...
Selecting the Cell(s)... command displays the cell format dialog box:

This dialog box allows setting the font, color, style alignment and 
attributes of selected cells. For more information on using this dialog 
box, refer to the paragraph “Defining Cell Appearance” on page 91.

■ Border(s)...
Selecting the Border(s)... command displays the cell border dialog box:
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This dialog box allows setting of the location, color and thickness of 
selected cell borders.

For more information on using this dialog box, refer to the paragraph 
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“Defining Cell Borders” on page 100.

■ Style Sheets...
Selecting the Style Sheets... command displays the style sheet dialog 
box:

This dialog box allows creating, modifying, or removing style sheets 
defined in the document. For more information, refer to the paragraph 
“Using Style Sheets” on page 101.

■ Column(s)
Selecting the Column(s) command displays a hierarchical submenu 
allowing setting of the width and display of selected columns.
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■ Width... displays the dialog box to set the width of columns in pix-
els (points).
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If the group of selected columns contains uneven sizes, no reference 
size will be specified in the "Column width" area.
Clicking the Default button resets the default value (108 pixels).
The Revert button resets the value defined prior to opening the dia-
log box, without having to close it.

■ Automatic Width sets the column width, adjusting it to its widest 
content.

■ Default Width sets the column width to the default size (108 pixels).

■ Hide hides the selected columns.

■ Show displays the selected columns previously hidden with the 
Hide command.

■ Row(s)
Selecting the Row(s) command displays a hierarchical submenu allow-
ing setting of the width and display of selected rows.

■ Height... displays the dialog box to set the height of rows in pixels 
(points).
If the selected group of rows contains uneven sizes, no reference 
size will be specified in the “Row width” area.
Clicking the Default button resets the default value for the plat-
form.
The Revert button resets the value defined prior to opening the dia-
log box, without having to close it.

■ Automatic Height sets the row height, adjusting it to its greatest 
content.

■ Default Height sets the row height to the default size for the plat-
form (19 pixels under Windows, 15 under Mac OS).

■ Hide hides the selected rows.

■ Show displays the selected rows previously hidden with the Hide 
command.
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The Tools menu The Tools menu lets you access document information, cell security, 
set formula calculations and freeze references.
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This menu contains the following commands:

■ Document Information...
Selecting the Document Information... command displays the dialog 
box allowing you to view and modify document information:

This dialog box allows you to enter and view additional statistics 
related to the current document. For more information on this dialog 
box, refer to the paragraph “Managing Document Information” on 
page 75.

■ Security
Selecting the Security command displays a submenu allowing you to 
set the display and lock selected cells.

■ Hide hides the cell content.

■ Show displays the cell content.

■ Lock prohibits modifying the cell content.

■ Unlock re-authorizes modifying cell content.
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■ Automatic Calculation
Selecting the Automatic Calculation command alternatively sets calcu-
lating as either automatic or manual. If the Automatic Calculation 
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option is selected, 4D View calculates cell formulas any time one is 
modified. If the Automatic Calculation is disabled, re-calculating all 
formulas is done on command.

When calculating is automatic, a checkmark (√) appears in front of the 
command.

■ Calculate Now
Selecting the Calculate Now menu recomputes all document cell for-
mulas. This command is disabled if the Automatic Calculation option 
is enabled.

■ Freeze References
The Freeze References command replaces the dynamic references 
within the document with their current values. These values are no 
longer dynamic. For more information, refer to the paragraph “Calcu-
lating Dynamic References” on page 162.

The Database menu The Database menu allows importing of fields and reports, and linking 
of cells and columns.

The Database menu contains the following commands:

■ Import Field...
Selecting the Import Field... command displays the import fields dialog 
box:
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This dialog box lets you select the fields to import into database tables. 
It also allows searching and sorting of these fields. For more 
information on importing fields, refer to the paragraph “Importing 
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Fields” on page 134.

■ Import Report...
Selecting the Import Report... command will first display a dialog box 
allowing you to choose on which table the report will be carried:

Once you have made your choice, the 4D Quick Report Editor dialog 
box is displayed, allowing you to create a report or use an existing 
template.
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For more information on using the Quick Report Editor, refer to the 
4th Dimension User Reference manual. For more information on 
importing reports, refer to the paragraph “Importing Reports” on 
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page 138.

■ Add pictures... 
Selecting the Add pictures... command displays the Choose Picture 
Field dialog box:

This dialog box allows inserting of dynamic picture references in your 
4D View areas. For more information, refer to the paragraph “Inserting 
Pictures” on page 145.

■ Linked Cells...
Selecting the Linked Cells... command displays the linking cells dialog 
box:



Chapter 2  Interface

This dialog box allow creating and removing of links between 
spreadsheet cells and 4th Dimension fields or variables. 

For more information on linking cells, refer to the paragraph 
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“Dynamically Referencing Fields” on page 142.

■ Linked Columns
Selecting the Linked Columns command displays a hierarchical sub-
menu allowing the linking of columns to Fields or Arrays. If you select, 
for example, the Fields subcommand, the following dialog box 
appears:

This dialog box allows creating and deleting of links between columns 
and database fields. The Arrays subcommand displays a dialog box 
allowing you to create and delete links between columns and database 
arrays. For more information on linking columns, refer to the 
paragraph “Linking Columns to Fields or Arrays” on page 154.

4D View Toolbars
4D View toolbars are located in the upper part of the plug-in window.

Toolbars provide quick access to certain often-used features. These 
toolbars can be moved and/or hidden easily in the 4D View window. 
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This is detailed in the paragraph “The Menu Bar and Toolbars” on 
page 17.

There are four toolbars and a formula editor in 4D View:
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■ The Standard toolbar:

■ The Numbers toolbar:

■ The Style toolbar:

■ The Borders toolbar:

■ The Formula editor:

The Standard 
toolbar

The Standard toolbar is organized into eight groups of buttons:

■ File management buttons,

■ Print management buttons,

■ Find buttons,

■ Cut/copy/paste buttons,

■ Undo and Redo buttons,

■ View management buttons,

■ Sort management buttons,

■ Zoom combo box. 

The File Management 
Icons

The file management buttons consist of three buttons:

From left to right, these buttons are: the New Document button, the 
Open Document button and the Save Document button.
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Clicking the New Document button displays a new 4D View document 
in the current window. If the current document is not saved, a dialog 
box is shown and proposes saving it before the new document is 
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displayed. This button has the same effect as the New command in the 
File menu. 

Clicking the Open Document button displays a standard Open file 
document. The document selected using this dialog box will be opened 
in a 4D View window. If the current document is not saved, 4D View 
allows you to save it before displaying the open document dialog box. 
This button has the same effect as the Open... command in the File 
menu. 

Clicking the Save Document button saves the current document in its 
current location if it has already been saved. Otherwise, a standard 
Save file dialog box is displayed, allowing you to name and set a 
location for your document. This button has the same effect as the 
Save command in the File menu. 

The Print Management 
buttons

The print management buttons consist of two buttons:

From left to right, these buttons are: the Print Preview button and the 
Print Document button.

Clicking the Print Preview button displays the print preview window. 
This is the same as selecting the Print Preview menu command in the 
File menu.

Clicking the Print Document button displays the print dialog box. This 
is the same as selecting the Print Document menu command in the File 
menu.

The Find button Clicking the Find button displays the search dialog box. For more 
information on using this dialog box, refer to the paragraph “Find” on 
page 80. 

This is the same as selecting the Find menu command in the Edit 
menu.
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The Copy/Paste 
Management buttons

The cut/copy/paste buttons consist of three buttons:
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From left to right, these buttons are: the Cut button, the Copy button 
and the Paste button.

Clicking the Cut button clears the current selection and places it on 
the clipboard. This is the same as selecting the Cut menu command 
from the Edit menu.

Clicking the Copy button copies the current selection and places it on 
the clipboard. This is the same as selecting the Copy menu command 
from the Edit menu.

Clicking the Paste button pastes the contents of the clipboard where 
the cursor is located. This is the same as selecting the Paste menu 
command from the Edit menu.

The Undo and Redo 
buttons

The undo and redo buttons consist of two buttons:

From left to right, these buttons are: Undo and Redo.

Clicking the Undo button cancels the last operation.
This icon can be used successively because 4D View stores several 
successive operations in memory. This is the same as selecting the 
Undo action command in the Edit menu.

Clicking the Redo button restores the previously undone operation. 
This icon can be used successively because 4D View stores several 
successive operations in memory. This is the same as selecting the 
Redo action command in the Edit menu.

The View management 
buttons

Clicking the Show references button displays the 4D reference in place 
of the current values.
If the view references option is already selected, the references will be 
replaced with their current values.
This is the same as selecting the Show References command in the 
View menu.
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The Sort management 
buttons

The sort management buttons consist of two buttons:
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From left to right, these buttons are: Ascending Sort and Descending 
Sort.

Ascending sort (increasing)

Descending sort (decreasing)

Clicking on one of these icons sorts the cells of the selected column(s). 
Depending on the icon selected, the cell sort will either be ascending 
or descending. For more information on detailed sorts, refer to the 
paragraph “Executing Sorts” on page 84.

The Zoom combo box The Zoom combo box allows you to apply an enlargement or 
reduction rate to the display. 

You can define a rate included between 25 and 1000. 

The Number toolbar The Number toolbar is organized into two groups of buttons:

■ Justification management buttons,

■ Format management buttons.

The Justification 
management buttons

The justification management buttons consist of four buttons:

From left to right, these buttons represent the Automatic Alignment 
button, the Align Left button, the Center button, and the Align Right 
button.

Clicking the Automatic Alignment button automatically aligns the 
content of each cell of the selected range (to the left for alphanumeric 
characters and to the right for numbers)

Clicking the Align Left button aligns the content of each cell in the 
current range to the left

Clicking the Center button centers the content of each cell in the 
current range.
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Clicking the Align Right button aligns the content of each cell in the 
current range to the right. 
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The Format 
management buttons

The format management buttons consist of a drop-down list and three 
buttons:

The drop-down list contains all the available formats in the 4D 
database.

From left to right, the three buttons correspond to the most-used pre-
defined formats:

■  Scientific,

■  Percentage,

■  Monetary.

The Style toolbar The Style toolbar is organized into three drop-down lists and a group 
of buttons:

■ Style sheet drop-down list,

■ Font name drop-down list,

■ Font size drop-down list,

■ Character style selection buttons.

Style sheet drop-down 
list

The style sheet drop-down list allows selecting of a customized style 
sheet and applying it to cells in the selected range. Style sheets in this 
list were created by the user. For more information on style sheets, 
refer to the paragraph “Using Style Sheets” on page 101.

Font Name drop-down 
list

The font selection drop-down list allows selecting of a font and 
applying it to cells in the selected range. Fonts in this list are installed 
system fonts (as well as current printer fonts under Windows). These 
fonts are the same as those displayed in the Font tab in the formatting 
dialog box.

Font Size drop-down list The font size drop-down list allows entering or selecting of the font 
size to apply to cells in the selected range. The available font sizes are 
the same as those displayed in the Font tab in the formatting dialog 
box.
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Character style selection 
buttons

The character style buttons consist of three buttons:
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From left to right, these buttons are: the Bold button, the Italic button 
and the Underline button. These buttons are the same as the style 
options available in the Font tab in the formatting dialog box.

Clicking the Bold button applies the Bold style to cells in the selected 
range.

Clicking the Italic button applies the Italic style to cells in the selected 
range.

Clicking the Underline button applies the Underline style to the cells 
in the selected range.

The Borders toolbar The Borders toolbar is organized into two groups of buttons:

■ Border display buttons

■ Border attribute buttons

The Border Display 
buttons

The border display buttons consist of six buttons:

From left to right, the buttons are: the Bottom Border button, the 
Outside Borders button, the Border Columns button, the Border Rows 
button, the Border All button and the No Border button.
These buttons allow displaying of different cell borders in the selected 
range.

Clicking the Bottom Border button displays the bottom border of the 
range of selected cells.

Clicking the Outside Borders button displays the outside borders of 
the range of selected cells.

Clicking the Border Columns button displays the borders of each 
column in the selected range.

Clicking the Border Rows button displays the borders of each row in 
the selected range.

Clicking the Border All button displays the borders of each cell of the 
selected range.
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Clicking the No Border button clears all borders of the range of 
selected cells.
474D View User Reference

The Border Attribute 
buttons

The border attribute buttons consist of two buttons:

From left to right, these buttons are: the Border Color button and the 
Border Settings button.

Clicking the Border Color button displays the palette of available 
colors (256 colors in 4D).

Clicking the Border Settings button displays a drop-down list 
containing the 12 types of borders.

Note For more information on managing borders, refer to the paragraph 
“Defining Cell Borders” on page 100. 

The Formula toolbar The Formula toolbar is organized into a group of buttons and an input 
area:

■ Formula input cancellation and validation buttons

■ Formula input area.

The Formula 
Modifications 
cancellation and 
validation buttons

The formula input cancellation and validation buttons consist of two 
buttons:

From left to right, these buttons are: the Cancel Formula Modifications 
button and the Validate Formula Modifications button.

Clicking the Cancel Formula Modifications button restores the formula 
as it was at its last save.

Clicking on the Validate Formula Modifications button validates the 
input in progress.

The formula input area For more information on entering formulas, refer to the paragraph 
“Entering a Formula, a Function or a Reference” on page 113.
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Documents

4D View documents can be inserted into database records or external 
windows. This chapter describes creating, opening, and saving of 
4D View documents in these two locations.

4D View also provides various tools to set general use preferences for 
documents and to obtain various document information.

This chapter will discuss the following principles and 4D View 
document management tools:

■ Document formats

■ Opening a document in an external window

■ Create, open and save a 4D View area in a form

■ Create, open and save 4D View documents

■ Define document preferences
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Document Formats
4D View documents can be opened and saved in different formats. 
These formats appear in the drop-down list in the standard File open 
50 4D View User Reference

and File save dialog boxes:

Below is a description of the available file formats in 4D View:

■ 4D View Documents
Native format of 4D View documents. 4D View documents saved in 
this format preserve all features. This format is available when saving 
and opening documents.

■ 4D View Template Documents
Format of 4D View template documents. This format is available when 
saving and opening documents.

■ 4D Calc Documents
Format compatible with the 4D Calc spreadsheet. Features unique to 
4D View are not preserved when saved in this format. This format is 
available when saving and opening documents.

■ 4D Report Documents
This format corresponds to semi-automatic 4D reports saved to disk. It 
is only available when opening documents.

Save file dialog boxOpen file dialog box
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■ SYLK 2.0 documents
Format used for spreadsheet exchanges between applications. This for-
mat is used by the Microsoft Excel® spreadsheet. This type of docu-
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ment does not preserve 4D View formulas. Only values and their 
appearance are preserved (if the equivalent exists in Excel).
4D reads SYLK 2.0 Mac OS and Windows, by accepting:

■ Borders, translated as 4D View graphics; the rows are left as is (and 
not as a series of dashes).

■ Cell styles, alignments, fonts and colors.

■ Column widths and row heights

■ Global options (hide or show grid, hide or show scrollbars).

This format is available when saving and opening documents.

■ Tabulated Text Documents
Format for tabulated text under Mac OS or Windows. This type of doc-
ument does not preserve any enhanced character features and uses the 
extended ASCII table for Mac OS or Windows (depending on the plat-
form). Columns are separated by tabs and advancing to the next row is 
done using a carriage return. This format is available when saving and 
opening documents.

■ HTML Documents
HTML stands for HyperText Mark-up Language. This format allows put-
ting the content of a 4D View page into a Web browser. Only values of 
non-empty cells are recorded. Enhanced cell features are not preserved 
(font, style, border, format, etc.). This format is only available when 
saving documents.

Opening a 4D View Document 
in an External Window

A 4D View document can be opened in its own window.

Used in an external window, 4D View behaves exactly like an 
independent application.

❿❿❿❿ To open a 4D View document in an external window:

1 Select User in the Mode menu, if you are not already in the User 
environment.

2 Choose the 4D View command in the Tools menu.
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If the 4D View command does not appear in the Tools menu, 4D View 
has not been correctly installed in your 4D environment. In this case, 
refer to the instructions in the 4th Dimension Installation Guide.
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A new 4D View document appears in an external window:

The external window contains the 4D View menu bar. The menus of 
this bar allow managing of your 4D View documents. For example, 
you can use the Edit menu commands to launch a search of an active 
4D View area. The 4th Dimension menus can still be selected in the 
standard menus, in the upper part of the screen.

The external 4D View window also contains five toolbars. These 
toolbars are designed to provide quick and easy access to basic 4D View 
functions. For example, to launch a search in a 4D View area, select the 
Find... command in the Edit menu, or click the  button in the 
Standard 4D View toolbar.

Windows

Mac OS

4D View menu 
bars
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Toolbars also allow customizing of the 4D View interface since —
except for the formula editor— they can be moved within the 
application window, can be used separately as floating palettes, or can 
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even be removed from the 4D View window.

The Standard toolbar also provides shortcuts, helpful for using 
standard features, which are located in the File and Edit menus.
The Numbers toolbar allows setting of cell content alignment and 
formatting.
The Style toolbar allows assigning of cell formats and selecting of a 
style for these cells.
The Borders toolbar allows setting of complete or partial borders for 
cells or cell ranges.
The Formula Editor toolbar allows entering of the content of a cell and 
validating or cancelling of formula modifications.

For more information, refer to the paragraph “4D View Toolbars” on 
page 40.

4D View windows also contain splitters which are used to divide a 
document into several areas and thus simultaneously view different 
parts of the same document. For more information on this feature, 
refer to the paragraph “Splitting the 4D View window” on page 14.

Opening several 
documents

To open an additional 4D View window, choose the 4D View 
command in the Tools menu.

This feature makes comparing or copying/pasting between different 
documents easier; you can switch from one document to another by 
clicking its window. The names of all open 4D View windows are 
displayed at the bottom of the Window menu. 

Menu bar
Numbers toolbar
Standard toolbar
Style toolbar

Borders toolbar
Formula Editor toolbar
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A document can be brought into the foreground by choosing its name 
from this menu:
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Once saved, 4D View document names appear in the window title.

Adjusting the size of 
the window

❿❿❿❿ To increase or decrease the size of a window:

1 Click in the lower right corner of the window.
Under Windows, the cursor turns into a double-arrow.

2 Adjust the size by dragging the mouse.

Note Under Windows, you can also change the height or width by clicking 
its sides.

Go To Full Screen To view an expanded portion of your document, the 4D View window 
can be viewed in full screen:

1 Under Windows, click the Maximize button, or choose Maximize in 
the System menu.
Under Mac OS, click the zoom box.
Note that the 4th Dimension menu bar remains at the top of the 
screen.

Windows 
open
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Closing the 
document

An external window can be closed at any time:

1 Click the close box of the window.
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OR
Under Windows, choose the Close command in the System menu.

Creating a 4D View Area in a Form
A 4D View spreadsheet can be inserted into a 4th Dimension form. A 
4D View area can be created in an input form, giving the user the 
means to enter invoicing rows, labeling rows, lists or any other kind of 
information, into each record. A 4D View area can also be placed in an 
output form used to display or print data

The following screen presents an included 4D View area in an input 
form: a list of current loans for a customer, John Smith. The list will be 
automatically saved with John’s record once it has been validated:

4D record

4D View plug-in 
area

Go To Full Screen 
check box
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Once a 4D View area is included in a form, it has the same features as 
the external windows, except that it does not have a close box. By 
default, the four 4D View toolbars (Standard, Numbers, Style, and 
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Borders) are displayed.

Creating the 
4D View area

❿❿❿❿ To create a 4D View area in a form:

1 Choose the Design command in the Mode menu in 4D, if you are not 
already in the Design environment.

To save the content of a 4D View area with each save, a BLOB type 
field must be created, which will be linked to the area. In fact, the plug-
in area content is saved in a BLOB field.

Steps 2, 3 and 7 below are not necessary if you wish to save the area 
content with each save.

2 In the Design window, create a BLOB type field in the table that will 
host the 4D View area.
For more information on creating a field, refer to the 4th Dimension 
Design Reference manual.

3 Name the field and place an underscore (_) at the end of the name.
For example, you can name the field PowerArea_.

4 In the Form editor, open the form where you want to add a 4D View 
area.
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This form must belong to the table containing the BLOB field associ-
ated to the area..
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The area may need to be resized to adapt to the form.

5 Select the Plug-in Area tool from the Objects palette and trace the 
area:

Objects palette

Plug-in Area tool

Plug-in Area
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6 Select 4D View from the Type drop-down list of the Property List:
Properties List
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This drop-down list contains all plug-ins installed in the database.

In the form editor, the inserted area displays the following message:

7 In the “Variable name” area, write the name of the BLOB field that you 
created in the Design environment, without entering the underscore.
For example, if the BLOB field is named PowerArea_, enter “Power-
Area”.

However, if you do not use this system, 4D View will allow saving of 
the 4D View area content to the disk when the record is validated.

The plug-in area of the form displays the 4D View icon, the name of 
the area, as well as a message indicating that it will be saved in the 
BLOB field:

Verifying the name of 
the area

If the name of the 4D View area does not exactly match the name of 
the BLOB field, or if this field does not exist, the message in the area 
will then indicate that it will not be saved with the document —
 4D View could save the document in the BLOB field if it existed.

Note The name of the 4D View plug-in area is a variable. This variable can 
only be a variable process. Interprocesses (names starting with <>) or 
local variables (names starting with $) cannot be used as plug-in area 
names. For more information on the different types of variables in 4D, 
refer to the 4D Language Reference manual.
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Saving a 4D View 
document as a separate 
file

In certain cases, the 4D View area does not need to be saved for each 
record. For example, you may wish to save your documents to the disk 
and load them by programming.
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In this case, there is no need to create a BLOB field to save documents.

Renaming the area If the 4D View area is not associated with a field, you can “back up” 
and rename the area at any time so that it is saved in a database field.
To do this, simply follow the instructions found in the preceding 
paragraph.

If the BLOB field does 
not exist

If the BLOB does not exist, it can be created in the Design environment 
window. In fact, it does not matter if you create the area and then the 
field, or vice versa. The result is the same.

Setting properties 
for the 4D View area

The properties of included 4D View areas can be set using the 
“Advanced Properties” dialog box. 

To display this dialog box, select a 4D View area in the Form editor and 
click on the Edit... button in the “Plug-in” theme of the Property List:

Access to Advanced Properties 
dialog box
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The following dialog box appears:
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The properties of the area can be set using options and entry areas. The 
dialog box includes several pages. The last page can be used to build 
the 4D View code corresponding to the settings made in the dialog 
box. 

■ The Default button is used to reset all the properties of the current 
page to their default value.

■ The Delete... button deletes all the advanced properties set for the area 
using the dialog box. Keep in mind that this button has no effect on 
properties set by programming. 
This button is dimmed if the Advanced Properties dialog box has not 
been validated at least once.

■ The Cancel button cancels any modifications made and closes the dia-
log box. 

■ The OK button validates any modifications made and closes the dialog 
box. 

The parameters of this dialog box are described in the following 
paragraphs. For more details about certain mechanisms, refer to the 
description of the PV SET AREA PROPERTY command in the Language 
Reference manual of 4D View. 



Creating a 4D View Area in a Form

Display Page The options of this page are used to determine the display of interface 
elements of the area.
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■ Toolbars, Scrollbars and Grid: Options used to display (option 
checked) or hide (option not checked) the corresponding elements of 
the area. 

■ Headers: Options used to display or hide the header areas of rows and 
columns.
The associated entry areas are used to set the width of row headers and 
the height of column headers respectively in pixels. 

■ Selection: Option used to set the highlighting mode of a selection. 
When the Highlight option is checked, the selection in the area is 
delimited by a highlight. In this case, the Highlight cell option indi-
cates whether the active cell must be visually identified within the 
selection. The Keep in inactive area option indicates whether the high-
lighting must remain displayed when the area is inactive. 
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Entry Page This page is used to determine data entry options for the area. 
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■ Undo and null selection: Options used to allow (or forbid) respectively 
the cancelling of an action (using the Undo command of the Edit 
menu) and areas with null selections. 

■ Drop mode: Menu used to set the type of data drop allowed in cells of 
the area during drag and drop operations. Keep in mind that this prop-
erty only sets what it is possible to carry out in the area; data copying 
must be managed separately. 

■ Resize: Options used to set whether rows and columns of the area can 
be resized manually by the user. 

■ Keyboard: Menus used to define or forbid the use of arrow keys, the 
Enter key during data input and the Carriage return key. 

■ Arrow keys: Sets the use of arrow keys for entry validation (valida-
tion of data entry and exit from cell). Validation is only carried out 
if the cursor is placed at the beginning or end of the cell contents. 

■ Input Enter key mode: Sets the effect of the Enter key (numeric key-
pad) during data input. 
- “Standard” indicates that the key validates the entry then 
selects/switches to entry mode the same cell. 
- “As Tab” indicates that the key validates the entry then 
selects/switches to entry mode the next cell to the right. The 
Shift+Enter combination has the same effect on the cell to the left. 



Creating a 4D View Area in a Form

- “As Carriage Return” indicates that the key validates the entry 
then selects/switches to entry mode the cell located directly below 
it. The Shift+Enter combination has the same effect on the cell 
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directly above it.

■ Carriage return: Sets the conditions for using the Carriage return key 
when creating a new line in the same cell. 
- “Not allowed”: The creation of multi-line cells is forbidden.
- “Allowed”: The Carriage return key creates a new line.
- “Allowed with Ctrl”: The Ctrl+Carriage return (Windows) or Com-
mand+Carriage return (Mac OS) combination creates a new line. 
- “Allowed with Shift”: The Shift+Carriage return combination cre-
ates a new line.

Select & DD Page This page is used to set the types of cell selections that will be possible 
and whether or not they can be dragged and dropped:

■ Selection column: Used to set the type of cell selections that can be 
created in the area. The “Multiple cells” type provides the greatest lib-
erty. 

■ Drag column: Used to set the type(s) of cell selections that can be 
dragged in the area. You can select several options in order to allow 
several types of selections to be dragged. 
If you check the “None” option, no selection can be dragged — any 
other options that were checked will automatically be unchecked. 
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■ Drop column: Used to set the type(s) of cell selections into which data 
can be dropped in the area. You can check several options in order to 
allow several types of selections into which data can be dropped. 
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If you check the “None” option, data cannot be dropped into any type 
of selection — any other options that were checked will automatically 
be unchecked. 

■ Signatures: Used to set the “drag” and “drop” signatures for an area. 
Signatures are alphanumeric strings (32 characters maximum) whose 
contents can be set freely. 

When drag and drop is allowed, it can take place between two areas (or 
within the same area) on the condition that they have at least one 
common signature, of the “drag” type for the source area and of the 
“drop” type for the target area. You must use the [+] and [-] buttons to 
add and delete signatures. 
For more information, refer to the “Drag and Drop, Introduction” sec-
tion of the 4D View Language Reference manual. 

Triggers Page The options of this page are used to set the triggers concerning 
selection, input and drag operations in the area:

A trigger is an “initiating event.” This page can be used to designate 
the events which can trigger selection, input and dragging operations 
in the area.
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When the same trigger is set for both selection and input, the input 
trigger has priority. When the same trigger is set for both selection and 
drag, the drag trigger has priority. 
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Note Under Mac OS, the Command key is substituted for the Ctrl key. 

■ Selection column: Used to set the mode for triggering a selection in the 
area. 
If you check the “Not allowed” option, it will not be possible to set a 
selection — any other options that were checked are automatically 
unchecked.

■ Input column: Used to set the mode for triggering input in the area. 
Input can only be carried out in the active cell. 
If you check the “Not allowed” option, input is disabled (no event can 
trigger input) — any other options that were checked are automatically 
unchecked. Input is still possible in the formula bar. 

■ Drag column: Used to set the mechanism to trigger dragging in the 
area. There is no trigger for dropping. 
If you check the “Not allowed” option, dragging will not be possible in 
the area — any other options that were checked are automatically 
unchecked. 

Options Page This page is used to set various options concerning the operation of 
the area:
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■ Copy hidden elements: Used to set whether or not hidden elements 
should be taken into account during copying. 

■ Display of save modified document confirmation dialog box: Used to 
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set whether or not to display the save confirmation message of the 4D 
View document when it has been modified. 

■ Ascii codes: The options of this area are used to set the Ascii code for 
field and record separator characters as well as for field wrapper charac-
ters. 
These characters are only used when importing/exporting data. 
In the following example: 
"E1Field1", "E1Field2", "E1Field3"; "E2Field4", "E2Field5";

■ the comma is the field separator

■ the semi-colon is the record separator (2 records: E1 and E2)

■ the quotes are the field wrappers. 

Code Page This page is used to build the 4D code corresponding to the options set 
in the Advanced Properties dialog box:

To build the code, click on the Build code button. The code then 
appears in the window as a list of statements. You can select all or part 
of it, copy it, etc. 
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The Copy all to Clipboard button can be used to copy the code directly 
into the Clipboard; you can then paste it, for example, into an area 
initialization method. The area is referenced by the $ID variable, which 
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receives the value of $1. 

To use this code with other areas, you can, for instance, paste it into a 
project method named PV_Init_area, which you can call using the 
statement PV_Init_area(MyArea). 

If you have made modifications in the Advanced Properties window, 
you can rebuild the code at any time by clicking the Build code button. 

Priority of properties To configure a 4D View area, it is possible to use either the Advanced 
Properties dialog box or programming (PV SET AREA PROPERTY com-
mand). Since both solutions can be used simultaneously and in a con-
tradictory manner, 4D View applies the following order of priority:

1 PV SET AREA PROPERTY executed in a form method.

2 Advanced Property dialog box — applies properties to a specific area. 

3 PV SET AREA PROPERTY(0;...) — applies a property to all the 4D View 
areas — for example in the "On Startup" database method.

Modifications made using the dialog boxes in the User mode do not 
affect the Advanced Properties settings. 

Note When an area is duplicated, its advanced properties are also 
duplicated.

Using 4D View in a 
form

When using 4D View in a form (in the User environment), the 
program menu bars appear above the 4D View area. 4D View menu 
commands, as well as those of 4th Dimension menus, can be selected. 
For more information on this, refer to the chapter “Using 4D objects” 
on page 133.

4D View allows use of the included area in full screen, as with any 
document.
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Expanding the 4D View 
area to Full Screen

❿❿❿❿ To view a 4D View area at full screen size:
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1 Click the full screen box in the upper right corner of the included area.
OR
Select the Go To Full Screen command in the 4D View File menu.
The document expands to fill the entire screen and the 4D View menu 
bar temporarily replaces the 4th Dimension menu bar.

If a 4D View area in a form is too small to be used without being 
expanded, it is displayed as a button.

If this button is clicked during data input, the 4D View area 
automatically expands to full screen size.

Returning to the Form When a 4D View area is expanded, the Return to Form command 
replaces the Go To Full Screen command in the File menu.

❿❿❿❿ To return to the 4D form containing an included area:

1 Select the Return to Form command in the 4D View File menu.
OR
Click the close box for the window.

Creating a New Document
A new, blank 4D View document can be created in an external window 
or in an area at any time. In either case, the new document replaces 
the current document. If changes have been made to the current docu-
ment, you will be prompted to save the changes before 4D View opens 
the new document.

❿❿❿❿ To create a new document:

1 Choose New in the 4D View File menu.
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Opening Documents in 4D View
Documents can be opened in any external window or 4D View area. 
The file formats that 4D View can open are described in the paragraph 
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“Document Formats” on page 50.

❿❿❿❿ To open a document in an external window or 4D View area:

1 Choose the Open... command in the 4D View File menu.
A standard Open file dialog box appears.

2 If you wish to restrict the display of files to a certain format, select a 
file format in the Files of type pull-down list.

3 Select the file to open.

4 Click Open.
The newly-opened document replaces the current document in the 
4D View window.

Note Only 4D View type documents (“4DPV”) remain “open” and locked at 
the operating system level: when displayed in the 4D View window, 
they cannot be opened from another application. However, a non-
native document is read and then closed. When such a document is 
displayed in the 4D View window, the standard Save file dialog box is 
displayed if the user selects the Save menu command, as for a new 
document.

Saving 4D View Documents
4D View document can be saved regardless of whether you are working 
in an external window or in a form. There are three ways to save 
4D View documents:

■ As part of a record

■ As a Mac OS or Windows file

■ As a template of a 4D View area

Saving a document 
with records

If you created a 4D View area in a form with automatic buttons and 
have associated a BLOB field to it, any information entered in the area 
is automatically saved with the record when the record is validated. For 
more information on this, refer to the paragraph “Creating a 4D View 
Area in a Form” on page 55.
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A 4D View document can always be saved as a separate file to the disk 
(refer to the following paragraph).
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Saving a document 
as a file

Any document created with 4D View can be saved as a separate file by 
using the standard Save and Save As... commands located in the 
4D View File menu.

Documents you have saved can then be opened using the Open 
command in the 4D View File menu, regardless of how the program is 
used — either as an external window or a form.

❿❿❿❿ To save a 4D View document as a file:

1 Select the Save As... command in the 4D View File menu.

Note that you must choose the 4D View File menu and not the 4th 
Dimension File menu.

4D View displays a standard Save file dialog box.
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2 If necessary, choose the desired file format to save the document from 
the Save as type drop-down list.
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By default, 4D View documents are saved in the standard 4D View file 
format. However, the document can also be saved in other formats. For 
more information on document formats available in 4D View, refer to 
the paragraph “Document Formats” on page 50.

3 Enter a name and location for the document.

4 Click Save.

❿❿❿❿ To update a saved document:

1 Select Save in the 4D View File menu.
The original document is updated.

Saving a document 
as a template

A template is a document, linked to a 4D View area, that serves as a 
starting point for each newly created record. Such documents may be 
necessary for, as an example, standard report formats or invoices. 
Instead of recreating the elements each time, the document can be 
saved as a template used by every document displayed in a particular 
4D View area in a form.

Note Templates can be created for 4D View areas in forms. If an external 
window opened from the Tools menu is used, the Save as Template 
command is disabled.
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When a 4D View document is saved as a template:

■ Static areas (labels, pictures, etc.) will be displayed as they were saved.
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■ Variable areas (data from database fields, functions, etc.) will be 
dynamically updated depending on current record data.

When a document is saved as a template, it is displayed by default in 
all new database records. Any changes made in the document are saved 
with the record. There can only be one template for each 4D View area.

The 4D View area in the following figure uses a template to 
automatically display the name and address of the customer for the 
current record. Every time the current record changes, the name and 
the address of the customer is displayed in the 4D View area:

❿❿❿❿ To save a 4D View document as a template:

1 Choose the Save As Template command in the 4D View File menu.

Static data saved in the template

Dynamic data saved in the tem-
plate (updated for each new client)
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4D View automatically assigns the file name and location of the tem-
plates, so that no Save File dialog box is displayed when you choose 
Save As Template.
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The file has the same name as the 4D View area followed by an 
underscore (and, under Windows, the “.4PV” extension). For example, 
the MyAreaPV template will be named MyAreaPV_ under Mac OS and 
MyAreaPV_.4PV under Windows.

By default, with both 4th Dimension and 4D Server (if templates are 
saved on the server), templates are stored in the database folder.

However, in client-server configuration, it is possible to store and/or 
load templates on client machines using the PV SET PLUGIN PROPERTY 
command. In this case, each client machine will contain its own 
templates. These templates are then stored as follows: 

■ Under Mac OS, in the (User)Library:Application Support:4D:4D View 
Templates:Databasename folder

■ Under Windows, in the Documents and settings\User\Application 
data\4D\4D View Templates\Databasename folder

Templates can also be created by saving a 4D View document in the 
4D View template format (.4TP extension under Windows). In order to 
be activated, a template must have the same name as the 4D View area, 
followed by an underline (and, under Windows, the “.4PV” extension), 
and be placed in the templates folder. 

Similarly, you can temporarily deactivate the operation of a template 
by changing its name or location.

❿❿❿❿ To save changes applied to a template:

1 Select again the Save as Template command in the 4D View File menu.
4D View will ask you to confirm replacement of the older template. 
Click the OK button to update the template.
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Setting Preferences
4D View allows you to set preferences for a document. You can set 
options for displaying scroll bars, displaying grids and their color, 
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number of columns and rows for a 4D View document, picture display 
and automatic resizing of rows and columns.

❿❿❿❿ To define preferences for an open document:

1 Choose Preferences... in the 4D View File menu.
The Preferences dialog box is displayed:

You can set the following options:

■ Scroll bars: check boxes allowing whether or not to display horizon-
tal/vertical scroll bars.

■ Worksheet Size: input area for setting the number of columns and 
rows for a 4D View document.

■ Grid: check boxes allowing whether or not to display cell separators 
(horizontal and/or vertical rows). A color can be set for the grid using 
the Color drop-down list.

■ Graphics: check boxes allowing whether or not to display graphics in a 
4D View document.

■ Auto Resize: check boxes allowing disabling of the optimal resizing 
feature for row height and column width by double-clicking on a title 
area.
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Managing Document Information
The Document Information... command in the Tools menu allows set-
ting the author, title and subject of your 4D View document, as well as 
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the organization for whom you work. You can also write additional 
notes about the document. 

❿❿❿❿ To display information for a 4D View document:

1 Select the Document Information... command in the 4D View Tools 
menu.
The “Document Information” dialog box is displayed:

Note 4D View automatically inserts the creation and modification dates and 
times of your documents in the “History” area.
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4D View offers various methods of navigating among cells and 
selecting them. The selection can be done manually or come from a 
search. A multi-level sort is also available.

This chapter will detail the following functions:

■ Selection, input and navigation basics

■ Copy and move cells

■ Find and replace

■ Executing sorts.

Selection, Input and Navigation Basics

Selection To select a cell, simply click on it or use the direction arrows on the 
keyboard. Its content (or formula) is displayed in the formula bar.

To select several continuous cells, drag the mouse from one end of the 
selection to the other. You can also click on the two ends of the 
selection while holding down the Shift key.

To select all cells in the spreadsheet, choose Select All in the 4D View 
Edit menu. The content of the spreadsheet (in other words, all cells) is 
then selected.

To select a column, click on the corresponding letter (or set of letters).
To select a row, click on the corresponding number.

To select a groups of cells that are not continuous, hold down the Ctrl 
key (Windows) or Command key (Mac OS) and click on each cell to be 
selected.

To deselect cells, simply click anywhere within the spreadsheet.
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Input and 
navigation
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By mouse Double-clicking on a cell allows passing into input mode in the 
relevant cell. If the cell is not empty, the insertion cursor is placed after 
the content of the cell.

Data can be entered directly once a cell is already selected, even if the 
insertion cursor is not visible in the formula bar. The input then 
replaces the content of the cell.

By keyboard The Tab key validates the cell input and selects the cell to its right.

Combining the Shift + Tab keys validates the cell input and selects the 
cell to its left.

The Carriage return key validates the cell input and selects the cell 
below it.

Combining the Shift + Carriage return keys validates the cell input and 
selects the cell above it.

The Enter key from the number pad allows validating of the input 
while maintaining the cell as the selected cell.

The direction keys (arrows) allow you to move a cell in the direction 
indicated by the arrow.

Note These default features can be modified using the 4D View language. 

Copy and Move Cells
4D View proposes specific features to copy or move cells inside an area.

Copying Cells to 
Adjacent Cells

You can use the Fill menu items to copy values to immediately 
adjacent cells (to the right or below). The Fill Down command copies 
the topmost row of selected cells onto the remaining selected cells. 
The Fill Right command copies the left-most column of cells into the 
remaining selected cells. The Clipboard is not affected.
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Suppose you want to fill rows 2 to 8 with data entered in row 1. You 
just have to select cells from rows 1 to 8, then choose Fill >Down from 
the Edit menu: 
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Note These commands copy the cell values, formulas and styles, but not the 
borders. 

Moving cells The Move command in the Edit menu allows you to move a cell 
selection within an area.

❿❿❿❿ To move information from one place to another on your area:

1 Select the cells you want to move.
The selected cells must be adjacent. 

2 Press the Ctrl key (Windows) or Command key (Mac OS) while you 
click the cell at the upper-left corner of the area to which you will 
move the selected cells.

3 Choose Move from the Edit menu.
4D View moves the selected cells to the new location.The moved cells 
overwrite any values in cells in the new location. All the information 
in a cell is moved, including values, formulas and styles, except for 
borders. 
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Find and Replace

Find Selecting the Find... command in the Edit menu displays the search 
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dialog box:

This dialog box allows searching of the entire document for a value. 
Several search options are available. 

The dialog box contains two buttons for two types of searches:

■ The Find button provokes the selection of the first cell matching the 
selected criteria. The search is carried out from top to bottom then 
from left to right starting from the current cell. Once the end of the 
document is reached (if no cell is found), the search starts from the 
beginning of the area and continues up to the current cell.

■ The Select button provokes the selection of all cells of the spreadsheet 
that correspond to the selected criteria. The search is carried out in the 
entire spreadsheet, regardless of the current cell’s location.

Note that the search does not take capital letters into account (“a” will 
find “A”). On the other hand, accented characters are taken into 
account (“à” will not find “a”).

The special character at sign (@) can be used to execute only “starting 
with” searches: for example, “Inv@” will find “Invoices”.

If the search does not find any match, 4D View generates a beep.

Search options

■ Values or Formulas
The Values and Formulas radio buttons allow setting of the search des-
tination.
Values means that the search will be executed on the cell content, for 
example, on a function result.
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Formulas means that the search will be carried over to formula ele-
ments, for example, a cell reference.

■ Match Whole Word or Match Partial Word
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The Match Whole Word and Match Partial Word radio buttons allow 
setting of the degree of search precision.
Match Whole Word means that 4D View must find cells containing 
only what has been entered as search criteria.
Match Partial Word means that 4D View must find cells containing at 
least a portion of what has been entered as search criteria.

Find Next The Find Next command executes a new search using the last search 
criteria. This command is disabled if there has not been a previous 
search.
The new search is executed from bottom to top and then from left to 
right starting from the current cell.

Replace The Replace... command displays the replace dialog box. This dialog 
box allows searching and replacing of a value.

The dialog box contains a search area and a replace area. The search 
area works exactly as the search area in the “Find” dialog box. For more 
information, refer to the paragraph “Find” on page 80.

Enter the value to search for in the “Find” area and the replacement 
value in the “Replace with” area.

■ The Replace button replaces the contents of the first cell matching the 
find criteria with the replacement value. The search is done from bot-
tom to top then from left to right starting from the current cell. 



Chapter 4  Editing Cells

■ Replace all
The Replace all button replaces all cell contents matching the find cri-
teria with the replacement value. The replacement is done in the entire 
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spreadsheet, regardless of the current cell’s location.

Replace Next Selecting the Replace Next menu command executes a new 
replacement using the last replace criteria. This command is disabled if 
there has not been a previous replace.

Set name The Set name... command displays the set cell name dialog box:

This dialog box allows attributing of a name to the current cell: once a 
name is entered into the entry area, it is displayed in relation to the 
current position of the cell in the list.

Note The first three characters of a cell name must not be numbers. 

Entry area

List of cells named in 
the spreadsheet
(empty by default)
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To delete a cell name, select it from the list and click the Delete 
button. To modify a name, select it and enter the new name in the 
entry area.
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If rows or columns are inserted or deleted in the spreadsheet, the name 
will remain associated with the cell, regardless of its new coordinates.
If the cell appears in the deleted selection, its name will disappear from 
the list.

This function is primarily useful when combined with the following 
command, Goto..., because it allows simultaneously selecting specific 
cells without needing to know their location.

In addition, cell names can be used in formulas to define absolute 
references (see the paragraph “Using Absolute Reference” on 
page 120). 

Goto The Goto... menu command displays a dialog box listing the cells with 
an associated name:

This dialog box allows choosing of a cell to select from the list of 
defined cells using the previous command (Set name...).

Validating this choice moves the spreadsheet vertically and 
horizontally, if necessary, to display the target cell. This command is 
disabled if no cell names have been set in the document.
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Go To Last Cell The Go To Last Cell command selects the last cell of the spreadsheet. 
The last cell is located at the intersection of the right-most column and 
the bottom-most row containing a non-empty cell.
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The spreadsheet display area is moved vertically and horizontally, if 
necessary, to display the last cell.

Executing Sorts
4D View allows execution of 4 levels of sorts in spreadsheet columns 
and rows.

By default, 4D View executes sorts in ascending order (from 1 to 9 or A 
to Z). However, the Descending option can be checked, for each sort 
level, to execute sorts in the opposite order.

Any type of data can be sorted, with the exception of arrays and 
picture-type imported1 fields.

Note Dynamically linked columns and rows cannot be sorted by the 
4D View Sort menu command. The sort must be carried out within 4D 
records. Sorting the selection with a 4D command will be reflected in 
the 4D View area linked to this data (in User mode, you will need to 
redraw the 4D View area). 
Mixed ranges (containing static and dynamic cells) cannot be selected 
and sorted. For more information on dynamic links, refer to the  
chapter “Using 4D objects” on page 133.

Last cell

1. Imported 4D field values can be sorted (with the exception of arrays and 
picture type fields) during import (see the chapter “Using 4D objects” on 
page 133).
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❿❿❿❿ To sort cells:

1 Select the range of cells to be sorted:
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2 Choose the Sort... command in the Edit menu.
The sort cells dialog box is displayed:

3 Set sort parameters.

■ Using the radio buttons, select whether rows or columns will be 
sorted.

■ Write the row number or column letter for the first sort level.

■ Enter the row number or column letter for the following sort levels, 
if necessary.
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■ For each sort level, select the sort order (ascending or descending) 
by checking the appropriate option.
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In this example, the “Last name” column will be sorted in an 
ascending manner; the “First name” column in descending order; and 
the “Age” column in ascending order.

4 Click the OK button to validate parameters.
The selection is then sorted according to your criteria.
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Documents

4D View allows customizing of the appearance of your documents. 
Basic cell characteristics, such as fonts, color, alignment, format, 
attributes and borders can be modified.

Customized style sheets can also be used to apply a set of changes to 
cells, titles or page headers and footers.

This chapter will detail the following functions:

■ Cells in the spreadsheet,

■ Setting the appearance of cells,

■ Setting cell borders,

■ Using style sheets,

■ Using pictures,

■ Protecting cells and cell content.

Cells in the Spreadsheet
Spreadsheets are composed of rows and columns. A number is associ-
ated with each row. A letter (or group of letters once the number of 
rows surpasses the number of letters in the alphabet) is associated with 
each column.

The intersection of a row and a column makes a cell.
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The appearance of a cell varies depending on its context:

■ Non-selected cell:
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■ Single selected cell. It also has thicker borders:

■ Selection of several cells:

Note The appearance of cells, such as cell selections, varies depending on 
the colors selected.

Resizing the 
spreadsheet

By default, cells are presented in a table that is 65535 rows by 2048 
columns. This is the maximum size of a spreadsheet. Tables of this size 
are rarely used; you can stay within the limits that are better adapted 
to your work by restricting the number of rows and columns.

To modify the number or rows and columns, choose the Preferences... 
command in the 4D View File menu. In the Preferences dialog box, set 
the number of columns and rows for the table in the “Worksheet Size” 
area:

Resizing the data 
input area

If entered cell data requires more than one line, the data input area 
(formula editor) can be resized to accommodate the desired number of 
lines.

Table size definition
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To resize the data input area, place the cursor on the lower border of 
the input area and drag the mouse toward the bottom, until the 
necessary number of lines appears.
894D View User Reference

Types of cells 4D automatically determines cell type depending on the cell content. 
For example, a cell containing the value “1256” will be a numeric type. 
When the cell content comes from 4D or field calculations, the type is 
determined by the data source.

Cells can be of the following type:

■ Number: all numeric values up to 15 significant digits.

■ Date: all date formats.

■ Time: all time formats.

Note Dates and times can be combined.

■ Boolean: as in 4th Dimension.

■ Text: Cells containing characters can expand several cells to the left 
and to the right, if these cells are not already occupied, or across sev-
eral lines in the same cell.

These cells can be formatted to the user’s liking (see the paragraph 
“Defining Cell Appearance” on page 91).

■ Picture: 4D pictures can be inserted in the cells using the linked fields 
or arrays feature (see the chapter “Using 4D objects” on page 133). In 
this case, cells containing pictures are picture cell types. Resizing the 
cell containing the picture will modify the appearance of the picture, 
depending on the applied format. For more detailed information on 
formatting pictures, refer to the paragraph “Format tab” on page 95.

Note • In 4D View areas, static pictures (imported or pasted pictures) are 
floating, appearing “above” the spreadsheet—they are not linked to a 
cell. For more information, refer to the paragraph “Using Pictures” on 
page 105. 
• It is possible to disable the automatic recognition of cell contents 
using the Forced text option (see the paragraph “Format tab” on 
page 95). 
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Cell content Information contained in cells can come from:

■ direct input of information in the formula bar.
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The information present in the selected cell is displayed in the formula 
bar.

■ the cut/copy/paste of values.
The cut/copy/paste functions are detailed in the paragraph “The Edit 
menu” on page 24.

■ 4th Dimension fields or calculations in these fields.
The various capabilities are covered in the chapter "Formulas, Opera-
tors, Operands and Functions” on page 113.

■ importing 4D View spreadsheets, Tab/Tab/Return (ASCII file) or SYLK.

Note The document formats that 4D View can open are listed in the chapter 
"Managing 4D View Documents” on page 49.

Cell characteristics A cell is composed of four types of information:

■ values or cell content,

■ formulas,

■ formats,

■ borders.

You must mark off these characteristics when you select the Paste 
Special... or Clear commands in the Edit menu. You can also specify 
which characteristics you want 4D View to apply.

Formulas are detailed in the chapter "Formulas, Operators, Operands 
and Functions” on page 113.

Formats are detailed in the paragraph “Defining Cell Appearance” on 
page 91.

Borders are detailed in the paragraph “Defining Cell Borders” on 
page 100.
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Cell attributes Certain cells in your spreadsheet can be protected to prevent them 
from being modified or deleted.
One or more visible cells can be made invisible, to improve the 
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appearance of your work sheet
By default, cells are visible and unprotected.

Refer to the paragraph “Protecting Cells and Cell Content” on 
page 112 for more information on this.
Cell attributes are detailed in the paragraph “Attributes tab” on 
page 100.

Defining Cell Appearance
❿❿❿❿ To format the content of a selection of cells:

1 Select the cells to format.
If more than one cell, row or column is selected, they will be formatted 
at the same time, in the same manner.

2 Choose the Cell(s)... command in the Style menu.

The “Format” dialog box appears allowing you to modify the attributes 
of your selection.

Note You can go back to the default appearance at any time by clicking the 
Default button or revert back to the original appearance by clicking the 
Revert button.
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Font tab In the “Font” tab page, you can use a style sheet, select a font and 
modify its size, as well as choosing the text style.
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Any modifications made are reflected in the example area.

Note If you set and applied the Cells style, selecting style attributes (with the 
exception of the “style sheet” attribute, see below) adds to the 
appearance set in the style sheet for the selection.

Style The Style option allows you to select a previously created style sheet. 
This style sheet is applied to the set of selected cells.

Note If you have already defined and applied the Cells style sheet, the 
application of another style sheet will replace it. For more information 
on creating and modifying style sheets, refer to the paragraph “Using 
Style Sheets” on page 101.

Font The Font option allows you to select a font available on your machine. 
This modification is applied to the set of selected cells.

Size The Size option allows selecting a font size or to enter one using the 
Other... option. This modification is applied to the set of selected cells.
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Text Style The Text Style option allows selecting of typographical attributes to 
apply to your selection.

Note Advanced typographic settings (Shadow, Outline, Condense and 
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Extended) have no effect under Windows. However, they can be 
selected in this environment in light of cross-platform database usage.

Color tab In the “Color” tab page, you can set colors for text, background, 
negative numbers and zeros -- for even- and odd-numbered rows:

Note If you defined and applied the Cells style sheet, selecting a color adds 
to the appearance set in the style sheet for the selection.

Even- and odd-
numbered rows

The “Even Rows”, “Odd Rows” and “Both” radio buttons allow you to 
select which rows will receive the color modifications. Color settings 
made in the dialog box will apply to even rows, to odd rows, or to both 
rows (default selection).

Text color The “Text Color” option allows you to select a color (preset or 
customized) for the text in selected cells, for the type of rows selected.

Background Color The “Background Color” option allows selecting of a color (preset or 
customized) for the background of selected cells, for the type of rows 
selected.
Choosing None (selected by default) means that the cell background 
will be transparent. 
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If Negative The “If Negative” option allows you to set a color (preset or 
customized) for negative numbers in the selection, for the type of rows 
selected.
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If Zero The “If Zero” option allows you to select a color (preset for customized) 
for zeros in the selection, for the type of rows selected.

Alignment tab In the “Alignment” tab page, you can horizontally and vertically align 
the content of selected cells, as well as rotate cell content:

Note If you defined and applied the Cells style sheet, selecting an alignment 
option adds to the appearance set in the style sheet for the selection.

Horizontal Alignment The “Horizontal Alignment” option allows you to set the horizontal 
alignment of the cell content. This modification applies to the set of 
selected cells.

The According to type option corresponds to the default alignment for 
the type of entered cell data (to the right for numbers, dates and times; 
to the left for text).

Vertical Alignment The “Vertical Alignment” allows you to select the vertical alignment 
for the content of your cells: on top, in the center or to the bottom. 
This parameter applies to the set of selected cells.
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Rotation The “Rotation” option allows you to rotate the content of your cells 
90, 180° or 270°. Cell content can be set back to normal by selecting 
None. This modification applies to the set of selected cells.
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Automatic Word Wrap The “Automatic Word Wrap” option causes automatic wrapping of the 
contents of a cell when they exceed its width. By default, when this 
function is not enabled, the contents of cells run over onto adjacent 
cells.

Format tab In the “Format” tab page, you can define the display format for 
number, text, date and time, boolean and picture data types:

Note If you defined and applied the Cells style sheet, selecting a format adds 
to the appearance set in the style sheet for the selection.

Several display formats can be defined for several data types in the 
same cell. For example, you can define simultaneously a boolean 
format, a text format and a number format. 4D View will use the 
appropriate format depending on the actual cell data type. 

Forced Text The “Forced text” option is used to force the display of a cell as raw 
text, i.e. without formatting carried out by 4D View according to its 
contents (number, date, text, etc.). Selecting this option disables all the 
display format pop-up menus (except for Text type data).
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Text The “Text” option only provides user-created formats (refer to the 
paragraph “Create a customized format” on page 98).
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Number The “Number” option puts several numeric formats at your fingertips. 
Below is a description of these options:

■ # type
Pounds keys are replaced by numbers when displaying numeric values. 
When the number of digits is less than the number of pound keys, the 
pound keys to the left are deleted as well as the unnecessary accompa-
nying text.
For example ### millions ### thousand ### applied to 21245 will 
read: 21 thousand 245.

■ ^ type
Circumflex accents are replaced by numbers, but if the number of dig-
its is less than the number of circumflex accents, the remaining 
accents are replaced with hard breaks.

■ * type
Stars are replaced by numbers, but if the number of digits is less than 
the number of stars, the remaining stars will appear in the display. The 
accompanying text between the left-hand stars and the left-most num-
ber will be replaced with stars.

■ 0 type
Zeros are replaced with numbers but if the number of digits is less than 
the number of zeros, the remaining zeros will appear in the display.

■ ###,##0;(###,##0) / $###,##0.00;$(###,##0.00)
When you choose this format, the appearance of the right value will 
change depending on if the result is positive or negative. With this 
type of format, you can also use colors to differentiate positive num-
bers from negative numbers. Refer to the paragraph “Color tab” on 
page 93. 

■ Positive;Negative;Null
When you choose this format, the values themselves are not displayed, 
but rather notification that the result is negative, positive or null.

■ ##_##_##_##
Displays two numbers_two numbers_ (etc.)
This format is intended for displaying telephone numbers. Enter the 
numbers without worrying about the format. In your own formats, 
you can modify the number of pound keys.
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Date & Time The “Date & Time” option makes several specific date and time 
formats available, as in 4D.

Also, you have access to mixed date and time formats.
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These particular formats can be used to display a date and time in the 
same cell. You can, for example, specifically indicate the time and date 
when an operation took place and then format this data.

In order for 4D View to “understand” that you are entering a date and 
time in the same cell, you must follow the rules below:

1 Select the cell before entering any information.

2 Enter the “=” sign.

3 Enter the date between exclamation points (!).

4 Add the “+” sign.

5 Enter the time between question marks (?) under Windows or † 
(option+t) under Mac OS.

6 Validate input.

The following is an illustration of some available 4D View formats:

Boolean The “Boolean” option only provides user created formats (refer to the 
paragraph “Create a customized format” on page 98).

These formats must be of the “True;False” type, “Yes;No” or even 
“Open;Closed”, etc.

Picture The “Picture” option provides different picture formats:

■ Truncated (non-centered)
This format truncates the picture in the cell and crops any portions 
that do not fit in the cell.

Format name Result
long to h:mn AM/PM Tuesday 7 June 2005 at 11:06 PM
abbreviated to 
h:mn AM/PM 

Tue 7 June 2005 at 11:06 PM

short to H:MN:SEC 6/7/05 at 23:06:15
Month, day year to 
H:MN AM/PM 

June 7 2005 at 11:06 PM

special and H:MN:SEC 6/7/05 and 23 hours 6 minutes 15 seconds
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■ Truncated (centered)
This format centers the picture in the cell and crops any portions that 
do not fit in the cell.
98 4D View User Reference

■ Replicated
This format fills the cell with as many copies of the picture as needed, 
placed side by side, without modifying the original picture size.

■ Scaled to Fit 
This format completely fills the cell by enlarging/reducing the picture. 
Since this operation is not proportional, the final result may be consid-
erably different from the original.

■ Scaled to Fit (proportional)
This format tries to fill the cell by enlarging/reducing the picture in a 
proportional manner. If this is not possible, it will leave a white area at 
the bottom or to the right of the picture.

■ Scaled to Fit (centered)
Like the Proportional format, this format tries to fill the cell by enlarg-
ing/reducing the picture in a proportional manner. It also centers the 
picture within the cell. If the cell cannot be completely filled, it leaves 
a white area above and below or to the left or right of the picture.

Note Only pictures inserted using the linked cells or linked rows features 
will be affected by the cell picture format. Other pictures can only be 
formatted using the Picture Attributes dialog box (see the paragraph 
“Picture attributes” on page 107). 

Create a customized 
format

You can create your own customized formats —  if you follow the rules 
listed above (relating to the #,^,*, and 0 symbols). Customized formats 
can be selected for each data type.
Note that Text and Boolean type data only accept customized formats.

❿❿❿❿ To create a customized format, for example, “##-##-##-##-##”:

1 Click the Edit Format button:

Edit Formats button
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The edit format dialog box appears, empty by default.

2 Enter the ##-##-##-##-## format in the area at the bottom of the 
dialog box.
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3 Click the Add button to validate your new format.

4 Click OK to validate your dialog box.
Your format will now appear at the bottom of the drop-down bars:
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Attributes tab In the “Attributes” tab page, you can modify attributes of the cell 
selection:
100 4D View User Reference

The Attributes options allow you to:

■ hide cell content

■ lock cells
Refer to the paragraph “Protecting Cells and Cell Content” on 
page 112 for more information on these attributes.

■ enable spell check features
This option requires the installation of an additional plug-in.

Defining Cell Borders
❿❿❿❿ To set the border for a selection of cells:

1 Select cells to border.
If you select several cells, rows or columns, they will be formatted at 
the same time in the same manner.

2 Choose the Border(s)... command in the Style menu.
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The “Borders” dialog box appears allowing you to modify the 
attributes of your selection.

You can individually choose the presence and color of each of the six 
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borders.

Certain buttons and arrows are disabled when the cell selection does 
not contain inner borders.
The five buttons allow the use of pre-set border layouts.
The six arrows allow the selection of the corresponding border.

Using Style Sheets
The Style Sheets... command in the 4D View menu allows you to 
choose a general style for the 4D View document and to set most 
appearance parameters in a single operation.

1. Select the type 
of border to apply

2. Select border 
color 

3. Define the border(s) 
to modify using the 
arrows or the pre-set 
border buttons .
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Once this command is chosen, the style sheet parameters dialog box 
appears:
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This dialog box offers the same features as the “Format” dialog box 
(accessible using the Style>Cell(s)... command). For more information, 
refer to the paragraph “Defining Cell Appearance” on page 91.

Default style sheets The Style for drop-down menu allows you to select one of three default 
style sheets:

Choice of style 
sheet  
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Default style sheets are automatically applied to the document once 
the dialog box is validated.

■ Cells
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This style sheet is applied to the set of cells in the spreadsheet. It can be 
combined with a specific format for certain cells. Refer to the para-
graph “Defining Cell Appearance” on page 91, for a detailed descrip-
tion of the different formats and how they interact with style sheets.

■ Columns/Rows Headers
This style sheet applies to row and column headers.

■ Page Header & Footer
This style sheet applies to the header and footer of your 4D View docu-
ments. Refer to the paragraph “Print Options...” on page 168, for a 
detailed description of page header and footer contents.

Note Unlike customized style sheets, default style sheets can neither be 
renamed nor deleted.

Customized style 
sheets

You can create your own customized style sheets.

To apply these style sheets, select the cells then choose the style sheet 
in the menu in the Style toolbar:

Once created, the customized style sheets also appear in the Style for 
menu in the “Style Sheets” dialog box. These new style sheets can now 
be modified:

❿❿❿❿ To create a customized style sheet:

1 In the “Style Sheets” dialog box, click the New... button.
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A dialog box allows you to name the style sheet:
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2 Enter a name and validate the dialog box.

■ Click the Rename button to rename a customized style sheet.

■ Click the Delete button to definitively delete a customized style sheet.

Priority of the styles The final style of a cell may be the result of style applications at several 
different levels: the standard “Cell” style sheet, a customized style 
sheet and a style directly applied using 4D View menu commands. 

In 4D View, this layering is managed in a hierarchical manner: priority 
is first given to the style defined by the user, then to the customized 
style sheet and finally to the standard style sheet;

Styles defined Cell content

Standard style sheet (cell) Bold, Underline My Text
Customized style sheet Color blue My Text
User style Not bold, Italic, 

Color red
My Text
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Using Pictures
4D View enables you to insert pictures into your spreadsheets. Three 
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types of pictures may be used: 

■ Static pictures: 4D View inserts a static picture when you copy and 
paste a picture into the area or import a 4D picture field (see the para-
graph “Importing Fields” on page 134). 
In this case, the picture is not associated with any particular cell, it 
“floats” in the area. You can only move it using the mouse or by modi-
fying its coordinates in the Picture attributes dialog box. 

■ Dynamic references: pictures which result from the referencing of 4D 
Picture type fields or variables. When the current value of the field or 
variable is modified, the picture inserted in the area automatically 
reflects this modification (see the paragraph “Dynamically Referencing 
Fields” on page 142). 
In this case as well, the picture is not associated with any particular cell 
and “floats” in the area. You can only move it using the mouse or by 
modifying its coordinates in the Picture attributes dialog box. 

■ Dynamic links: this type of picture comes from dynamic links with 4D 
Picture type fields or variables (see the paragraph “Dynamic Links” on 
page 148). According to the principle of dynamic links, any modifica-
tion made on the 4D field will be reflected in the 4D View area and 
vice versa: when you double-click on a picture which results from a 
dynamic link, it becomes enterable. You can then paste in another pic-
ture which replaces the previous one in the 4D View area and in 4D as 
well. 
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In this case, the pictures are associated with the cells that contain 
them. It is not possible to modify them using the Picture attributes dia-
log box. Only cell formatting (see the “Format tab” on page 95) is 
106 4D View User Reference

taken into account. 

Different kinds of pictures

Standard display (Values)

References display

Linked picture (Replicated format)

Field reference (Add pictures... menu)

Pasted picture
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Picture attributes When you double-click on a static picture or a picture reference, the 
“Picture Attributes” dialog box appears:
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This dialog box allows you to modify the picture characteristics:

Position The Top and Left entry areas show the location of the picture. These 
coordinates (in pixels) indicate the top left corner of the picture and 
are calculated starting from the top left corner of the spreadsheet. 

Mapping This area allows you to modify the picture display within the 
spreadsheet:

■ Mapping menu: this menu allows you to define the picture appearance 
when it is resized. For more information on the values of this menu, 
see the paragraph “Picture” on page 97. 

■ Background: by default, pictures are placed “in front of” the spread-
sheet and thus hide any other information that it contains. If you 
check this box, the picture will be placed “behind” the spreadsheet. 

■ Locked: when you check this box, the size and position of the picture 
are locked in the spreadsheet: it is not possible to move or resize it 
using the mouse (on the other hand, double-clicking on it will display 
the “Picture attributes” dialog box). This option also enables you to 
select cells located “in front of” a background picture using the mouse.

Dimensions This entry area enables reading and modification of the picture width 
and height (in pixels). 

■ Keep Proportions: if you check this box, the initial proportions of the 
picture are restored when you validate the dialog box. 



Chapter 5  Formatting 4D View Documents

■ Relatives: when you check this box, the picture width and height val-
ues are expressed as a percentage with respect to the initial size of the 
picture. 
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Reference This area is only active for dynamic pictures referencing a 4D field or 
variable (pictures inserted using the Add pictures... menu command). 

When a picture reference is inserted, for example, in a template 
document, the displayed picture is modified each time the actual 
record is changed. 

It is possible that the size of the pictures contained in the records are 
not all the same. By default, 4D View displays the picture in its original 
size which may vary from one area to another.

If you check the Locked Size box, all the picture references will be 
displayed within the frame originally defined for the area. In this case, 
the display options set in the dialog box define the way in which 
pictures will be resized within the set frame, if necessary. 

The Edit... button displays the Choose Picture Field dialog box (see the 
paragraph “Inserting Pictures” on page 145). 

Managing Columns
Double-clicking a column header adjusts the column width depending 
on its largest content.1

Double-clicking the right-hand separator of a column applies the 
default 4D View column width—108 pixels.

The Column(s) hierarchical sub-menu of the Style menu allows setting 
or enabling of certain characteristics of the columns in the 
spreadsheet.

1. This function can be disabled in the Preferences dialog box. Refer to the 
paragraph “Setting Preferences” on page 74.
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The commands of this sub-menu are only applied to columns of 
selected cells in the document.
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Width Selecting the Width... command displays a dialog box allowing you to 
set the width, in pixels, of selected columns:

You can enter the desired width in the available input area.

To return to the default 4D View column width (108 pixels), click the 
Default button.

To cancel your input and return to the last width set for the selected 
columns, click the Revert button.

To validate the dialog box, click the OK button. Click the Cancel 
button if you do not wish to save changes.

Automatic Width You can automatically adjust column widths depending on the width 
of its largest content. There are two ways in which to do this:

■ Use the Automatic Width command. In this case, all selected columns 
will be resized.

■ Double click a column header.
This function can be disabled in the Preferences dialog box. Refer to 
the paragraph “Setting Preferences” on page 74.

Default Width The Default Width command allows you to return the selected 
columns to the default width of 108 pixels. This menu command 
completes the same action as the Default button in the column width 
dialog box.
Double-clicking the right-hand separator of a column applies the 
default 4D View column width. 
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Hide The Hide command allows you to hide selected columns.
Do not confuse this function, which makes selected columns from the 
spreadsheet disappear, with the “Hidden” cell attribute, which only 
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hides the content (see the paragraph “Protecting Cells and Cell 
Content” on page 112).

Show The Show command allows you to show previously hidden columns 
within the selection.

For example, if you hid column D in your spreadsheet, select columns 
C and E, then choose the Show command to make it reappear.

Managing Rows
Double-clicking a row header adjusts the size of the row depending on 
its largest content1.
Double-clicking the bottom-hand separator of a row applies the default 
4D View row width—19 pixels under Windows and 16 pixels under 
Mac OS.

The Row(s) hierarchical sub-menu in the Style menu allows setting or 
enabling certain characteristics of the rows in your spreadsheet:

Height The Height... command displays a dialog box allowing you to set the 
height, in pixels, of selected rows: 

1. This function can be disabled in the Preferences dialog box. Refer to the 
paragraph “Setting Preferences” on page 74.
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You can enter the desired height in the available input area.

To return to the default 4D View row height (19 pixels under Windows 
and 16 pixels under Mac OS), click the Default button.
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To cancel your input and return to the last height set for the selected 
rows, click the Revert button.

To validate the dialog box, click the OK button. Click the Cancel 
button if you do not wish to save changes.

Automatic Height You can automatically adjust row height depending on the height of 
its largest content. There are two ways in which you can do this:

■ Use the Automatic Height command. In this case, all selected rows will 
be resized.

■ Double click a row header.
This function can be disabled in the Preferences dialog box. Refer to 
the paragraph “Setting Preferences” on page 74.

Default Height The Default Height command allows you to return the selected rows to 
the default height of 19 pixels under Windows and 16 pixels under 
Mac OS. This menu command completes the same action as the 
Default button in the row height dialog box.
Double-clicking the bottom-hand separator of a row also applies the 
default 4D View row height.

Hide The Hide command allows you to hide selected rows.
Do not confuse this function, which makes selected rows from the 
spreadsheet disappear, with the “Hidden” cell attribute, which only 
hides the content (see the paragraph “Protecting Cells and Cell 
Content” on page 112).

Show The Show command allows you to show previously hidden rows 
within the selection.

For example, if you hid row 5 in your spreadsheet, you should select 
rows 4 and 6, then choose the Show command to make it reappear.
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Protecting Cells and Cell Content
4D View allows hiding of cells or making them non-enterable.
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Once the content of a cell is hidden, it is no longer visible and the cell 
is automatically protected, in other words, non-enterable.

If you make a cell non-enterable, it remains visible but its content can 
no longer be modified.

Hiding cell content

❿❿❿❿ To hide the content of cells:

1 Select the cell(s) to hide.

2 Select the Hide command in the Security submenu of the Tools menu.

Once the content of your cells is hidden, 4D View displays a different 
cursor in the formula editor when attempting to modify them.

Note Be sure not to confuse this function with the Hide function for rows 
and columns which makes them disappear from the spreadsheet (see 
the paragraph “Hide” on page 110 and the paragraph “Hide” on 
page 111).

❿❿❿❿ To display previously hidden cell content:

1 Select the cell(s) whose content is hidden.

2 Select the Show command in the Security submenu of the Tools menu.
The content of cells is once again visible.

Locking cells

❿❿❿❿ To lock cells:

1 Select the cell(s) to lock.

2 Select the Lock command in the Security submenu of the Tools menu.

The content of locked cells is still visible, but 4D View displays a 
different cursor in the formula editor when attempting to modify their 
content.

❿❿❿❿ To unlock previously locked cells:

1 Select the locked cell(s).

2 Select the Unlock command in the Security submenu of the Tools 
menu.
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Operands and Functions

This chapter describes the entering of formulas and their components, 
operators and operands (constants, cell references, as well as specific 
4D View functions).

This chapter is broken down into the following parts:

■ Entering a formula or a function

■ Operators, Operands and Constants

■ Cell references

■ 4D View functions

Entering a Formula, a Function or a Reference
❿❿❿❿ To enter a formula or a function in a 4D View area:

1 Select the cell into which you will enter the formula or function.

2 Enter = (the equal sign).

3 Enter the formula then hit the Enter key.
OR
• Under Windows, right-click in the input area of the formula bar.
• Under Mac OS, right-click or Control+click in the input area of the 
formula bar.
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A pop-up menu listing the formula categories and available references 
appears, allowing you to select the desired elements:
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Operators and Operands
Every 4D View formula is an expression that returns a value. All 
expressions are comprised of operands and operators.

Operators available in 4D View are generally identical to those for 
4th Dimension.

Operands are divided into several categories:

■ constants,

■ references to other cells (relatives, absolutes, mixed or by name),

■ 4D variables, fields and functions,

■ Internal 4D View functions.

Data Types 4D View supports five types of data:

■ numbers (real to 15 precise numbers),

■ dates (same as 4D),

■ times (same as 4D),

■ character strings (one or more rows),

■ booleans (same as 4D).
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Operators

Numeric operators +: addition
-: subtraction
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*: multiplication
/: division
\: remainder
÷ (Alt+0247 under Windows, Option+: under Mac OS): whole division
^: exponent (raise it a power)
%: percentage (divide the number before the operator by one hundred)

Boolean operators &: and logic
|: or logic
¬ (Option+l) under Mac OS or ~ (tilde, AltGr+2) under Windows: 
negation

String operators +: concatenation
-: destruction
\: position

Date operators +: date + number of days -> date
+: date + time -> date + time of day
-: date - number of days -> date
-: date - date -> number of days between the two.

Duration operators +: addition
-: subtraction
*: duration * number -> duration
/: duration / number -> duration

Comparison operators 
(2 operands of the same 
kind)

=: equal to
≠ (Mac OS) or # (Windows): different than
>: greater than
<: less than
>=: greater than or equal to
<=: less than or equal to

Operator priority List of operators from most to least important:

1. ¬ (Mac OS) and ~ (Windows)%
2. * / \ ÷ ^ &
2. + - | 
3. = ≠ (Mac OS) and # (Windows) > < >= <=
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Constants A constant is a value that does not change during execution.

The writing conventions are described in the following paragraphs.
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Numeric constants A numeric type constant is written without a separator:

1,2
1,2 E3
1,2E-3
0,3x

Date constants A date type constant is still written between two exclamation points:

!10/12/01!

Time constants A time type constant is still written between two question marks under 
Windows (or two † under Mac OS):

?10:12:10? 
†10:12:10† (Mac OS only)

Text constants Character strings (or texts) are written between the ' (straight 
apostrophe) or “ (straight quotation mark) symbols:

'Sophie' or “Sophie”

If you use one of these characters in your string, use the other one as a 
separator.

Booleans Booleans only have two possible values: true or false.

This type of value is primarily used for the If function and to read 
4th Dimension boolean fields.

Priority of Operands 
in Formulas

When two or more different operands have the same name, 4D View 
determines the type of each element according to the following order 
of priority: 

Priority Element type

1 Cell reference
2 Cell name
3 4D View function
4 Project method
5 4D command
6 Variable
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For instance, if the string "MyTotal" used in a formula corresponds to a 
project method and a cell name, 4D View will consider, at the time of 
formula analysis, that it consists of a cell name. 
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Using Cell References
Formulas often refer to other cells by means of cell addresses. You can 
copy such formulas into other cells. When you copy or move these 
cells to new locations, each cell address in that formula will either 
change or stay the same, depending on how it is typed. A reference 
that changes is called a relative reference, and refers to a cell by how far 
left/right and up/down it is from the cell with the formula. A reference 
that always points to a particular cell is called an absolute reference. 

You can also create a mixed reference which always points to a fixed 
row or column.

For example, the following formula, entered in cell C8, adds the values 
in the two cells above it and displays the result.

= C6 + C7

This formula refers to cells C6 and C7. That is, 4D View is instructed to 
refer to these other cells for values to use in the formula.

Relative Reference A relative reference modifies itself automatically when the formula 
that contains the reference is copied and pasted, or when the Fill Down 
or Fill Right menu items are used to copy the formula to other cells. In 
the example, the formula in cell C8 refers to cells C6 and C7, the cells 
one row up and two rows up. If you copy the formula in cell C8 to cell 
B10, the formula modifies itself to refer to cells B8 and B9, maintaining 
the same relative reference as the original formula—to the two cells 
above it in the same row.
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Absolute Reference An absolute reference, by contrast, does not change when it is copied 
or pasted. If the formula in C8 refers to cells C6 and C7 with absolute 
reference and you copy it to cell B10, the formula in cell B10 still refers 
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to cells C6 and C7.

By default, cell reference is relative. You can make the reference 
absolute when you want a formula always to refer to the same cell no 
matter where the formula is copied. 

Original 
formula

Copy Copy

Relative reference is 
to cells in the same 
relative position

Original 
formula

Copy Copy

Absolute reference 
is to the specific cells 
themselves
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Reference Notation If you use only cell coordinates, for example, C5, 4D View interprets 
the reference as relative. You may make the reference absolute by 
putting a dollar sign in front of the letter and the number, as in $C$5.
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You can mix absolute and relative references by inserting a dollar sign 
in front of the letter or the number alone, for example, $C5 or C$5. A 
mixed reference allows you to specify either the row or the column as 
absolute, while allowing the other portion of the address to refer 
relatively.

A convenient, fast and accurate way to specify an absolute reference is 
to name the cell and use that name in place of the cell address. A 
reference to a named cell is always absolute. For information about 
naming cells, see the paragraph “Set name” on page 82.

The following table shows the effect of the different notations:

Using Relative 
Reference

Relative reference enables you to copy a single formula into several 
cells without having to edit it. The formulas are automatically 
modified to perform the same calculation on the cells in the same 
relative location as the original formula. 

This operation is especially useful when you build a spreadsheet that 
performs the same calculation over several different cells. Instead of 
having to create the same formula several times, you can create it once 
and copy it as many times as necessary.

Example Type of reference Result

C5 Relative Reference is to the relative location of cell 
C5, depending on the location of the cell 
in which the reference is first used

$C$5 Absolute Reference is absolute. Will always refer to 
cell C5 no matter where it is used.

$C5 Mixed Reference is always to column C, but the 
row reference is relative to the location of 
the cell in which the reference is first used.

C$5 Mixed Reference is always to row 5, but the col-
umn reference is relative to the location of 
the cell in which the reference is first used

Cell name Absolute Reference is absolute. Will always refer to 
the named cell no matter where the refer-
ence is used.
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▼ Suppose you are planning to purchase an automobile. You construct a 
spreadsheet that calculates the payment on a loan. You enter the fol-
lowing formula in cell C9:
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=MonthlyValue (B5/12; B6; B7)

In this formula, the annual interest rate (B5), the number of payments 
(B6) and the amount of the loan (B7) are used to calculate the amount 
of each payment.

You then copy the formula to cells C9, D9 and E9. By entering the 
rates, months and amounts for each car, you can compare the 
monthly payment for each one.

Because of relative reference, you can write the formula only once, 
then copy it and paste it twice. The formula changes so that the same 
operation is performed on new cells.

Using Absolute 
Reference

Use absolute reference when you want to refer to a specific cell no 
matter where the formula is copied.

▼ Again, suppose you are buying a car and suppose you have set aside 
one cell, B5, specifically to contain the interest rate. You could then 
enter the following formula in cell B9:

=MonthlyValue ($B$5/12; B6; B7)
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This formula performs the same calculation to determine the amount 
of each payment. When you copy the formula to cells C9, D9 and E9, 
however, the absolute reference to cell B5 remains in effect.
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Because of absolute reference, you need to enter the interest rate only 
once. The cell reference to B5 remains the same in each formula. 
Wherever you paste the formula on the spreadsheet, it always refers to 
cell B5. To test the effect of different interest rates on your monthly 
payment, you can enter the new rate in cell B4; 4D View will 
recalculate the payment for each car.

Functions
4D View has its own functions. These functions can be accessed using 
the pop-up menu in the formula bar entry area.

Note that the Cell name hierarchical menu provides direct access to 
user-named cell names and the Database hierarchical menu allows 
making direct reference to table fields in your database.

Mathematical 
functions

Sum Sum (number1;number2...) or Sum (interval1;interval2...) returns the 
sum of the numbers of the selection.
The selection can be continuous or discontinuous.
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Average Average (number1;number2...) or Average (interval1;interval2...) returns 
the average value of the selected cells.
The selection can be continuous or discontinuous.
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Min Min (number1;number2...) or Min (interval1;interval2...) returns the 
minimum value among the values of the selected cells.
The selection can be continuous or discontinuous.

Max Max (number1;number2...) or Max (interval1;interval2...) returns the 
maximum value among the values of the selected cells.
The selection can be continuous or discontinuous.

Abs Abs (TheDigit) returns the absolute value of TheDigit. Abs returns 
TheDigit without the preceding + or - symbol.

Rounding Rounding (TheDigit;NumDecimal) returns the rounded number of 
TheDigit with a precision equal to NumDecimal.

SquareRoot SquareRoot (TheDigit) returns the square root of TheDigit. TheDigit must 
be positive or null, otherwise 4D View returns an error message.

Log Log (TheDigit) returns the base e logarithm (also called natural 
logarithm) of TheDigit. TheDigit must be greater than 0, otherwise 
4D View returns an error message.

Exp Exp (TheDigit) returns the exponential for TheDigit.

Random Random sends back a random number between 0 and 0,9999999...

Count Count (Interval) returns the number of non-empty cells found in 
Interval. 

Variance Variance (number1;number2...) or Variance (interval1;interval2...) returns 
the variance of selected cells.
The selection can be continuous or discontinuous.

StdDeviation StdDeviation (number1;number2...) or StdDeviation (interval1;interval2...) 
returns the standard deviation of a population based on a sample of 
this population.
Standard deviation is a measure of the dispersion of values in relation 
to the average (average value).
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number1, number2,... represent the numeric arguments corresponding 
to a sample of the population. You can also substitute a single matrix 
or a matrix reference to arguments separated by semicolons. 
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Logical values, such as True and False and the text are ignored.

The StdDeviation function works on the hypothesis that arguments 
represent only a sample of the population. The standard deviation is 
calculated using the “without bias” method, or “n-1”. The StdDeviation 
function uses the following formula:

String functions

String String(TheDigit;{TheFormat}) returns a string of characters composed of 
TheDigit numbers formatted according to TheFormat.

This function also applies to dates. 

When a numeric or date value has been converted into a string, 
4D View considers it as a character type string. 

SubString SubString (TheString;StartingFrom{;Length}) returns a string of 
characters composed of characters from TheString starting from the 
StartingFrom character and with a number of characters equal to Length.

If StartingFrom is greater than the length of TheString, SubString does 
nothing. If Length is omitted, SubString returns all characters starting 
from the StartingFrom character.

Length Length (TheString) returns the number of characters of TheString.

Find Find (value_to_find;interval_to_search;return_interval) searches for a 
value in an interval and returns the corresponding value used in the 
return interval. 

value_to_find must contain the reference of a cell that actually contains 
the value to find. 

Search interval must be sorted since Find uses the first value higher or 
equal to the value set as value_to_find.

nΣx
2 Σx )2(–

n n 1–( )
----------------------------------
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▼ Example: 
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“3”, located in the A8 cell, is the value to find. B1:B6 is the interval to 
search. C1:C6 is the return_interval. The B3 cell contains the value to 
find. The corresponding value in the return interval is in the C3 cell, 
that is, “697”.

Logical functions

If If (logic_test; value_if_true; value_if_false) returns value_if_true if the 
result of logic_test is true and value_if_false if the result of logic_test is 
false.

Use If to run conditional tests on values and formulas of cells. The 
result of logic_test determines the value returned by the function If. 
value_if_true and value_if_false can contain any value. If can be called 
several times in the same method to run more complex tests.

▼ Example: You want cell B1, giving the value of Sales, to be equal to 
250. The function:

=If(B1<200;”Declining result”;”Good result”) 
write “Good result” in the cell.

And And(logical_value1; logical_value2;…; logical_valueN) returns True if the 
evaluation of all the parameters is true. 

And returns False if the evaluation of at least one of the parameters is 
false. 

Or Or (logical_value1; logical_value2;…; logical_valueN) returns False if the 
evaluation of all parameters is false. 

Or returns True if the evaluation of at least on the parameters is true.

True True always returns True.
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False False always returns False.

Not Not (logical_value) returns the opposite of the logical value passed as a 
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parameter.

No(True) returns False.
No(False) returns True.

Empty Empty (Cell) tests if a cell is empty or not.

▼ Example:

=If(Empty(A1);”Error”;0) 
write “Error” if A1 is empty.

Date and time 
functions

CurrentDate CurrentDate returns the current date.

CurrentTime CurrentTime returns the current time.

AddToDate AddToDate(date; day_increment; month_increment; year_increment) 
increments a date value depending on the values passed as parameters.

Note In 4D View, the day is the unit of measure for date, and seconds for 
time. 

Trigonometric 
functions

Pi Pi returns the value of Pi with a precision of 18 decimals.

Sin Sin(Angle) returns the sine of Angle. Angle is expressed in radians.

Cos Cos(Angle) returns the cosine of Angle. Angle is expressed in radians.

Tan Tan(Angle) returns the tangent of Angle. Angle is expressed in radians.

ArcSin ArcSin(Angle) returns the arc sine of Angle, expressed in radians. Angle 
must be included in the range -1 to +1, otherwise 4D View returns an 
error message. 
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ArcCos ArcCos(Angle) returns the arc cosine of Angle, expressed in radians. 
Angle must be included in the range -1 to +1, otherwise 4D View 
returns an error message. 
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ArcTan ArcTan(Angle) returns the arc tangent of Angle, expressed in radians.

Financial functions

CVCompound CVCompound (i;n;m) calculates the current value of a sum using the 
composed interests. 

i is the interest rate for a period, n is the number of periods and m the 
monthly payment at the end of each period. CVCompound returns the 
current value of this investment, if the monthly payments are paid at 
the end of the period. 

▼ Example: you have a loan with an 12% annual interest rate (thus 1% 
per month) over 5 months with monthly payments of 1 000 euros. 

CVCompound(1%;5;1000) = 4853,4312393251

Here is the formula for CVCompound:

CVSimple CVSimple (i;n;f) calculates the current value of a sum using single 
interest rates. 

i is the interest rate for a period, n is the number of periods and f the 
final value at the end of a period. CVSimple returns the current value of 
this investment, if the monthly payments are paid at the end of the 
period. 

▼ Example:

CVSimple(1%;5;5*1000) = 4757,328438033744

Here is the formula for CVSimple:

FVCompound FVCompound (i;n;m) calculates the final value of a sum using 
composed interests. 

CVCompound i n m );;( m
1 1 i )+( n–

–
i

------------------------------×=

CVSimple i n f );;( f

1 i )+( n
-------------------=
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i is the interest rate for a period, n is the number of periods and m the 
monthly payment at the end of each period. FVCompound returns the 
value acquired during this investment, if the monthly payments are 
1274D View User Reference

paid at the end of the period. 

▼ Example: you plan on depositing 1 000 euros each month in a savings 
account, which earns you 12% annual interest, for 35 months.

FVCompound(1%;35;1000) = 41660,275603126

Here is the formula for FVCompound:

FVSimple FVSimple (i;n;f) calculates the final value of a sum using single interests. 

i is the interest rate for a period, n is the number of periods and f the 
final value at the end of a period. FVSimple returns the current value of 
this investment, if the monthly payments are paid at the end of the 
period. 

▼ Example:

FVSimple(12%;35;35*1000)=1847986,69

Here is the formula for FVSimple:

PeriodNumber1 PeriodNumber1(i;m;p) returns the number of periods needed to 
reimburse a loan.

i is the interest rate for a period, m is the monthly payment paid at the 
end of the period and p is the current value of the loan.

▼ Example: you borrowed 6500 euros with 10.5% annual interest and 
you reimburse 166.42 euros per month.

PeriodNumber1(10.5%/12;166,42;6500) = 48

Here is the formula for PeriodNumber1:

PeriodNumber2 PeriodNumber2(i;f;p) returns the number of periods needed to 
reimburse a loan.

FVCompound i n m );;( m
1 i )+( n 1–

i
-------------------------×=

FVSimple i n f );;( f 1 i )+( n×=

PeriodNumber1 i m p );;( m 1 p×–( ) m⁄( )log
1 i )+(log

-------------------------------------------------=
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i is the interest rate for a period, f is the acquired value of the loan and 
p is the current value of the loan.

▼ Example: you borrowed 3000 euros with 10.5% annual interest and 
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you know that the total monthly payments will be 5000 euros.

PeriodNumber2(10.5%/12;5000;3000) = 58

Here is the formula for PeriodNumber2:

Rate1 Rate1 (n;m;p) returns the interest rate corresponding to these values.

n is the number of periods, m is the monthly payment paid at the end 
of the period and p is the current value of the loan.

▼ Example: you borrowed 3000 euros and your monthly payments are 
1 000 euros over 5 months.

Rate1(5;1000;3000) = 0.19

Here is the formula for Rate1:

Rate2 Rate2 (n;f;p) returns the interest rate corresponding to these values.

n is the number of periods, f is the acquired value and p is the current 
value of the loan.

▼ Example: you borrowed 2800 euros and your monthly payments are 
6 000 euros over 5 months.

Rate2(5;6000;2800) = 0.16

The following is used to solve Rate2; if it does not converge, 4D View 
returns an error:

MonthlyValue MonthlyValue(i;n;p) returns the value of the monthly loan payments. 

i is the interest rate for a period, n is the number of periods and p is the 
current value of the loan. 

PeriodNumber2 i f p );;( f p⁄( )log
1 i )+(log

-------------------------=

i m 1 1 i+( ) n–
–( )×

p
---------------------------------------------=

un 1+

m 1 1 un+( ) n–
–( )×

p
-------------------------------------------------=
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▼ Example: you borrowed 6500 euros over 48 months with 10.5% inter-
est.

MonthlyValue(10.5%/12;48;6500) = 166,42
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Here is the formula for MonthlyValue:

Cell references 
(functions)

Type Type (value) returns the value type as a character. Use the Type function 
when the execution of another function depends on the type of value 
contained in a specific cell.

The Type function is particularly useful when calling functions that 
accept different types of data. Use the Type function to see the type of 
data returned by a function.

value can be any value accepted by 4D View, for example, a number, 
text, logical value, etc.

FindCell FindCell (value_to_find;search_range) searches for a value in a range of 
cells and returns the reference of the cell in which the value was found. 
This internal reference cannot be displayed; it can only be used by 
other functions that accept a cell reference as parameter. If the search 
is unsuccessful, an error is returned. 

value_to_find must contain the reference of a cell that actually contains 
the value to find. 

MonthlyValue i n p );;( i

1 1 i )+(–
n–

------------------------------=

If the value argument is: Type returns:

Number N
Text S
Date D
Time H
Date and time T
Picture P
Boolean B
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▼ Example: Assuming cell C3 contains 10.

=FindCell(C3;A1:B9)
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... returns 10 if the value is actually found in the A1:B9 cell range, 
otherwise it returns an error.

Column Column{(reference)} returns the column letter of reference. The reference 
argument can be a cell or a range of cells.

If the reference argument is omitted, the default argument is the 
reference of the cell in which the Column function is placed.

▼ Example: Assuming cell C3 contains 10, as well as cells A4 and B2.

=Column(FindCell(C3;A1:B9))

... returns column A. The search starts from cell A1 to A9, then B1, etc. 
Searches stop when the search value is found. 

Row Row{(reference)} returns the row number of reference. The reference 
argument can be a cell or a range of cells.

If the reference argument is omitted, the default argument is the 
reference of the cell in which the Row function is placed.

▼ Example: Assuming cell C3 contains 10, as well as cells A4 and B2.

=Row(FindCell(C3;A1:B9))

... returns row 4. The search starts from cell A1 to A9, then B1, etc. 
Searches stop when the search value is found. 

Cell Cell(cell1) returns the contents of cell1. The cell1 parameter 
(mandatory) is a character string. This function allows referencing a 
cell in an absolute manner, equivalent to $A$1.

▼ To obtain the value contained in cell A1:

=Cell ("A1") 

... returns the contents of cell A1
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▼ Cell A1 contains the string C10. If you enter the following function in 
cell B2:

=Cell(A1)
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...the function returns the value contained in cell C10. If the string 
contained in cell A1 is modified, the function will return the value of 
the new cell “pointed” by cell A1.

▼ Cell A1 contains the string C10. If you enter the following function in 
cell B2:

=Column(Cell($A$1))

...the function returns C. If the string contained in cell A1 is modified, 
the function will return the name of the new column “pointed” by cell 
A1.

Range Range (cell1; cell2) returns the internal reference of a range of cells 
(reference cannot be displayed but can be used by other 4D View 
functions). The cell1 and cell2 parameters are character strings.

▼ Examples:

=Column(Range ("A1";"A3"))

... returns column A.

=Row(Range ("A1";"F1"))

... returns row 1.

Area Area returns the identifier, Longint type, of the 4D View area in which 
this function is used.

Eval4D Eval4D(“4DCommand”) executes a 4th Dimension command.

This extremely powerful command allows you to perform any 
operation not only by calling 4th Dimension commands but also with 
methods that you have created or plug-ins.

Suppose that you want to call the 4D command BEEP and hear a beep 
every time 4D View recalculates your spreadsheet. Simply write: 
=Eval4D("BEEP").
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When you use Eval4D and quotation marks, you are in 4th Dimension. 
You will not be able to make reference to a cell in the spreadsheet 
because, at this level, 4th Dimension cannot recognize it. In this case, 
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you can use an alternative syntax: call the 4D command directly, as if 
it was a formula:

=Name_of_4D_Command(A1)

For example, to return in cell A1 the number of the month written in 
cell B1, directly use the 4th Dimension function Month of preceded by 
the equal sign, in cell A1: 

=Month of(B1)

In this manner, you can also call a method created in 4th Dimension. If 
you created a method called Factorial, directly input the name of this 
method, preceded by the equal sign, in the 4D View edit area: 

=Factorial(10)
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One of the most powerful features of 4D View is its ability to call and 
use data from 4D database fields.

4D View provides three levels of interaction between database data and 
the content of cells in your spreadsheets:

■ Import data: 4D View imports into cells the current values of 4D fields 
at the moment they are imported. No dynamic link is kept—once the 
import is completed, cells contain static values.

■ Dynamic referencing: 4D View inserts field references into cells or for-
mulas and uses their current value. If the referenced data is modified in 
4th Dimension (new field value, modification of the current selection, 
etc.), the spreadsheet automatically reflects any changes.

■ Dynamic linking: In this case, data from the database and data written 
in the spreadsheet are closely linked. When a dynamic link is created 
between a 4D field and a cell, any changes made in one of two envi-
ronments (4th Dimension database and 4D View spreadsheet) is imme-
diately made in the other. 

You can select which type of interaction to use depending on your 
needs and the interface that you wish to use.

Note Interactions between 4th Dimension and 4D View are not limited to 
database data: 4D View can use any 4th Dimension command, 
function or method. For more information on this, refer to the chapter 
“Formulas, Operators, Operands and Functions” on page 113 and to 
the 4D View Language Reference manual.



Chapter 7  Using 4D objects

Importing data
Importing data is the first level of interaction between a 4th Dimension 
database and a 4D View spreadsheet. Once the import is done in your 
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4D View area, there is no dynamic link with the data. If you modify 
the values of the fields imported in 4D, your spreadsheet will not 
reflect any of these changes.

4D View allows you to import two types of data in your spreadsheet:

■ Values of fields in the database,

■ Quick reports.

Importing Fields The Import Field... command in the Database menu allows you to dis-
play values from the current record selection in a 4D View area.

You can work with any records of any table, whether you use 4D View 
in an external window (in a window created from the Tools menu) or 
included in a form of this table. 

❿❿❿❿ To import fields in your spreadsheet:

1 Select the cell into which you will import fields.
The selected cell is considered as the entry point for the import: 
imported values will be inserted toward the bottom, starting from this 
cell. If you import several fields, additional fields will be added in the 
columns to the right of this cell.

2 Choose the Import Field... command from the Database menu.
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The “Choose fields” dialog box appears:

Menu of database 
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By default, a first import row is displayed, which contains the name of 
the first field of the first table.

3 Click on the row.
A hierarchical pop-up menu appears displaying all tables and fields of 
the database.

4 Select the table and then the field to import in the hierarchical menu.

5 If you wish to import an additional field, select the table containing 
the field to import from the menu located at the top of the window.

6 Click the New button to create a new import row.

7 Repeat steps 3-6 for each new row.
Each field will be imported in a new column in the 4D View area.

tables
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You can also modify the import list using the following commands:

■ Delete: Remove the selected row.

■ Copy: Copy the content of the selected row into memory.
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■ Paste: Replace the selected row with the row stored in memory 
using the Copy command.
The Copy/Paste combination allows you to add several rows whose 
content varies only slightly.

■ Delete all: Removes all previously-defined rows.

8 If you wish to create a sub-selection of records before importing 
values, select the import row and click the Find... button.
By default, if you do not perform a search, all values belonging to the 
current selection of the selected table will be displayed in the 4D View 
area.

When you click the Find... button, the 4th Dimension Query editor 
dialog box appears allowing you to define the records to import:

Note For more information on this dialog box, refer to the 4th Dimension 
User Reference manual.

9 If you wish to sort the selection of records to import, select a row and 
click the Sort... button.
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By default, if you do not perform a sort, the imported values will be 
displayed in the order of the current selection.

When you click the Sort... button, the 4th Dimension Order by dialog 
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box appears allowing you to set the order of the records to import:

Note For more information on this dialog box, refer to the 4th Dimension 
User Reference manual.

10 Once the import list has been set, click on the Import button: 

List of fields to import

Import button



Chapter 7  Using 4D objects

The current values of the selection are then inserted into the 4D View 
area:.
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You can see that the values are pasted “as is” in the area; no references 
are included. Once the data has been imported, the values located in 
the 4D View area and those in the fields are completely independent. If 
you select the References command in the View menu, the imported 
data is not modified.

Importing Reports The Import Report... command in the Database menu allows you to 
display, in a 4D View area, values from calculations made in the 
current record selection. These values are imported using a quick 
report that can be loaded from your hard drive or created. 

Note For more information on quick reports, refer to the 4th Dimension User 
Reference manual.

As with the previous command (see the paragraph “Importing Fields” 
on page 134), the result of this import is not dynamically linked to 
data. It is simply a “photograph” of the data at the moment it is 
imported.

The interest of using quick reports in a 4D View area is in their ability 
to save to disk and load report parameters, to include aggregate 
calculations (mean, sum, etc.), styles, etc.

1st import row

2nd import row

3rd import row
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Unlike with importing fields, importing reports does not allow you to 
directly modify the current selection of tables during an operation 
using a search. You need to make sure that the current selection 
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contains the data to import.

❿❿❿❿ To import a report in your spreadsheet: 

1 Set the current selection of 4D records whose values you wish to use.

2 Select the cell from where you will import the report.
The selected cell is considered as the entry point for the import: 
imported values will be inserted toward the bottom, starting from this 
cell. If you import several columns, they will be added in the columns 
to the right of this cell.

3 Select Import Report... from the Database menu.

A dialog box appears listing the tables of the database:
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4 Select the table to apply the imported report.
The quick report editor allows creating of reports using the fields of a 
table as well as possibly those of linked tables (if the link is automatic).
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5 Define your report using the 4D Quick report editor.
For more information on this editor, refer to the 4th Dimension User 
Reference manual.

4D View allows you to use any 4D Quick report editor functions:

■ Any type of rows, including headers, footers, page breaks,

■ Hidden rows or columns (do not appear in imported columns),

■ Calculations (sum, mean, etc.)

■ Columns calculated using the 4D formula editor1,

■ Sort and repeated values options for columns.

Note Columns are not automatically resized when importing a report.

■ Character styles. 

1. Calling methods or specific commands from the formula editor requires a 
specific configuration. For more information about this, refer to the descrip-
tion of the SET ALLOWED METHOD  command in the ans le manuel 
4th Dimension Language Reference manual. 

Hidden row

Right alignment

Calculations
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6 Select 4D View in the File>Destination sub-menu of the Quick Report 
editor.
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7 Choose Generate... in the File menu of the Quick Report editor to 
generate the report.

The 4D View area now displays the report:

You can now modify the appearance of the area or the inserted values. 
As when importing fields, the values are pasted “as is” in the area, no 
references are included.
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Saving and loading the 
report

The parameters of the last generated report are kept throughout the 
session. If you wish to save the report, select the Import Report... 
command and then choose the Save or Save as... commands in the 
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4th Dimension File menu. To open the report later on, simply use the 
Open... command to load a previously saved report.

Dynamically Referencing Fields
Dynamically referencing fields allows a higher level of interaction 
between 4th Dimension and 4D View.

This consists of inserting a field reference in your cells, either directly 
(cell value) or inside a formula used to calculate the value of a cell. 
For inserting images (Add pictures... command), the reference is not 
attached to a cell but to the entire spreadsheet.

When displaying a 4D View area, this reference is replaced by the 
current cell value. A dynamic link is kept between the area and the 4D 
data: if the value of the field is changed, the 4D View area will use the 
new value. 



Dynamically Referencing Fields

This behavior is particularly useful in cases where included areas use 
document templates: simply insert field references in the template, the 
values will be automatically updated when viewing records:
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Note For more information on document template, refer to the paragraph 
“Saving a document as a template” on page 71.

Field reference

Database field

4D View area saved 
as a template



Chapter 7  Using 4D objects

❿❿❿❿ To insert a 4th Dimension field reference in a 4D View area:

1 Select the cell where you will insert the field.

2 In the 4D View formula bar input area, insert the “=” character.
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Inputting the = character is necessary when you insert a direct field ref-
erence (the cell displays the current content of the field).
When you insert a field reference within a formula, the = character is 
no longer required.

3 In the same area, right-click or Control+Click (under Mac OS only).
The hierarchical pop-up menu of formulas and references appears. The 
Database command lists all tables and fields of the database.

4 Choose the Database command, then the table and the field to insert:

5 Validate your selection by holding down the Enter key or by clicking 
the validate icon in the formula bar.

The field reference is then inserted in the cell or the formula as 
[TableName]FieldName].

If a current record is defined in the table, the current value of the field 
replaces the reference in the call, unless you have deselected the 
Automatic Calculation command in the Tools menu of the area (see the 
paragraph “Calculating Dynamic References” on page 162).

Referenced field

The cell is immediately filled with the 
data of the field of the current record

Direct reference

Referenced field

The cell is immediately filled with the 
result of the formula

Function

Reference used in 
a formula
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Inserting Pictures The Add pictures... command in the Database menu allows insertion 
of a 4D picture reference in your spreadsheet, which comes either from 
a field, a variable or the Picture library.
1454D View User Reference

The inserted reference is not linked to a cell but to the entire 
spreadsheet. However, you can modify its display using the “Pictures 
Attributes” dialog box. This dialog box is detailed in the paragraph 
“Using Pictures” on page 105.

❿❿❿❿ To insert an picture field reference:

1 Select the Add pictures... command in the Database menu.

The following dialog box appears:

The Field tab displays the list of database tables containing at least one 
Picture field.

2 To insert a Picture field reference, expand the table containing the 
field and select it (see step 5).
OR
To insert an Picture reference from a 4D expression, click on the 
Expression tab.

Expression tab
Field tab



Chapter 7  Using 4D objects

The following page appears:
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3 Click on the Edit... button
The 4th Dimension formula editor is displayed:

This editor displays a list of database fields, a list of operators and a list 
of 4D commands that are allowed in formulas by default. 
This third list also contains, where applicable, the names of project 
methods that are “allowed” in formulas. If you want for the 4D View 
user to be able to use project methods, you must declare them 
explicitly using the SET ALLOWED METHODS command. Similarly, if 
you want for the user to be able to access 4D View commands or 4D 
commands that are not allowed by default, you must create and allow 
project methods that specifically call these commands. For more 
information, refer to the 4th Dimension Language Reference manual. 
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4 Enter a formula and click OK.
You must enter a formula returning a Picture type expression. For more 
information on the formula editor, refer to the 4th Dimension User Ref-
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erence manual.

5 Validate the “Select an image field” dialog box by clicking on the OK 
button.
The picture reference is inserted in the spreadsheet.

You can move it or resize it using your mouse. You can also modify its 
properties by double-clicking on it.

To remove an image reference, select it and then hold down the Return 
or Del key. 

Viewing Field 
References

You can view field references inserted in your 4D View area at any time 
(as well as other dynamic references): select the References command 
in the View menu. All inserted references appear in the area:

Field References in 
External Windows

You are perfectly able to insert field references in 4D View areas in an 
external window. The value of the current record of the referenced 
table (opened in its own window) is used.

However, in this environment, you will need to keep in mind the 
following:

■ When the table of the referenced field does not contain a current 
record, 4D View displays an error message in the cell containing the 
reference: “error: this field does not exist.”
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■ If the current value of the field is modified while the 4D View window 
is in the foreground, the redrawing of this window is not automatic: it 
must be provoked using the Calculate now command in the Tools 
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menu, or the PV REDRAW language command.

Dynamic Links
4D View allows, without programming, establishing of a direct 
connection between a 4D View area and 4th Dimension. Once this 
connection or link has been established, there is in an interdependence 
between the two environments: the link acts upon the selection.

During link creation, the values of the current selection determine 
those of the linked cells. Later on, one will influence the other and 
vice-versa.

4D View allows defining of four types of dynamic links:

■ Link between a cell and a 4D field,

■ Link between a cell and a 4D variable,

■ Link between a column and a 4D field,

■ Link between a column and a 4D array.

Linking Cells to 
Fields or Variables

When you link a cell to a field or a variable, the modification of the 
cell content is reflected in the field linked to the current record or the 
value of the linked variable.

This mechanism also works in the other direction: any modification of 
field or variable values linked to cells, or changes in the current record, 
cause modification of the linked cell content.

This feature is particularly useful for user interfaces based on arrays.

Defined links are saved at the same time as the 4D View area. They 
remain active for the area as long as they are not removed.

Creating a cell link You can link a cell to a field or a variable of the 4D database. In this 
case, the 4D View area will display the current value of the field or the 
variable. Any changes in this value in 4D will be immediately made in 
the 4D View area. Conversely, the linked cell remains enterable: any 
modification made to the value of the cell will be made in 4D.
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❿❿❿❿ To link a cell to a field or a variable:

1 Select the cell to link (if you wish to link the current cell).

2 Select the Linked Cells... command in the Database menu.
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The linked cells management dialog box appears:

You can link either the selected cell (current cell) or a cell whose 
reference you may enter.
By entering the cells reference, you can simultaneous create as many 
links as desired.

3 If you do not want to create a link with the current cell, click on the 
Cell button.
An additional field appears, allowing you to enter the cell to link:

You must enter the coordinates of the cell as LetterColumnRowNumber, 
for example, “E12”.

4 If you want to create a cell/field link, click on the Field button.

Input area for cell coordinates
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An area displaying the list of tables and fields of the database appears, 
allowing you to set which field to link to the cell:
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You can link any type of 4D field to a cell, with the exception of BLOB 
type fields.

OR
If you want to create a cell/variable link, click the Variable button.
In this case, an input area appears, allowing you to enter the name of 
the variable to link:

You can use any type of variable process or interprocess, with the 
exception of BLOB type variables.
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If you create a link in a 4D View area in an external window, you must 
use interprocess variables (variables whose name starts with the <> 
character).
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Notes • Array type variables cannot be used.
• For more information on variables, refer to 4th Dimension 
documentation.

5 Click the Add button to create the link:

Note The right side of the window does not display the links of columns 
that may already be defined for the area (see the paragraph “Linking 
Columns to Fields or Arrays” on page 154). If you try to create a field 
link in a cell already used for a column link, 4D View does nothing.

6 Repeat steps 3-5 as many times as necessary.

The A2 cell is linked to the 
Musician Name field
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You can simultaneously define cell/field links and cell/variable links in 
the same 4D View area:
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7 Validate the dialog box using the OK button.
The linked cells are then filled with the values of fields of the current 
record of the selected table, or with the values of variables whose name 
you entered:

Note No value appears if there is no current record in the defined table or if 
the linked variable does not exist.
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You can see that the input area of the 4D View formula bar displays the 
value contained in the cell, and not a reference:
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This value can be modified: any modification is carried out in the 
linked field as soon as the cell is validated: 

To view links in a spreadsheet (as well as other dynamic references), 
select the References command in the View menu. The links appear as 
follows:

Modified value

Cell linked to the
Musician name field

Cell linked to the Age 
variable
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Removing a cell link If you want to unlink certain cells from your database:

1 Select the Linked Cells... command in the Database menu.

2 In the list of linked cells, select the row containing the link that you 
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would like to remove.

3 Click the Delete button.

4 Validate the dialog box using the OK button.

Note You can also apply the Delete... command or Clear>Formulas in the 
Edit menu to a linked cell to remove the link.

Linking Columns to 
Fields or Arrays 

As with the links described above, the columns/fields and 
columns/arrays links allow creation of dynamic relations in both 
directions between a 4D View area and 4D database data: any 
modifications of linked cell content is immediately carried over to 
4th Dimension and vice-versa.

This type of link allows filling of several rows of the 4D View area:

■ If you create a column/field link, the values of all current selection 
records are inserted in the column.

■ If you create a column/array link, all elements of the array are inserted 
into the column.

The two types of column links cannot be mixed in the same area. The 
Linked columns command in the Database menu in 4D View indicates 
the use of a checkmark if a certain type of link already exists in the 
area:

Unlike cell links, you cannot choose the location of linked columns in 
the 4D View area: the first linked column is column A, the next is 
column B, and so on. Linked column values also start in row 1. Once 
the link is defined, a row cannot be inserted or removed using 4D View 
commands. For more information on this, refer to the paragraph 
“Using linked columns” on page 161.

Defined links are saved at the same time as the 4D View area. They 
remain active for the area as long as they are not removed.

A column/field type link already exists in 
the area
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Creating a column/field 
link

❿❿❿❿ To link a column to a field:
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1 In the Database menu, select the Linked Columns then Fields 
commands.

The linked columns management window appears:

2 In the list of tables, select the table you want to create a dynamic link 
with.

3 Click on the field to which you will link values.
You can use any type of 4D field, except for BLOB type fields.

4 Click on the Add button.

List of tables

List of fields of 
the selected 
table
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The defined link is displayed in the right side of the window:
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Note The right side of the window does not display cell links that may 
already be defined for the area (see the paragraph “Linking Cells to 
Fields or Variables” on page 148). If the column used contained a 
linked cell, the latter is moved below the inserted column.

5 Repeats steps 2-4 as many times as necessary.
Additional linked columns will be columns B, C, etc. You may not set a 
column used for a link.

Different linked columns must contain the same number of values. If 
you set several links with tables not having the same number of 
current records, 4D View will display the number of values contained 
in the smallest selection for each column.

6 Click OK to validate the dialog box.

The AlbumTitle field is 
linked to column A
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Linked columns are then filled with the values of fields of the current 
selection:
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Note No value appears if there is no current selection in one of the linked 
tables.

As with linked cells, the input area of the 4D View formula bar displays 
the value contained in each cell, and not a reference.
Also, any value can be modified; any modifications are made in the 
field of the linked record as soon as the cell is validated. 

4D User 
environment 
window

External 4D 
View window
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To view the links of columns in a spreadsheet (as well as other 
dynamic references), select the References command in the View 
menu. Columns links appears as follows:
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Creating a column/array 
link

4D View allows you to link columns of your spreadsheet to 
4th Dimension arrays. 4D arrays are language objects that can store a 
large number of variables as an array. For more information on arrays 
in 4th Dimension, refer to the 4D Language Reference manual.

In order to be able to link a column to an array, the array must exist in 
the process managing the 4D View area. 

❿❿❿❿ To link a column to an array:

1 In the Database menu, select the Linked Columns and then Arrays 
commands:
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The linked column management window then appears:
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2 In the left side of the window, enter the name of the 4D array to link 
to column A of the area.

You can use any type of process or interprocess array, with the 
exception of pointer type arrays. If you create a link from a 4D View 
external window, you must use interprocess arrays (arrays whose name 
starts with the <> character).

3 Click the Add button.
The defined link is displayed in the right side of the window:

The TitlesArray array is 
linked to column A
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Note The right side of the window does not display links of cells that may 
already be defined in the area (see the paragraph “Linking Cells to 
Fields or Variables” on page 148). If the column used contained a 
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linked cell, the latter is moved below the inserted column.

■ Two-dimensional arrays 
You can use two-dimensional arrays. For this, you must enter the 
arrayName{NumCol} syntax in the array name area. For example, for a 
2D array named myArray, enter myArray{1}, click on Add then enter 
MyArray{2} and click Add. Each “column” of the 4D array will also be 
inserted into a column of the 4D View area.

4 Repeat steps 2-4 as many times as necessary.
Additional linked columns will be columns B, C, etc. You may not set a 
column used for a link.

Different linked columns must contain the same number of values. If 
you define several links in the same area with arrays not containing 
the same number of elements, the links will not work correctly.

5 Click on OK to validate the dialog box.
Linked columns will then be filled with array values:

Array data

Columns linked 
to arrays
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Note In the above example, array data was placed in a scrollbar area for 
example purposes only.
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4D View inserts nothing if there is no linked array in the same 4D 
process.

As with linked fields, the 4D View formula bar input area displays the 
value contained in each cell, and not a reference. Also, any value can 
be modified; any modifications are made in the element of the 
corresponding array as soon as the cell is validated and vice-versa. 

To view column links in a spreadsheet (as well as other dynamic 
references), select the References command in the View menu. The 
columns/arrays links appear as follows:

Using linked columns Data links allow modification of the values of 4D records or array 
elements from the spreadsheet.

However, you cannot remove 4D records or array elements from the 
spreadsheet, for example by removing a row inserted in the 4D View 
area. The corresponding commands (Delete, Cut) are dimmed in the 
Edit menu and in the 4D View toolbars.
Removing records or array elements is done from the data source, in 
other words, the 4th Dimension application.
It is, however, possible to erase the content of one or more cells using 
the Clear command in the Edit menu.
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Also, you cannot add 4D records or array elements using the 
spreadsheet, for example by inserting a row in the 4D View area. The 
corresponding commands are dimmed in the Insert menu and in 
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4D View toolbars. The addition of records or array elements is done 
from the data source; in other words, the 4th Dimension application.

Sorts cannot be performed directly in columns inserted in the 4D View 
area. These operations must be done in the data source; in other words, 
the 4th Dimension application. 

Finally, if you want to remove one or more column links in the area:

1 In the Database menu, select Linked Columns then the submenu set 
off with a checkmark.
The checkmark indicates what kind of column link is active in the 
area.

2 In the list of linked columns, select the row containing the link that 
you would like to remove.

3 Click Delete.
OR
If you want to remove all column links, click on the Delete all button.

4 Validate the dialog box using the OK button.

Calculating Dynamic References
A number of calculations are executed when working with a 
spreadsheet. The more calculations within the spreadsheet, the more 
time it will take for the changes to take effect in the cell, since the cell 
serves several operations.

4D View provides you with two ways of updating references in your 
documents: automatically and manually. 

Automatic 
calculation

This is the default option for all new 4D View spreadsheets. When this 
option is selected, 4D View calculates your set of spreadsheets every 
time data is entered.
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Select the Automatic Calculation menu command from the Tools menu 
to select/deselect this option (a check mark appears in front of the 
command when activated).
1634D View User Reference

Calculate Now If you want to start recalculation at any desired moment or to “force” 
an area redraw, select the Calculate Now command from the Tools 
menu.

Freeze References Once calculations are complete and you no longer want your 
spreadsheet to be dynamic, select the Freeze References menu 
command in the Tools menu. All references will be frozen, which 
means that your cells will keep their current data but not their 
formulas, field references or 4D variables, dynamic links, etc. 

Note Once you freeze references, ALL references are frozen, including 
functions unique to 4D View such as Sum, Length, True, etc.
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Printing 4D View documents is handled using six commands in the 
File menu, which are described in this chapter:

■ Print Area

■ Print Options...

■ Page Setup...

■ Print Preview...

■ Print Document...

■ Print Formulas...

Print Area
The print area may contain all information in a spreadsheet or just a 
portion. To set your print area, simply select the cells that should be 
printed.

A different print area can be set for each of your 4D View documents.

A 4D View document can only have one print area.

Note If no print area is set, the entire spreadsheet will be printed by default.
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Setting the print 
area

❿❿❿❿ To define the print area for the spreadsheet:
166 4D View User Reference

1 Select the cells, rows, or columns to print.

2 Choose the Print Area command, then Set, in the File menu.
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Viewing the print 
area

❿❿❿❿ To view a previously set print area:
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1 Choose the Print Area command, then Show, in the File menu.

Deleting the print 
area

❿❿❿❿ To delete an existing print area:

1 Choose the Print Area command, then Clear, in the File menu.
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Print Options...
To define print options, select Print Options... in the File menu.
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The following dialog box appears:

Page headers and 
footers

For page headers and footers, you can add the text of your choice 
which will be printed to the left, in the center, to the right or all three.
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Options You can set whether or not to print various additional elements:

■ Row and Column Titles,
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■ Display a grid for cells.

■ Frame Each Page.

Also, you can set two print centering options.

■ Centered Printing: allows centering the print area within the page.

■ Adjust Printable Area: sets the area to print in relation to the non-
empty cell in the bottom-most right part of the document.

Margins In this area, set the margins for the print job.

Note Keep in mind the authorized print area for your printer.

Repeat You can specify a range of rows and columns to be repeated on each 
page during printing.

Page Setup...
The Page Setup... command in the File menu is used to set printing 
parameters for the current printer.
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The standard printer setting dialog box for your computer appears. 
This dialog box varies depending on the installed printer drivers and 
operating system.
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Parameters entered in this dialog box, such as paper size and print 
percentage, determine the amount of information that can be printed 
per page.

Once parameters have been set, click the OK button to validate them.

Print Preview...
The print preview feature displays a reduced version of each printed 
screen on your monitor. You can zoom in on a page area using the 
drop-down menu. This feature allows you to view with precision what 
will actually be printed.

Page Setup... dialog box (Win-
dows)
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For this, select the Print Preview... command in the File menu:
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The print preview dialog box allows you to print the page that is 
currently being viewed, to stop viewing pages in your document and 
to go to the next/previous page.
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Print Document...
The Print Document... command in the File menu allows you to start 
printing an entire, or part of, a document, depending on the parame-
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ters set using the Print Area, Print Options... and Page Setup... com-
mands.

Print Formulas...
The Print Formulas... command in the File menu prints only formulas 
in the spreadsheet.

In this case, the document is printed as a list of cells containing 
formulas as well as the label of these formulas.

This print job respects the existing print area as well as parameters set 
in the “Printing Options” dialog box.
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4D View allows exporting of data in several formats. This feature lets 
you exchange documents between 4D View and other applications.

4D View documents can be exported entirely or partially. Portions of a 
document can be exported once an export area has been set.

Export Area
A different export area can be set for each 4D View document.

A given 4D View document can only have one export area.

Note If no export area is set, the entire spreadsheet will be exported by 
default.
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Setting the export 
area

❿❿❿❿ To set the export area for a spreadsheet:
174 4D View User Reference

1 Select the cells, rows or columns to be exported.

2 Choose the Export Area command, then Set, in the File menu.
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Viewing the export 
area

❿❿❿❿ To view a previously set export area:
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1 Choose the Export Area command, then Show, in the File menu.

Deleting the export 
area

❿❿❿❿ To delete an existing export area:

1 Choose the Export Area command, then Clear, in the File menu.
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Exporting Data
4D View provides three export formats. Select a format in the export 
dialog box, which is accessible using the Export... command in the File 
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menu.

HTML Document 
(*.htm)

This format publishes data from a 4D View area onto your Intranet site 
or on the Web.

Complete HTML pages can be created from 4D View area data, from a 
previously defined export area, or by inserting data from 4D View areas 
into existing HTML pages.

Under Windows, the extension for this type of document is “.HTM”.

Export format selection 
menu

Exported 4D View area Display of HTML export in a Web browser
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Tab Formatted Text 
(*.txt)

In this format, basic data from the spreadsheet is saved. The export file 
is generated as a text file.
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Columns are separated by Tabs and going on to the next row is done 
using a Carriage return.

Under Windows, the extension for this type of document is “.TXT”.

SYLK 2.0 document 
(*.txt)

This format is used for spreadsheet exchanges between applications. It 
is used most notably by Microsoft® Excel®.

Note 4D View formulas are not yet written. Only values and their 
appearance are kept — in the event that they have a match in 
Microsoft Excel.

Under Windows, the extension for this type of document is “.TXT”.
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